Team Fortress 2
This topic has been locked
Kangaroo Jack Apr 26, 2013 @ 2:22pm
"You must enable Steam Community In-game to use the Mann Co. Store"
The title above is the message I got after trying to use the Mann Co. Store today. I thought that this was odd, since I never remembered turning it off for TF2. I quit the game and right-clicked on TF2 and clicked "Properties". The "Enable Steam Community In-game" tab was already checked. Thinking that this was just a one time error, I restarted TF2, with no luck. I got the same message. I then quit it again and went into Steam Settings and checked to see if it was enabled for all games. I clicked the "In-game" tab, and it was indeed already checked. This puzzled me, so I started TF2 again, with no such luck. Then Steam had to reinstall for the new update. It updated, and I thought this would fix the problem. It didnt. I just keep getting the same error no matter what options I have checked and not checked. Any answer to fix this problem is highly appreciated. Thank you for your time.
Last edited by Kangaroo Jack; Nov 6, 2013 @ 11:27am
< >
Showing 1-15 of 173 comments
I have this same error someone help us :(.
Old Man Jenkins May 17, 2013 @ 2:45pm 
I also got error, this sucks.
Old Man Jenkins May 17, 2013 @ 2:55pm 
Apparently you need to uncheck it, run game. And then recheck it for it to work
I've done the above suggestion multiple times, it doesn't work for me.
Kangaroo Jack May 17, 2013 @ 4:28pm 
Same thing with me. I unchecked it, played TF2, checked it, played TF2, its still not fixed.
Ploudo May 30, 2013 @ 10:08am 
damn, it's to prevent us from opening the crates...
Mideav Jun 2, 2013 @ 9:00am 
Well, here is what worked for me. Apparently it had to do with Don't Starve. The last time I played Don't Starve was in windowed mode (it also crashed). By opening Don't Starve again and putting it in fullscreen and exiting it without crashing fixed the problem for me. I suggest if something like this has happened, open all your games, make sure steam overlay works and that they are all in fullscreen and that they close without force or crashing.
Ri0s Jun 2, 2013 @ 1:19pm 
I'm having the same problem, but none of these suggestions have helped
(-,+,+,+) Jun 3, 2013 @ 10:52pm 
I have a solution.

I think that you have to restart steam twice. First, right click on TF2 >Properties> uncheck "Enable Steam Community...".

Restart Steam

Now check the same option and restart steam again.


Now it should be working.
garrett_oh Jun 5, 2013 @ 8:32pm 
Same issue here.
it woked gdavtor :)) thanks
Thank you gdavator!
SumoSam Jun 14, 2013 @ 4:30pm 
Originally posted by gdavtor:
I have a solution.

I think that you have to restart steam twice. First, right click on TF2 >Properties> uncheck "Enable Steam Community...".

Restart Steam

Now check the same option and restart steam again.


Now it should be working.
thank you very much! i finally bought my friend a tuxxy and opened 4 robo crates!
Grech Jun 24, 2013 @ 6:09pm 
it still didn't work for me :s
FireKeep Jun 28, 2013 @ 3:46pm 
me niether
< >
Showing 1-15 of 173 comments
Per page: 15 30 50

Date Posted: Apr 26, 2013 @ 2:22pm
Posts: 173