Funyarinba Apr 8, 2013 @ 9:42pm
TF2 lags badly.
I've been playing this game for awhile, and I have experience plenty of lag. Is there a way to make it lag less?

before any one of you say turn the game to high priority, setting the game to that is where the real lag kicks in. One time I saw a sniper at the other side of the map. I tried to run in cover, but due to control lag, it took about 3 seconds to respond to it, enough time for a sniper to get a free kill. If you know how to fix high priority, let me know.

I am running on windows 8
Showing 1-15 of 42 comments
< >
Icehat Apr 8, 2013 @ 9:56pm 
Specs?
СаН9_58 Apr 8, 2013 @ 11:44pm 
KAK CDEJIATb TAK 4TO6bI JIAGOF MENbWE 6bIJIO
Ruebezahl Apr 9, 2013 @ 1:12am 
Are you always playing on the same server? That kind of huge lag is usually caused by your connection to the server or even the server itself.

If you want to find out if your configuration is causing the lag, just create a local server and play a game against a bunch of bots. If you are lag-free, then it means your specs are fine, and you should simply try playing on other (better) servers.
Funyarinba Apr 9, 2013 @ 4:34am 
I expected better replies. :/



Originally posted by Ruebezahl:
Are you always playing on the same server? That kind of huge lag is usually caused by your connection to the server or even the server itself.

If you want to find out if your configuration is causing the lag, just create a local server and play a game against a bunch of bots. If you are lag-free, then it means your specs are fine, and you should simply try playing on other (better) servers.

Servers aren't an issue. If it was, I'd mention it.


Originally posted by W.O.O.B SomeWittyUsername:
Specs?
OS: WIndows 8 pro 64-bit
CPU
Mobile AMD Sempron 3600+
Sherman 65nm Technology
RAM
2.00 GB Dual-Channel DDR2 @ 203MHz (5-5-5-18)
Graphics
HP w2007 (1680x1050@59Hz)
ATI Radeon X1250 (Toshiba)
Hard Drives
149GB TOSHIBA MK1652GSX ATA Device (SATA)
Audio
High Definition Audio Device
Specs according to Speccy.
Rex, the lonely dinosaur Apr 9, 2013 @ 4:36am 
when did the huge lag start
Magnus | ertesda Apr 9, 2013 @ 6:46am 
Ping?
Backdraft_|BC| Apr 9, 2013 @ 6:48am 
Most likely the server, if not try defragging.
PuSsY_sLaYeR69 Apr 9, 2013 @ 7:32am 
Most likely the ping is low or terrible host.
ABlindSniper115 Apr 9, 2013 @ 7:55am 
It's probably your internet connecton. I seriously doubt that your computer is the problem. Even on my old computer, which was not a gaming computer by any means and was 6-7 years old, TF2 ran very well. So either you have a computer powered by a potato, or you have bad internet. I'm inclined to think that it's your internet.
iamthevirus Apr 9, 2013 @ 10:20am 
There are 3 types of lag (roughly) :

1) the Steam/Valve/TF2 lag : you can't help that

2) your internet : check ping. if it is under 100, you are fine (press TAB) over 200 starts to be annoying.

3) your computer :
- obviously, lower all the video settings to minimum...
- then, lower directX level from 9+ to like 8...

- by going to Steam right clicking Team Fortress 2 on left side...
- click Properties.
- click Set Launch Options.
- add this without quotes with the minuses : "-novid -high -mat_dxlevel 81"
= -novid : is just a bonus so you don't have valve video upon loading, so loads fast
= -high : I think it has something about high performance
= -mat_dxlevel 81 : lowers the directX level. yes, the game will look a tiny bit less beautiful, but it is worth it (you get used to it). don't use dxlevel 81 because you'll have to keep setting your video settings.
Funyarinba Apr 9, 2013 @ 2:11pm 
...Seriously? If I'm not talking about issues with internet connections, then why the ♥♥♥♥ would I be having problems with ping? I'm obviously talking about FPS.


Originally posted by iamthevirus -atg-:
There are 3 types of lag (roughly) :

1) the Steam/Valve/TF2 lag : you can't help that

2) your internet : check ping. if it is under 100, you are fine (press TAB) over 200 starts to be annoying.

3) your computer :
- obviously, lower all the video settings to minimum...
- then, lower directX level from 9+ to like 8...

- by going to Steam right clicking Team Fortress 2 on left side...
- click Properties.
- click Set Launch Options.
- add this without quotes with the minuses : "-novid -high -mat_dxlevel 81"
= -novid : is just a bonus so you don't have valve video upon loading, so loads fast
= -high : I think it has something about high performance
= -mat_dxlevel 81 : lowers the directX level. yes, the game will look a tiny bit less beautiful, but it is worth it (you get used to it). don't use dxlevel 81 because you'll have to keep setting your video settings.

Stop thinking that lag involves with internet, please.

And I've heard that so many times, it did not help, maybe only like about 5 FPS when I'm not in a firefight and nothing when I am in one.

High sets the game in high quality, as well as high CPU priority. I don't have this on for OBVIOUS reasons *coughinputlagcough*
Icehat Apr 9, 2013 @ 4:27pm 
Sorry to tell you this, but your graphics card is crap. According to my sources, it's very underpowered - it's built to preserve battery life and size, not performance.
http://www.notebookcheck.net/ATI-Radeon-Xpress-X1250.6946.0.html
Funyarinba Apr 9, 2013 @ 4:35pm 
Originally posted by W.O.O.B SomeWittyUsername:
Sorry to tell you this, but your graphics card is crap. According to my sources, it's very underpowered - it's built to preserve battery life and size, not performance.
http://www.notebookcheck.net/ATI-Radeon-Xpress-X1250.6946.0.html

Jeez, like I didn't even know that!

All I want to know is how to ♥♥♥♥ing fix high priority. ANY game I set on high priority includes LULINPUTDELAY. This only happens on windows 8, while all other OS are just fine.
Last edited by Funyarinba; Apr 9, 2013 @ 4:36pm
Icehat Apr 9, 2013 @ 4:37pm 
Originally posted by An Ika Musume:
Originally posted by W.O.O.B SomeWittyUsername:
Sorry to tell you this, but your graphics card is crap. According to my sources, it's very underpowered - it's built to preserve battery life and size, not performance.
http://www.notebookcheck.net/ATI-Radeon-Xpress-X1250.6946.0.html

Jeez, like I didn't even know that!

All I want to know is how to ♥♥♥♥ing fix high priority. ANY game I set on high priority includes LULINPUTDELAY. This only happens on windows 8, while all other OS are just fine.
Don't set it to high priority
Funyarinba Apr 9, 2013 @ 4:41pm 
Originally posted by W.O.O.B SomeWittyUsername:
Originally posted by An Ika Musume:

Jeez, like I didn't even know that!

All I want to know is how to ♥♥♥♥ing fix high priority. ANY game I set on high priority includes LULINPUTDELAY. This only happens on windows 8, while all other OS are just fine.
Don't set it to high priority

Makes the game playable if set to high, except the input controls
Last edited by Funyarinba; Apr 9, 2013 @ 4:41pm
Showing 1-15 of 42 comments
< >
Per page: 15 30 50
Date Posted: Apr 8, 2013 @ 9:42pm
Posts: 42