Phoenix Sep 3 @ 11:30am
Tf2 is corupted for me, please help
I've tried reinstalling it twice, but on startup I get these weird green pixels followed by what I can only describe as a rom corruptor on steroids.
Showing 1-9 of 9 comments
< >
Thunder Sep 3 @ 11:32am 
Get a screenshot.
Thunder Sep 3 @ 11:40am 
Try other games if it does the same thing then your GPU has some problems.
Phoenix Sep 3 @ 4:08pm 
I guess it is my GPU Ive tried other 3D games and it came with the same results, but I haven't done much, I dont know what could've caused this. My games have been working fine for hundreds of hours, but now they dont work anymore.
Last edited by Phoenix; Sep 3 @ 4:08pm
StunnzaJeth Sep 3 @ 4:14pm 
it must just be your GPUs time to die. Sometimes they can just break out of the blue.

It may be a long shot, but uninstall and re-install your graphic drivers. Could fix it. If not, well. Gotta get a new GPU
Phoenix Sep 4 @ 7:57am 
its a laptop so thats going to be difficult Ive scanned it and it doesnt seem to have any hardware based issues, im going to backup important files and reset my laptop
I believe its called artifacting m'friend. I used to get it on my olde laptop. I tried many things to fix it such as laptop coolerpads,thermal paste on the heatsink, reinstalls, ect. In the end, it basically means you need to upgrade your hardware within a year or two, before it totally ♥♥♥♥'s the bed.
Phoenix Sep 5 @ 11:23am 
I think the problem may lie with my steam, when I launch Terraria I get these same corruptions, but when I launch N Terraria (Modded version of regular terraria with the same if not higher requirements) it doesn't have them. Also when I launch other non-steam games they work properly as well even though they have far higher graphical requirements.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50