[invalid]Floppy Nuns May 11 @ 2:47pm
Running GTX 760 and still getting around 20 fps on low
So my PC is by no means bad and I am not a expert with PC parts etc I can run sniper elite v2 medium with a good 60fps all the time but I cant run ANY soruce games decently fIst full of frags, Insurgency, TF2, ETC plz help
Showing 1-13 of 13 comments
< >
Sonic Dice May 11 @ 2:52pm 
cpu/ram/windows????? Seriously i have a 660 and 3570k on stocks and the game runs fine with 32 players maxed out you might have a virus or some ♥♥♥♥.
Tsukasa Shinjou May 11 @ 3:00pm 
That's what I'm running, and I'm getting a solid 60 FPS in this game no questions asked.

Maybe it's your CPU? I know that's my issue with a lot of games that require hyper-threading.
[invalid]Floppy Nuns May 11 @ 3:11pm 
GTX 760
Windows 7 64bit
6GB ram
Processor: AMD A8-3820 APU with Radeon(tm) HD graphics 2.50 GHz
not sure what my GPU is or CPU sorry
Last edited by [invalid]Floppy Nuns; May 11 @ 3:11pm
Bill Nye the Russian Spy May 11 @ 3:18pm 
Make sure your not using you intergrated graphics
[invalid]Floppy Nuns May 11 @ 3:18pm 
How do I check?
Sonic Dice May 11 @ 3:21pm 
Processor: AMD A8-3820 APU with Radeon(tm) HD graphics 2.50 GHz what in god's name's processor is that, never mix amd with nvidia, you're only supposed to have intel/nvidia amd/ati
[invalid]Floppy Nuns May 11 @ 3:22pm 
Mk I heard that wasent a issue I just got my PC fixed and every game was running fine now everything runs like ♥♥♥♥ but only SEV2 runs great
Bill Nye the Russian Spy May 11 @ 3:54pm 
Originally posted by Sonic Dice:
Processor: AMD A8-3820 APU with Radeon(tm) HD graphics 2.50 GHz what in god's name's processor is that, never mix amd with nvidia, you're only supposed to have intel/nvidia amd/ati
Not exacty my dad runs a amd and a nvidia card and he runs fine.
Hownsich May 11 @ 3:57pm 
hm
[invalid]Floppy Nuns May 11 @ 4:00pm 
hmmmm Idk it ran fine games on my RADEON 6870HD
Tsukasa Shinjou May 11 @ 4:24pm 
Originally posted by Sonic Dice:
Processor: AMD A8-3820 APU with Radeon(tm) HD graphics 2.50 GHz what in god's name's processor is that, never mix amd with nvidia, you're only supposed to have intel/nvidia amd/ati

This.

Intel/Nvidia should go along fine.

Admittedly, I'm running an Nvidia GeForce GTX 780 with and AMD-8350 Eight-Core Processor.

Not sure why, but my PC still runs most things like a charm, minus games that require serious hyper-threading.

Sentient_Toaster May 11 @ 5:24pm 
Originally posted by ♥♥♥♥inFlappyBunsOfJapan:
How do I check?

Well, you could find the hl2.exe in the TF2 directory, and then check the right-click context menu. (steam/steamapps/common/Team Fortress 2). You should see a "Run with graphics processor" option that leads to a choice between the nVidia and the integrated graphics, and one of those will be labeled (default).

At least that's what it looks like using my Intel + nVidia setup w/ W7. If you're running W8 it may be different.
[invalid]Floppy Nuns May 11 @ 5:26pm 
THANKS IL TRY
sorry caps
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: May 11 @ 2:47pm
Posts: 13