PlagueofMidgets Feb 11 @ 8:08am
A Man in Need of Help - Menu Clicking
While navigating the main menu and customizing my characters the game hesitates and makes a couple clicking noises while it decides what to do. The game hasn't always done this so I don't know how to fix the problem. I have a 4700k, GTX 770, and 16 GB of RAM so it shouldn't be my hardware. Thanks in advance for your help!
Showing 1-10 of 10 comments
< >
Team Starcom Leader Feb 11 @ 8:09am 
It's just a thing. It happens to me too
PlagueofMidgets Feb 11 @ 8:12am 
Originally posted by ThatBlokeWithTheHat:
It's just a thing. It happens to me too
That's unfortunate to hear. It's not a huge issue but it is irritating after awhile so hopefully they sort it out.
Louis PiLLs oR Ḋḭḗ Feb 11 @ 8:29am 
Its normal dont worry.
Bananaᴴᴰ ๖ۣۜKush Feb 11 @ 8:30am 
It happens to me as well. Usually only happens the first time you click on something in the inventory pages and stuff ^^
PlagueofMidgets Feb 11 @ 8:36am 
Have the menus always been buggy? I don't remember having so many problems before. It also doesn't display anything when I click a tab and looks like vsync messed up.
Bananaᴴᴰ ๖ۣۜKush Feb 11 @ 8:37am 
For as long as I can remember.
Haritori Feb 11 @ 9:29am 
Actually its the "Loading" sound, as backpacks and other stuff require the internet to load ID's, Name files, and recent Item Drops
Bananaᴴᴰ ๖ۣۜKush Feb 11 @ 9:31am 
I don't think you quite understand what he means Haritori.
Bananaᴴᴰ ๖ۣۜKush Feb 11 @ 9:32am 
And besides, a game doesn't need to make a sound to load
PlagueofMidgets Feb 11 @ 9:36am 
It isn't a normal loading issue as it is more glitchy in nature. I've tried everything I know of doing such as putting the game as an exception for the antivirus. I guess it is good to know I am not alone in this matter atleast.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Feb 11 @ 8:08am
Posts: 10