Team Fortress 2
Dodge Charger Jun 8, 2014 @ 7:33am
Lagging and stuttering all of a sudden?
Has anyone started seeing this odd problem? Everywhere I go, even if I join a low ping server, I start to stutter and lag all over the place. Even when I move, it will just lag too much for me, making it unplayable. Here's what I tried to do, but failed to work successfully:

-Verified the integrity of game cache.
-Reinstalled the game many times.
-Checked my Internet connection.
-Exiting out of Steam, and then relogging in back.

Guess what? None of these did not work. Does anyone have a solution to this problem? Please reply back, and thanks.
Last edited by Dodge Charger; Jun 8, 2014 @ 7:34am
< >
Showing 1-4 of 4 comments
Dodge Charger Jun 8, 2014 @ 7:39am 
So it looks like you people are gunna ignore this thread, and not help someone with an issue?
Lagger (Banned) Jun 8, 2014 @ 8:01am 
I definitely have nothing to do with your problem.

No, I have nothing to contribute with, saw-ry.
Last edited by Lagger; Jun 8, 2014 @ 8:01am
Dodge Charger Jun 8, 2014 @ 8:02am 
Originally posted by Lagger, The Last Laggard -CZE-:
I definitely have nothing to do with your problem.

No, I have nothing to contribute with, saw-ry.

Alright then, be useless then. You're not even providing a suggestion to my problem, so please, GTFO.
Last edited by Dodge Charger; Jun 8, 2014 @ 11:27am
Dodge Charger Jun 8, 2014 @ 11:27am 
Originally posted by Bee with a Helmet:
Sometimes lag happens when your pc is dusty, i remember i had horrible lag issues, i cleaned my laptop it only took a few minutes and it was running very smoothly again.

I did the same thing with my Desktop PC. I cleaned out the fan because it was dusty, and it was running smoothly. Now, I don't know exactly why I'm lagging and stuttering all of a sudden.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Date Posted: Jun 8, 2014 @ 7:33am
Posts: 4