Team Fortress 2
Monk Of War Jul 14, 2014 @ 3:00am
Change the language
How can I change the game language? I have everything in polish, so its pain to check the english item names every single time I want to trade something
< >
Showing 1-8 of 8 comments
lolschrauber Jul 14, 2014 @ 3:03am 
You can do this via the games library by right clicking and going to properties.
Monk Of War Jul 14, 2014 @ 3:05am 
I tried setting it to english. Didn't help
《FRU》 ~Frulk~ Jul 14, 2014 @ 3:12am 
I think, you've to change the language via steam (Steam > Settings > Interface > Select the language you wish to use)
lolschrauber Jul 14, 2014 @ 3:47am 
Originally posted by MonkOfWar:
I tried setting it to english. Didn't help
i had that problem too. Change the language to something else, german or french or something, and let it finish downloading the files. Then, restart steam, set it to english, and let it finish downloading the files.
Originally posted by lolschrauber:
You can do this via the games library by right clicking and going to properties.
It DOES NOT work
Sorry for necroing, but I just don't want to make one more thread if there's already one totally related.

So, changing TF2 language to 'English' from Steam Library settings doesn't work, game still keeps my native language. Suggested here change language to anything but english, restarting steam and changing to english again doesn't work either.
I know that I can change all steam interface to english, but I just don't want to do it for obvious reason.

So, any ideas? Maybe something like launch options or game files?
Last edited by Irvitzer the Toy Soldier [⇄]; Apr 2, 2015 @ 9:33am
xPositionx Jun 11, 2015 @ 10:53am 
Go to your resource folder "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\resource" and open the file tf_(your language).txt and tf_english.txt and copy everything from tf_english and paste it in tf_(your language). Then u see "Language" "English", change it to your language, so if u paste it in tf_polish.txt then u have to change "Language" "English" to "Language" "polish". Just (re)start tf2 and you have it in egnlish! (Sorry for my bad english, i'm from Belgium)
Azor Eiti (Banned) Jun 11, 2015 @ 10:56am 
Worked for me.

Steam -> Settings -> Interface and from there you select the language. Restart steam, both steam and TF2 will be in English.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Jul 14, 2014 @ 3:00am
Posts: 8