Randomguy7 Dec 26, 2013 @ 1:32pm
Randomguy7's Texture Streaming Removal Tutorial!
http://steamcommunity.com/sharedfiles/filedetails/?id=179520453
HEY NEWCOMERS
THIS IS SOMETHING YOU NEED TO TRY OUT, EVEN IF YOU ALREADY RUN IT WELL

Why? because I've found a long time ago an exploit-ish thing that effectively turns OFF the texture streaming in most udk/ut3 engine games. (besides blacklight retribution... that one doesn't like it).

WHY DOES THIS MATTER FOR ROTT?

Well in case you didnt' know this, the entire game is essentially one big lego set. Each "lego" is separately rendered and, as is inherent in the unreal engine 3, streaming them absolutely doesn't work, especially in the later cave levels.

What I did was turn the poolsize= command to EXACTLY 999999999
that's three sets of nines. any more will leave it without any textures, haven't tried any less. This spammy command breaks the system in a good way, because nobody at Epic Software probably thought anybody would try something so high. This means that after or while the level is loaded/loading, the entire level will stream in for good and the pointless quality loss from the streaming feature makes it look nicer anyway.

NOW HERE IS THE MOST IMPORTANT PART:
You NEED a 64 bit system. Also, this works wonders for those few udk gems that already have a 64-bit exe (like The Haunted: Hells' Reach!) because 64 bit systems simply load all of the levels better thanks to their allowance of more than 2 gigabytes of ram, as well as their ability to actually MANAGE large amounts of ram. So if you don't have a 64 bit system, eh, you could try the patch some have made but it still won't cut it that well.

SO THIS IS FOR 2 THINGS: PURE IMAGE QUALITY AND LESS DROPS FROM BROKEN STREAMING ERRORS, AS WELL AS FROM RAM OPTIMIZATION.

You should note that you will have to create new ini files from scratch every time an update happens, like if you've had them before the quicksave patch. This will ensure the new features work with this fix.

NOW ON TO THE ORIGINAL TUTORIAL:



(You can also see this tutorial on my blog at www.randomguy7.com!)

Hi guys and welcome to my tutorial! Before you do anything, fire up your game and play through about half of a level. Take note of your total amount of ram beforehand. After playing through half, or more than half of a level, WITHOUT FINISHING IT, press ctrl-alt-delete and fire up the task manager. Jot down how much total memory the game's proccess is using, and close down the game safely.

After doing this, take a calculator/smartphone app and divide your used ram/total ram and make this into a percentage. (hint: it's moving the dot two spaces to the right!)

Then look at this chart:

10-18%: You should be fine.
18-25% Expect some heavy load and cycles, but no errors and still more performance increases. Think of this as a "second loading screen" after you boot up the game.
25-32% Consider running gamebooster, and choose to close your desktop.exe proccess before running the game with this tweak.
32-45%: You probably should just keep the streaming on and deal with it.

The reason I added this section was because some of you were wondering if this was safe or not for your system. Level loads are different from total ram usage, and if the game's proccess uses about an eighth to three eights, you should be fine with using this tweak. However, if you use close to a half of your total ram, consider first disabling your desktop. This is important; windows 7 and earlier uses about one half of your ram for proccesses and the other half for important system information. BE SURE NOT TO DISABLE PAGEFILE. ACTUALLY, MAKE IT BIGGER JUST TO BE SURE, UNLESS YOU'RE ROLLING WITH UNGODLY AMOUNTS OF RAM.
This will make sure there aren't any Operating System glitches. Although these are unlikely, they should be watched for if said game is using a lot of your ram. I am unsure about how this works for windows 8, which i use, but I'm sure it's similar. However, there are still options such as:
increasing your pagefile
using a large flashdrive for readyboost
using the bcdedit /set increaseuserva command (learn about it on google!)
getting a 64 bit operating system, which will optimize your ram usage

using all of these things at once is encouraged but is not required. If you like playing with fire, like me, who has more ram than is said to support on the box, has a macbook without osx and has windows 8 installed instead, and plays games on it, then be sure to take proper safety measures such as these before moving on.

That being said, for me at least, I recieved two times my previous framerate and a much higher framerate stability accross the board for all of my unreal engine 3/udk games!!


WARNING! BEFORE DOING ANYTHING, YOU **MUST** TURN OFF UsePriorityStreaming=True ! IF YOU FAIL TO DO THIS THERE WILL BE CRASHES. I HAVE TESTED THIS AND EVERY TIME I HAD THIS SET TO TRUE, IT CRASHED. CHANGE IT TO BE LIKE SO BEFORE DOING ANYTHING:
UsePriorityStreaming=False

BE SURE TO DO THIS FIRST!!!

ALSO BE SURE TO CHANGE YOUR IN-GAME SETTINGS FIRST BEFORE DOING THIS. THIS WILL CRASH MOST GAMES DUE TO THE REQUIRED READ-ONLY TAG FOR THE .INI FILE. THIS CRASHES DUE TO THE FACT THAT THE GAME YOU ARE USING WILL NOT BE ABLE TO CHANGE THE SETTINGS. YOU WILL HAVE TO DO THIS EVERY TIME YOU DECIDE TO CHANGE SETTINGS!

I had to rewrite this. Change these settings for every freaking UT3/udk engine game. The only things you need are:
8+ gigs of ram **EDIT**(just to be safe... however please note that the game isn't even 8 gigabytes, so you guys should have no problem...)
a 64 bit operating system
and that's it.

What I did is changed these:


ROTTEngine.ini
PoolSize=999999999
UseTextureFileCache=False
bAllowSwitchingStreamingSystem=True
UseDynamicStreaming=False
OnlyStreamInTextures=True (please note this tweak is also in the systemsettings .ini file)


notice the rediculously high poolsize. This forces it to load the entire level to your ram, so after loading the whole level will spawn, forcing everything to load and will take a second to a couple of seconds depending on your rig. With this I was able to complete Clear and Present Dangers, and almost beat the NME, all with a constant 20+ fps. Here's my config:


2.0 ghz Intel Core 2 Duo P7350
8 Gigs of ram
Nvidia Geforce 9400m
Windows Virtual memory maximized at 7936 gigs (my video ram is shared)
and I also turned off the reflections here:

AllowImageReflections=False
AllowImageReflectionShadowing=False

and turned off

AllowSubsurfaceScattering=False

and that's it! You will never have to worry about texture, vertex, or mesh streaming ever again in any udk/ut3 engine game ever again. Thank you so much and I am glad to have done my part to the gaming community!!



**MAJOR EDIT**

Hi guys, it's been a while since I wrote this and I've learned a couple of important things. First of all: for those of who who are still on the first act, these tweaks won't be that much of a boost. However, in the later levels the tweak will work exponentially greater.

PLEASE NOTE: NO STREAMING =/= MORE RAM USAGE.
It still will use the same amount of ram regardless, but instead of feeding it in one chunk at a time it will all pop in after you load the level. Sometimes, especially in the lava levels of "the room" and the cave levels somewhere in the third act, the details in-game are too much to handle, at least for my cpu, and having them streamed in means a much lower workload for the cpu, always having things to pop in. Having them all there at once, for me at least, works loads better.

THIS MEANS THAT THIS TWEAK IS MORE FOR YOUR CPU USAGE AND NOT FOR BOOSTING THE TOTAL AMOUNT OF RAM YOUR GAME USES. IT ONLY MAKES THE ACTIVE TEXTURES IN YOUR RAM BOOSTED, AND WILL THEREFORE OPTIMIZE IT'S USAGE.

I hope this clarifies things!
Last edited by Randomguy7; Dec 26, 2013 @ 5:01pm
Showing 1-1 of 1 comments
< >
Rex Draco Dec 26, 2013 @ 7:18pm 
I don't get it.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50