SoullessDreamer Aug 26, 2013 @ 12:12am
The lag with advance PhysX
Ok so I was fiddling around with some things and found out that my issue with advance Physx has been the fact that it has been stuck on using the CPU, rather than a GPU. Even though I set it to use GPU 1 or 2 in the Nvidia Control panel. I would suggest all of you that are having issues go to your Nvidia control panel and then at the top of the window there is a pulldown labeled 3D Settings. Click on 'Show PhysX Visual Indicator' in that pulldown. This will make it come up with text in the upper left hand part of the screen when you play a game. It will say PhysX->CPU or GPU. If it says CPU even though you have advance PhysX on(in game) and your PhysX set to a GPU(Nvidia control panel) not auto. Then you have the same problem. If you have GPU then you are fine. The people that have monster CPUs will not see lag even if they have this issue as they have a good enough CPU to handle the load. If I am not the only one with this issue then it's a Nvidia issue and the Devs are off the hook(sadly I am sure it is). So please help me and others out and check to see if you have the same issue.

Thank you.
Showing 1-11 of 11 comments
< >
PowerHaus930 Aug 26, 2013 @ 12:50am 
I used to regret buying an ATI card but not now because to me the biggest reason to buy Nvidia is the capability to run Physx and there seems to be alot of problems with Physx and this game. Are there alot of issues with Physx in other games as well?
SoullessDreamer Aug 26, 2013 @ 12:52am 
So far I have seen the same issue with advance PhysX in both Metro Last Light and The Bureau: XCOM Declassified. Mainly ever since the drivers for Metro Last Light came out. So for some time.
Last edited by SoullessDreamer; Aug 26, 2013 @ 12:52am
PowerHaus930 Aug 26, 2013 @ 12:55am 
That really sucks. Well hopefully they will get things sorted out soon.
Prometheus Aug 26, 2013 @ 9:14am 
"NVIDIA has presented new official 9.13.0725 Release of the PhysX System Software.

Release Notes

- Fixes a bug that caused the Metro: Last Light to not be GPU accelerated on some systems."
Last edited by Prometheus; Aug 26, 2013 @ 11:35am
Luqin Sep 15, 2013 @ 6:01am 
Originally posted by Prometheus:
"NVIDIA has presented new official 9.13.0725 Release of the PhysX System Software.

Release Notes

- Fixes a bug that caused the Metro: Last Light to not be GPU accelerated on some systems."
I just installed this and it didnt fix the problem.. i only got like few FPS more then before patch.. (10 instead of 7 )
I have Phenom II x4, gtx660, 16gb ram, win 7 64x
abexomotron Sep 17, 2013 @ 1:15pm 
Originally posted by ☢B.O.B.☢:
Ok so I was fiddling around with some things and found out that my issue with advance Physx has been the fact that it has been stuck on using the CPU, rather than a GPU. Even though I set it to use GPU 1 or 2 in the Nvidia Control panel. I would suggest all of you that are having issues go to your Nvidia control panel and then at the top of the window there is a pulldown labeled 3D Settings. Click on 'Show PhysX Visual Indicator' in that pulldown. This will make it come up with text in the upper left hand part of the screen when you play a game. It will say PhysX->CPU or GPU. If it says CPU even though you have advance PhysX on(in game) and your PhysX set to a GPU(Nvidia control panel) not auto. Then you have the same problem. If you have GPU then you are fine. The people that have monster CPUs will not see lag even if they have this issue as they have a good enough CPU to handle the load. If I am not the only one with this issue then it's a Nvidia issue and the Devs are off the hook(sadly I am sure it is). So please help me and others out and check to see if you have the same issue.

Thank you.

Maybe you can try reverting back to PhysX 9.12.1031

I'm still using that PhysX version and never had any problem. 2nd GPU still used as PhysX for me.

Gtx 680 Lightning SLI here.
Luqin Sep 17, 2013 @ 2:09pm 
Originally posted by abexomotron:
Originally posted by ☢B.O.B.☢:
Ok so I was fiddling around with some things and found out that my issue with advance Physx has been the fact that it has been stuck on using the CPU, rather than a GPU. Even though I set it to use GPU 1 or 2 in the Nvidia Control panel. I would suggest all of you that are having issues go to your Nvidia control panel and then at the top of the window there is a pulldown labeled 3D Settings. Click on 'Show PhysX Visual Indicator' in that pulldown. This will make it come up with text in the upper left hand part of the screen when you play a game. It will say PhysX->CPU or GPU. If it says CPU even though you have advance PhysX on(in game) and your PhysX set to a GPU(Nvidia control panel) not auto. Then you have the same problem. If you have GPU then you are fine. The people that have monster CPUs will not see lag even if they have this issue as they have a good enough CPU to handle the load. If I am not the only one with this issue then it's a Nvidia issue and the Devs are off the hook(sadly I am sure it is). So please help me and others out and check to see if you have the same issue.

Thank you.

Maybe you can try reverting back to PhysX 9.12.1031

I'm still using that PhysX version and never had any problem. 2nd GPU still used as PhysX for me.

Gtx 680 Lightning SLI here.
Many ppl are having that problem... problem is that Nvidia has broken installers too, and i cannot instal 9 12 1031.. it says instalation failure .. i even had to install regular drivers using windows update.. because Nvidia instalers dont work..
PROTOTEMPLAR Jan 3 @ 2:50pm 
If you are getting 10fps with advance physX on and much better fps with it off, you can solve this by deleting the 3 physX .dlls in the metro game directory (they are for AMD users). deleting those files bumped my fps from 10 to a smooth 60 with advanced physx enabled. Hope this helps

edit: the 3 dlls are called like loader, wrapper, etc. should be pretty obivous.

Originally posted by lazgi:
Originally posted by Prometheus:
"NVIDIA has presented new official 9.13.0725 Release of the PhysX System Software.

Release Notes

- Fixes a bug that caused the Metro: Last Light to not be GPU accelerated on some systems."
I just installed this and it didnt fix the problem.. i only got like few FPS more then before patch.. (10 instead of 7 )
I have Phenom II x4, gtx660, 16gb ram, win 7 64x
Last edited by PROTOTEMPLAR; Jan 3 @ 2:51pm
EXPERIMENTONGOD Mar 21 @ 6:59am 
I had exactly the same problem as the OP; today I installed Metro: Last Light and for some reason my PhysX was downgraded to the version included with the game (PhysX 9.12.1031) which ironically DOESN'T WORK (no GPU accelerated PhysX). After reinstalling the latest version (PhysX 9.13.1220) my FPS got fixed (it went from 16.97 fps to 35.06 fps on the benchmark, no more slideshow when the doors blow up).
mcfunkey Jun 7 @ 8:35pm 
Originally posted by PROTOTEMPLAR:
If you are getting 10fps with advance physX on and much better fps with it off, you can solve this by deleting the 3 physX .dlls in the metro game directory (they are for AMD users). deleting those files bumped my fps from 10 to a smooth 60 with advanced physx enabled. Hope this helps

edit: the 3 dlls are called like loader, wrapper, etc. should be pretty obivous.

Originally posted by lazgi:
I just installed this and it didnt fix the problem.. i only got like few FPS more then before patch.. (10 instead of 7 )
I have Phenom II x4, gtx660, 16gb ram, win 7 64x


I can confirm deleting the 3 dlls works, went from 5 fps to 20 fps during the benchmark battle scene. GTX760
Prometheus Jun 7 @ 10:24pm 
Originally posted by mcfunkey:
Originally posted by PROTOTEMPLAR:
If you are getting 10fps with advance physX on and much better fps with it off, you can solve this by deleting the 3 physX .dlls in the metro game directory (they are for AMD users). deleting those files bumped my fps from 10 to a smooth 60 with advanced physx enabled. Hope this helps

edit: the 3 dlls are called like loader, wrapper, etc. should be pretty obivous.


I can confirm deleting the 3 dlls works, went from 5 fps to 20 fps during the benchmark battle scene. GTX760

You shouldn't need to do this with latest physx software installed . Completely fixed my physx performance .
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Aug 26, 2013 @ 12:12am
Posts: 11