CDorno Jul 6, 2013 @ 5:44pm
Metro: Last Light lagging horribly, completely unplayable
First off - I'm running a i5 2500K processor and a 6970 graphics card. Have ensured that the drivers are updated to the latest version, as is the game.

Yes still, I'm experiencing severe lag (or stuttering) to the point that the game is completely unplayable. Even the opening game menu (showing the cart with New Game, Continue, Options, etc.) is lagging severely. Cinematics appear to play fine, but in-game is unplayable because of the stuttering.

I've tried all sorts of solutions to no avail. Any suggestions?
Showing 1-6 of 6 comments
< >
.i. Jul 6, 2013 @ 8:27pm 
just a suggestion, check steam.exe and MetroLL.exe compatibility ( right click properties compatibility for all users uncheck compatibility )

also test the game in lower graphic settings, if it works ok with low settings it means it most most likely is a graphics issue
SAUL Jul 10, 2013 @ 7:39pm 
METRO LAST LIGHT RUNNING IN DX9! How To Enable DX9 to boost your FPS (enter this in youtubes search field)It helpped for me.
Plus search- Stuttering fix [solved] in this forum.Luck for option Nr.5 in it.
[SW] MacAttack Jul 10, 2013 @ 10:27pm 
Originally posted by CDorno:
First off - I'm running a i5 2500K processor and a 6970 graphics card. Have ensured that the drivers are updated to the latest version, as is the game.

Yes still, I'm experiencing severe lag (or stuttering) to the point that the game is completely unplayable. Even the opening game menu (showing the cart with New Game, Continue, Options, etc.) is lagging severely. Cinematics appear to play fine, but in-game is unplayable because of the stuttering.

I've tried all sorts of solutions to no avail. Any suggestions?

I'm not as knowledgable about AMD cards, but I might be able to offer a few suggestions. Is your 6970 a higher-end AMD card? If not, that may be causing stuttering in the game. I had a few issues like that with my old Nvidia GTX 650. If I kept the game on a lower resolution, with most of the graphics on low, there was minimal stutter.

But now, with my new GTX 770, I can run the game on ultra/very high with no stuttering and very minute drops in frames, which averages 80 to 100, even in graphically intense scenes. Anyway, point is, find a niche that best suits your liking. Experiement with different graphical settings and resolutions to get the best performance. If all else fails, save money to upgrade. :D
=(eG)= Martial.Lore Jul 10, 2013 @ 11:48pm 
I'm having few problems with lower specs ( i5-2310 CPU @ 2.90GHz + 6GB RAM and AMD Radeon HD 6450). Most video options are set low. Still looks OK though. and only the grenade explosion wave cutscene right before Venice showing really dire stuttering.
<3 | Atchoum Jul 11, 2013 @ 1:22am 
Long answer: Turn off your MSAA it's one of the least effeicent AA's there is making your comp just chugg cause the Metro series are system hog's.
Short answer Turn off your MSAA.
*9 Minutes later* Wait a minute was it SSAA or MSAA?
CDorno Jul 11, 2013 @ 4:42am 
I ended up completely uninstalling all drivers and doing a fresh install. For whatever reason, this fixed it.

Thanks for the suggestions though everyone!!
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Jul 6, 2013 @ 5:44pm
Posts: 6