Beerbot! May 14, 2013 @ 4:32pm
Game executable crashes on launch - SOLVED
I've scoured the forums and a handful of people seem to be experiencing this, but I've found no fix yet.

UPDATE - A workaround has been discovered that is working for me, at least. I have reported it to the tech support associate I was working with, so hopefully a future patch will correct it.

Originally posted by StaggBro:
I found out what was making MY game crash. For some reason the game doesn't like my wireless headset. (I have the Afterglow wireless ones) Whenever I have it unpluged, the game starts up and works fine, but the second I plug the USB reciever into the back, the game crashes. My normal audio jack headset works fine though. Weird that it took three days to find this.

For the record, I am using a Turtle Beach PX3 headset with wireless USB receiver, but other posts indicate the make/model does not seem to matter.

UPDATE 2 - It looks like several commenters are continuing to have problems regardless of the workaround mentioned above. I'll continue to keep an eye on it, but I cannot personally test them (as the game works for me at the moment). One user did post a fix that I will post now:

Originally posted by tumptump:
Hay guys. so i had game crash and same problems whyt game start. so what have i done to make it work. - C:\Users\myusername\AppData\Local\4A Games\MetroLL and delete the user.cfg file - than i unpluget my wired headset - started game as admin in safe mode and it works now. try it mb it will help

Hope this helps!

ORIGINAL POST

As soon as the game launches, the game crashes with the Windows message "Metro Last Light Executable Has Stopped Working". Launching in the game's "Safe Mode" produces the same effect. Benchmarking utility will also not launch with the same message.

What I've tried:
- Verify game cache (at least seven times now).
- Reinstalled game (Twice)
- Updated graphics drivers (Details below)
- Restarted Steam
- Restarted machine
- Obtained full Windows updates
- Banged head against desk

System Specs (Work in progress, don't laugh):
- Windows 7 x64
- Asus GeForce GTX 660 (Driver version 320.14)
- Intel i5-3570K at Factory Clock (about 3.40GHz)
- 4GB RAM
- Two Displays at 1920x1080, DVI input

Suggestions are most welcome. Thanks.
Last edited by Beerbot!; May 24, 2013 @ 1:11pm
Showing 1-15 of 74 comments
< >
Nathan May 14, 2013 @ 4:59pm 
I feel your pain been looking for solutions since last night.
Adeptus Astartes May 15, 2013 @ 1:23pm 
Devs apparently don't care, I got it working for a brief second but I had to change something, alt-tabed and I'm back to the issue
Beerbot! May 15, 2013 @ 2:32pm 
UPDATE:

In a fit of rage, I reimaged my computer earlier today, and believe it or not, it still does not work with the exact same anonymous error. This can only lead me to believe it is a hardware issue. Yet most people who are running approximately the same hardware as I am are running the game just fine. I am officially at a loss.
Faces of Death May 15, 2013 @ 2:36pm 
The only time mine crashed on launch was if i had Afterburner open and running an overclock, so if you have your card overclocked, try bringing it to stock.
Beerbot! May 15, 2013 @ 2:41pm 
No dice. Both CPU and GPU are on stock settings. Didn't even have the Asus overclock utility running.
I Have No Ass But I Must Fart May 15, 2013 @ 4:32pm 
Running it as administrator fixed it for me. Yes its stupid but it made it work although sometimes it will still fail to launch it launches for me now 9/10.
Beerbot! May 15, 2013 @ 6:39pm 
Originally posted by Obliterator of Fetuses:
Running it as administrator fixed it for me. Yes its stupid but it made it work although sometimes it will still fail to launch it launches for me now 9/10.

Tried with no luck, both with running the game .exe and the Steam client in administrator mode.
Darkheart291 May 15, 2013 @ 8:14pm 
I'm having the same issue thus far with no solutions, Someone suggested I go to C:\Users\myusername\AppData\Local\4A Games\MetroLL and delete the user.cfg file but when I went there i didn't even have a MetroLL folder in my 4A games folder.
Thus far I have tried:
-Reinstalling (twice)
-Verifying cache (twice)
-restarting steam
-restarting system
-windows updates
-running as admin
-graphics card driver update
All to no avail, my system is:
-i7950 CPU
-Nvidia Geforce GTX 660
-12 GB ram
-Windows 7 64 bit
-single monitor display connected via HDMI
Beerbot! May 16, 2013 @ 3:56am 
Originally posted by Darkheart291:
I'm having the same issue thus far with no solutions, Someone suggested I go to C:\Users\myusername\AppData\Local\4A Games\MetroLL and delete the user.cfg file but when I went there i didn't even have a MetroLL folder in my 4A games folder.

On the Steam version of the game, the user.cfg file is located in your steamapps directory (Usually C:\Program Files\Steam\steamapps\common\Metro Last Light). Though I've tried deleting it and letting the game rebuild it with no luck. I've also edited the thing six ways from Sunday and found nothing that made a difference.
StaggBro May 16, 2013 @ 4:22pm 
I've tried all of the above and only gotten as far as to have the game go full screen once before crashing.

This is ridiculous. I've searched all over and this is the only thread I have found where anyone is having the same issues as me. While everyone complains about the FOV being too narrow, we sit here trying to click the play button in a nice enough way, that the game might feel sorry for us and actually start so we can finally complain about the FOV being too small......
QUICKRICH May 16, 2013 @ 4:29pm 
Agree mine crashes in the tunnels running after the creature, Tried everything above no luck.

Really getting anoyed at devs recently.
Beerbot! May 16, 2013 @ 4:57pm 
I've been working with their tech support on finding a solution. If they are able to figure anything out, I'll post it here.
RobGT81 May 17, 2013 @ 1:10am 
I have this problem too I think. I only get as far as the Deep SIlver splash and the game crashes back to windows :( Any luck with a solution?
seq1 May 17, 2013 @ 1:16am 
I've a GTX 660 Ti and similar problems. Sometimes I get the game to run for a few minutes until it freezes. Tried everything except for reinstalling the OS and nothing seems to help.
StaggBro May 17, 2013 @ 11:20am 
I found out what was making MY game crash. For some reason the game doesn't like my wireless headset. (I have the Afterglow wireless ones) Whenever I have it unpluged, the game starts up and works fine, but the second I plug the USB reciever into the back, the game crashes. My normal audio jack headset works fine though. Weird that it took three days to find this.
Showing 1-15 of 74 comments
< >
Per page: 15 30 50
Date Posted: May 14, 2013 @ 4:32pm
Posts: 74