Metro: Last Light

Metro: Last Light

View Stats:
twiggy_110 Nov 4, 2013 @ 10:41am
Major drop in framerate
So i know Metro is a demanding game on hardware specs, but i should be able to run at least recommended settings:
The problem:
ive played the game fine, up until a certain point, ive had minor drop in frames before this point, but this is an unplayable drop. i dont know exactly how many frames but moving or switching weapons feels like hours. i go into the menu and its all okay. i reload checkpoints and the drop is still there.
ive tried on lower settings and turned off things that could drop frames and still have the issues.
Any suggestions?

Hardware specs:
i3 3.4ghz
Amd Radeon 7850 3gb
8gb ram
low res monitor - vga (with dvi adapter in the graphics card)
< >
Showing 1-7 of 7 comments
fRENCHY789 Nov 4, 2013 @ 10:58am 
I have the exact same problem but I'm running with a ♥♥♥♥♥ier graphics card (5850)

Its a very playable 25-30 FPS at 720P and everything on low (feels like im playing on an xbox lol) until that scene where you crawl and see the russian guy in jail getting hauled of to execution by the nazis. From then on its like 10 FPS and totally unplayable.

Perhaps its overheating hardware? I quit the game and will let my GPU chill out and then go back in :) Good luck dude!
Elow Nov 4, 2013 @ 2:31pm 
Make sure you disable Physx in the game options, it's not in video options but game options. That feature requires a lot of computer power.
twiggy_110 Nov 4, 2013 @ 4:02pm 
ahh thanks, i thought i had already turned it off! turns out i didnt and its finally playable again.
thanks
Elow Nov 4, 2013 @ 10:59pm 
Glad to help, enjoy the game! :D
nitejrny Apr 18, 2014 @ 2:23pm 
Same problem with my 780 Ti. The FPS were like a roller coaster, rising and falling between 230fps to 14 fps. What finally fixed it was learning that the Nvidia software does not automatically update the Physx drivers (stupid, I know), and I had to download just the physx driver and install it manually. Here's the current link. Hope it works for you!!

http://www.nvidia.com/object/physx-9.13.1220-driver.html
SpaceCouncil Jun 12, 2014 @ 10:13pm 
I had a similar issue where I would run at very high 1920x1080 at 60fps then suddenly drop to 16 frames. I tried everthing. I had the resolution down to 640x480 and it was still at 16. I'm like no f'ing way. So I tried the advanced Physx trick. nothing. same issue. Turns out I needed to unisntall and reinstall my graphic drivers (I already had the newest one, which was why I so perplexed). Then turn off advanced physics, now running at 60fps no issues.
SAUL Jun 13, 2014 @ 7:22pm 
http://www.youtube.com/watch?v=CD0IloS8KSQ

read evrything that guy writes under his video
do it
enjoi
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Nov 4, 2013 @ 10:41am
Posts: 7