kulinar Dec 4, 2013 @ 9:46am
[Linux] How to change display?
What to set in configure file? Now it starts in wrong display (2, small)
Showing 1-15 of 27 comments
< >
kulinar Dec 5, 2013 @ 5:32am 
up
kulinar Dec 5, 2013 @ 10:33am 
UP!
Analrapist Dec 5, 2013 @ 4:29pm 
just move game window manually to desired display
kulinar Dec 6, 2013 @ 11:12am 
Originally posted by Analrapist:
just move game window manually to desired display

I've tried. But the game window opened on both screens.. :(((((((((
Squee Dec 6, 2013 @ 11:30am 
I dunno if this will help, but have you tried to check and possibly edit the user.cfg? Also make sure you have the user.cfg in your user folder and not the game folder.

Another option you could try is temporarily disabling the 2nd screen, then starting the game. Maybe that will force it to the first. I had to do something similar with tropico 3 where the game wouldnt start if ya had 2 screens connected. But you could activate the 2nd screen again after starting the game with only one.
URMarty Dec 6, 2013 @ 9:23pm 
This ♥♥♥♥ run 4:3 on my 1080p widescreen HDTV only cuz i got one old 4:3, i was crying for fix from the beginning. I guess they just ignore it.
kulinar Dec 8, 2013 @ 12:36am 
How to switch in windowed mode?? I changed r_fullscreen option in user.cfg to "off" but its not works!! ******* developers!
kulinar Dec 8, 2013 @ 12:36am 
UP UP UP UP !
NukaCola Dec 8, 2013 @ 5:30am 
Originally posted by Squee:
I dunno if this will help, but have you tried to check and possibly edit the user.cfg? Also make sure you have the user.cfg in your user folder and not the game folder.

Another option you could try is temporarily disabling the 2nd screen, then starting the game. Maybe that will force it to the first. I had to do something similar with tropico 3 where the game wouldnt start if ya had 2 screens connected. But you could activate the 2nd screen again after starting the game with only one.

Setting fullscreen=off starts the game in windowed mode, this time mostly on the left monitor but spanning both. However you cannot move it as the game grabs mouse/keyboard preventing that (mouse won't leave the game window). There are a few other games in my steam library that I've had to start windowed, but they don't grab mouse/keyboard the same way and IIRC you can just move those to primary and fullscreen there.

A small scriptlet starting the game in a new X server using only primary screen should be doable and allow you to switch back and forth between game/desktop. That seems like a pita to work around what is clearly a buggy implementation though. It is the kind of stuff I'll do to run a game in wine, I don't expect having to deal with that for native games.
jondale Dec 8, 2013 @ 5:23pm 
I'm having this issue as well. It shows up on the wrong monitor. I'm unable to move it.
kulinar Dec 10, 2013 @ 6:14am 
up
Twoony Dec 10, 2013 @ 7:07am 
It crashes a lot on Linux AMD drivers

I have tried GPU's in different builds, i have tried Mint, ubuntu, with Cinnamon + KDE + even forcing the opensource drivers too...

I can usually get about 3 stages through a level and then a whole system lock up. I check my temps and they are fine but i dropped all my overclocks just to be safe and it still happens.

Last edited by Twoony; Dec 10, 2013 @ 1:50pm
kulinar Dec 10, 2013 @ 10:57am 
oneonyourface, I finished a game on small monitor. I have nvidia gt550ti and havnt your problems. But this topic about switching displays...
Last edited by kulinar; Dec 10, 2013 @ 10:58am
krebain Dec 10, 2013 @ 2:32pm 
I have the same problem. Linux version of Metro Last Light seems not to have several graphic options, including screen resolution. Hope it will be solved. It is not a nice "feature" for the first AAA game for linux in Steam...
kulinar Dec 11, 2013 @ 6:58am 
up every day!
Showing 1-15 of 27 comments
< >
Per page: 15 30 50
Date Posted: Dec 4, 2013 @ 9:46am
Posts: 27