Metro: Last Light

View Stats:
thrashcardiom Nov 7, 2013 @ 4:20pm
LInux version on multi screens
I have three monitors, two of which are 1920x1080 and the third is 1680x1050. MML starts full screen on the low resolution monitor. I'd like it to run on one of the HD monitors but I cannot find a way to set the screen it runs on. No other games, Steam based or otherwise, have this issue. Has anyone else experienced this? Does anyone have a solution or suggestions?
Showing 1-13 of 13 comments
< >
Xpander Nov 7, 2013 @ 8:37pm 
there are resolution settings in the Metro LL dir user.cfg files
try to copy them into Metro Last Light/<userid>/user.cfg file and make your needed modifications.

i have dualscreen with twinview ... 1920x1080 as primary and 1280x1024 as secondary and ofc it chooses the primary and plays with correct resolution.. so i have no complaints about the multimonitor support
thrashcardiom Nov 8, 2013 @ 9:36am 
Is your primary screen the left most screen in your set up?
BodeTuxDebian Nov 8, 2013 @ 9:42am 
1) NVidia or AMD/ATI?
2) IF nvidia, u~ll need to use Xinerama; twinview just supports 2 monitors.
Try to set one monitor (main) as xscreen0, the 2nd as xscreen1 and so on...
Last edited by BodeTuxDebian; Nov 8, 2013 @ 9:43am
Rain Ninja Nov 8, 2013 @ 1:28pm 
Even though it may not be your distro, is this any use to you? https://wiki.archlinux.org/index.php/NVIDIA#Gaming_using_Twinview

TBH I'm running dual monitors on separate X screens ATM, I had the same problem with TwinView with this game. Though I suspect I may not have set up my metamodes properly and I can't see that I have that SDL environment variable set anywhere, even though I swear in the past I did so. So I may try TwinView again soon.
Last edited by Rain Ninja; Nov 8, 2013 @ 1:30pm
BodeTuxDebian Nov 8, 2013 @ 2:37pm 
for 3 monitors, i am pretty sure twinview will not work (twinview = max 2 monitors); you'll need to configure it using Xinerama and or separate and independant screen / X
thrashcardiom Nov 8, 2013 @ 4:34pm 
Thanks for all the advice. Currently I have simply disabled the low res monitor. It's a work around.
Commander® [Alchemy] [ALinux] Nov 8, 2013 @ 10:14pm 
You can try to force som rules on the window itself. I have 3 monitors and the left one is portrait. Seems the game ignores my "primary" choice and goes for left one and screwing aspect ratio.

After playing around I created some rules in KDE that forced it to launch on my primary screen. Intro video is still anoyying since it goes with the aspect ratio of my portrait monitor but after that its smooth sailing.
HellFlame Nov 9, 2013 @ 1:31am 
Windows better then Linux! And you can write anything! I'm from Russia,so I will not understand you)
SteveIDusa Nov 9, 2013 @ 9:00am 
I also have 3 Monitors and have played around for a couple of days trying different solutions, easiest thus far has been to just use "Monitors" in Linux Mint 15 and Disable the Monitors I am not using while playing the game, I know this is far from a fix, but it got me to where my Game is on the Correct Screen, Front and Center, then just enable them again when done playing.
thrashcardiom Nov 9, 2013 @ 9:46am 
Originally posted by Commander® Alchemy ALinux:

After playing around I created some rules in KDE that forced it to launch on my primary screen. Intro video is still anoyying since it goes with the aspect ratio of my portrait monitor but after that its smooth sailing.

Are you able to detail your rule?

Thanks in advance.
Citosicarius Nov 10, 2013 @ 5:31pm 
I originally had this problem too, but there's an option in the nvidia control panel to set the default full screen monitor
SteveIDusa Nov 10, 2013 @ 7:03pm 
@ [GS*], how many monitors are you using?
jose1711 Sep 14, 2014 @ 6:17am 
same issue here with this game. 3 monitors, nvidia - primary = center. game always start on the left-most monitor and even if i move it to another one, mouse is stuck in the original window
Showing 1-13 of 13 comments
< >
Per page: 15 30 50

Date Posted: Nov 7, 2013 @ 4:20pm
Posts: 13