Metro 2033 > General Discussions > Topic Details
MrIownYouNot Oct 6, 2012 @ 1:49pm
FPS problems
Bought this game run the first level and I got very bad FPS about 20 - 30 on ultra
My specs are:

P67X UD3 B3 gigabyte motherbord
Intel i5 2500k 3,7 Gz
SLI 560ti (asus)
8G of RAM

I know this game had some FPS problems can somebody tell me how to fix it?
Showing 1-15 of 23 comments
< >
gabogdl Oct 6, 2012 @ 1:59pm 
got the same problem, i have minimun fs, i cant play =(
PiniataMurderer Oct 6, 2012 @ 2:10pm 
If you are running only one Gtx 560 ti card it might not be enough to run the game on Ultra. Try runing on High or Medium settings. Also you can try tweaking the settings a bit to keep model detail on Ultra but reduce the other effects.
Phiph Oct 6, 2012 @ 2:21pm 
Seeing as the 560Ti is one of the latest card, along in SLI it should be fine. Maybe check the NVidia control panel, and be sure that it isnt forcing it to run in 3D mode. :)
FearShot Oct 6, 2012 @ 3:19pm 
Sadly this is a very demanding game. Turn down the settings a bit if you feel like 20-30 fps is unplayable, otherwise get a 670 or 680 from nvidia.
Listy Oct 6, 2012 @ 3:26pm 
You have the same processor and graphics card as are in my pc, and mine runs like a dream on the top settings in 1080 resolution.

I do have 12gb ram but I wouldn't have thought the jump from 8 to 12 to make that much of a difference in fps on this game. You sure there's nothing like a background app doing a lot of disk writes as you are playing?
blueblur22 Oct 6, 2012 @ 4:09pm 
Originally posted by FearShot:
Sadly this is a very demanding game. Turn down the settings a bit if you feel like 20-30 fps is unplayable, otherwise get a 670 or 680 from nvidia.

What this guy said. The game was not directly supported by nvidia or amd/ati, so it's optimized for neither. Nothing to do with your rig.
Amerika Oct 6, 2012 @ 5:22pm 
Originally posted by MrIownYouNot:
Bought this game run the first level and I got very bad FPS about 20 - 30 on ultra
My specs are:

P67X UD3 B3 gigabyte motherbord
Intel i5 2500k 3,7 Gz
SLI 560ti (asus)
8G of RAM

I know this game had some FPS problems can somebody tell me how to fix it?

This game is VERY hard on computers...even new ones. There is a reason why it has basically replaced Crysis as the defacto system killing game used by most hardware testing sites. I too have a pretty damn good computer but I had to run Metro 2033 to dx9 and set most everything to medium quality levels. Honestly, you don't gain much by moving to dx11 so I wouldn't even use it. Lowering to dx9 and your settings also greatly improves input lag.
RAMPAGE572 Oct 6, 2012 @ 7:55pm 
Well the game was ment to be a benchmarker so therefore if you say you have a 560ti lol thats not high end so lower the settings to normal, aaa 4x af and then in nvidia control panel add the game in and put fxaa on, triplebuffering on and vsync there you go happy gaming
D4RKM4L1C3 Oct 6, 2012 @ 8:45pm 
560 ti is really only a mid-class card so you really have to lower the settings ^^
Pace Oct 6, 2012 @ 9:05pm 
This game doesn't scale very well with newer hardware. I can still drop below 30fps with a GTX 680. Just lower the settings
MrIownYouNot Oct 7, 2012 @ 5:12am 
Thanks for all the comments :D
Put the settings from ultra to high and played a little around with the other settings and I am enjoying the game right now at 40 FPS.
I don't really mind the lowish FPS as long as it is in SP if in MP it's a problem for me.
And I really hope Metro last light does it better on support from nvidia and AMD soo we can enjoy the game even more :)
Brave Scarecrow Oct 9, 2012 @ 12:27am 
nvidia states that a pair of factory reference 560ti's in SLI can handle Metro 2033 easily(check the link). Your hardware is fine, its most likely the developers fault for not optimizing the game for PC's or somthing.


http://www.geforce.com/optimize/optimal-game-settings/Metro-2033-GeForce-GTX-560-Ti-SLI-OPS
Spetsgruppa Oct 10, 2012 @ 8:54pm 
I got i5 3570k (no OC) 8gb 1600mhz ram.. and GTX 280.. runs on DX10 1650x1050 on Very High no prob at 45-55 FPS.. make sure you download new drivers.
Last edited by Spetsgruppa; Oct 10, 2012 @ 8:55pm
Chewy Singapore Oct 11, 2012 @ 3:51am 
If your 560 ti has only 1 GB of video memory(vram), it is not good enough to run Metro 2033 on very high with all the direct x 11 DOF tessellation and 4x msaa settings turned on. The frame rate crashes into the 20s when you are out of vram. Your graphics cards are very powerful and should run metro 2033 very smoothly but its too bad you dont have enough vram. Even if you have gtx 680s in sli it probably wont make too much of a difference. Also SLI does not scale as well on this game as crossfire.

I would recommend turning all settings to max(1080P) except for Direct x 11 Depth of field and MSAA 4x. I got Playable framerates(28+) on these settings most of the time with a single AMD 6850 so you should do just fine.

Some say turning on v sync in the user.cfg file improves framerate. It is located here
D:\Program Files (x86)\Steam\userdata\43698215\43110\remote For AMD users you have to use D3Doverride included with rivatuuner to force vsync on or else it wont work, nvidia users would have to force it on in the nvidia control panel. You can increase your FOV here too i recommend 55.

This benchmarking video demonstrates the problem.

http://www.youtube.com/watch?v=G2ntJOMe-pU



Last edited by Chewy Singapore; Oct 12, 2012 @ 2:30am
=T$E= Samnaske Oct 12, 2012 @ 1:07am 
Heard from some way Metro 2033 don't really support SLI. It is likely to run in a single card
Showing 1-15 of 23 comments
< >
Per page: 15 30 50
Date Posted: Oct 6, 2012 @ 1:49pm
Posts: 23