Metro 2033 > General Discussions > Topic Details
Alien Mask Sep 23, 2013 @ 10:04pm
Whats up with the lag?
I got this game on sale and the lag is pretty crazy in single player I dont know if its just me should I try verifying or putting my video settings on low?
Showing 1-5 of 5 comments
< >
Boxes Sep 24, 2013 @ 8:08am 
Try this first: http://steamcommunity.com/sharedfiles/filedetails/?id=136345159
If that doesn't help enough lower the settings, the game is pretty demanding.
PowerHaus930 Sep 24, 2013 @ 11:21am 
Also you want to make sure that you turn off Advanced Physx in the Game Optiions menu. This game is not optimized very well so Tesselation can really hurt performance too. Also while you are in the config file go to the setting r_dx11_dof 1 and change it to 0. DOF is a DX11 feature that will destroy framerate so unless you have a beast of a machine turn it to off. If you are still having trouble try playing on DX10 instead and that should help.
Alien Mask Sep 24, 2013 @ 12:36pm 
Ok I did it on DX 9 and put everything on low settings that seem to help out alot. Pretty ridiculous game though I like it kind of reminds me of Half Life a bit.
PowerHaus930 Sep 24, 2013 @ 1:53pm 
What kind of CPU and GPU do you have?
WindWaker Sep 25, 2013 @ 6:32am 
I had lags first, but when I changed the settings from DX 9 to DX 11 it stopped. This game sure is heavy and it looks really good. Even from its age compare to newer games.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Sep 23, 2013 @ 10:04pm
Posts: 5