Metro 2033

Metro 2033

View Stats:
Metro 2033 > General Discussions > Topic Details
Grimmbald Sep 10, 2013 @ 7:29pm
Lol what a pos
I bought a nvidia 760gtx 4 GB card to go with my new i7 3770k and this ♥♥♥♥ing game runs like ♥♥♥♥. Gee maybe I should check my drivers...you know make sure they are up to date...stay away!
< >
Showing 1-15 of 36 comments
node357 Sep 10, 2013 @ 7:33pm 
Check out the configuration tips threads in this forum
PowerHaus930 Sep 10, 2013 @ 7:48pm 
Yeah this game definitely needs tweaking in order to run decently. The main thing to do that I remember is to turn on Vsync through the config file. Check out the thread for more info.
jV Sep 10, 2013 @ 11:22pm 
Maybe turn off physx.
TITOMOSQUITO187 Sep 11, 2013 @ 8:26am 
ugh...♥♥♥♥ this. I jsut did a ton of modding in Skyrim, Terraria and New Vegas. I'm done ♥♥♥♥ing around with game files...lol
LagMan_pt Sep 11, 2013 @ 10:56am 
This is a demanding game that still beats most games in the graphics department despite its age and its true not very optimized, so you should lower your graphs a bit, im sure you can play this game great on your machine on very high settings turning dx11 dof off and physx as well. Just because you have a new computer doesnt mean you can max out everygame, there are still games that can tear down the fiercest configuration.
Red Hessian Alpha Sep 14, 2013 @ 8:34am 
I can max out this game with a GTX 670mx, of course my card has a slight overclock. Try fiddling with shadows, physx, ect if you don't feel like overclocking.
mechaniK Sep 15, 2013 @ 3:31am 
lol im playing this game with an fx 8350 and a 5 year old geforce 9500gt 512mb ddr2 XD if i run it 800x600 i can get it to high settings.. ofc it still looks like sh!t, but its very playable
I have a gtx 660 with 2GB and i max it out with no problem. Check your drivers, and if that doesn't fix it, then it might be a hardware problem.
[7ap] Nikola_ch Sep 20, 2013 @ 5:35am 
просто русский коомнетарий
mechaniK Sep 20, 2013 @ 12:19pm 
just bought a gtx 680, max settings with ease.
MacAttack Sep 21, 2013 @ 3:56pm 
I found that the option "advanced DOF" takes a lot of power to run. Turn that off. Even my 770 couldn't have that on. Also, this is kind of weird. Motion blur is tied to graphics quality. They don't have a seperate option for motion blur, go figure. :P

Anyway, you know how there is a little "text box" below the options that shows the effect each option gives? When the graphical detail is set to "very high," it adds motion blur to objects AND characters. And that takes some processing power too. I found performance increased greatly with in just set to "high."

Of course there is other variables in there. It also takes extra shadows off objects and whatnot, including a few other small details. But that really doesn't matter, as it is hard to tell the difference with it on, or off.
Rodso Sep 25, 2013 @ 3:48am 
check to see if your drivers are up to date
henkkass Sep 27, 2013 @ 5:58am 
Overclock your system
Grimmbald Sep 27, 2013 @ 6:07am 
I fixed it!
Here is what I did:
Right click "Metro 2033" from Library list and select "delete local content"
Last edited by Grimmbald; Sep 27, 2013 @ 6:11am
LagMan_pt Sep 27, 2013 @ 9:08am 
haha ok that fixes everything i guess. This is a great game thou despite the usual attached tecnical probs and your pc is more than capable of running this with a few tweaks on the options menu, my opinion of course.
< >
Showing 1-15 of 36 comments
Per page: 15 30 50

Metro 2033 > General Discussions > Topic Details
Date Posted: Sep 10, 2013 @ 7:29pm
Posts: 36