Metro 2033 > General Discussions > Topic Details
SgtSteaksauce Jun 29, 2013 @ 10:30am
Metro 2033 Running Smoothly
I recently overhauled my 4-year-old computer in order to play Metro 2033 and was frustrated by the frequent crashes. After uninstalling the 320.18 drivers and going back to the 314.07 drivers, everything seems to be running smooth and stable. I’ve been able to play through the first couple of chapters of Metro 2033 without a crash or other issue.

Specs:

Motherboard: Gigabyte GA-MA790X-DS4
Processor: Phenom II X4 965 3.4GHz
Memory: 8GB DDR2 800
Video: EVGA Geforce GTX 660 2GB /w 23” Samsung monitor via HDMI
Audio: Sound Blaster Recon 3D /w Klipsch Promedia 2.1
Hard Drive: WD Caviar Black 500GB
Windows 7 64 @ 1920 x1080
Latest audio, network, and DirectX drivers

I currently run Metro 2033 on ‘Normal’ settings with DirectX 10, 4x AA and 16X AF. It can be run with higher settings, but these middle ground settings look nice and run fast. I do not know how far this stability will last into the game, but hopefully I will be able to play it through without issue.

My other games, including Starcraft 2, Borderlands 2, Portal 2 and Alan Wake all seem to be running just as well.
Showing 1-3 of 3 comments
< >
mychaelo Jun 30, 2013 @ 4:11am 
Running M2033 with 660 on 'Medium'? Madness! Crack it up to high, turn off MSAA, turn on Advanced Physics and you'll have no problems. 320 is unstable, both beta and WHQL release.
Wɑκσi Jul 1, 2013 @ 8:33am 
I don't know :(
Enzo Jul 1, 2013 @ 10:12am 
Bazinga
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jun 29, 2013 @ 10:30am
Posts: 3