Metro 2033 > 一般討論 > 主題細節
Gemma 2012 年 12 月 22 日 @ 下午 4 時 47 分
Solutions for various problems you may encounter with Metro 2033
IF YOUR GAME WON'T EVEN START UP and you bought a german retail version or EU-Version, try setting the language to german (or appropiate language) via Steam (Library->Metro 2033->Properties->language). Steam will then re-download about 2.1GB and after that the problem should be solved (if you already have installed latest graphics/physx-drivers of course). Don't be afraid, that the game itself will be in german then, it won't. text and speech stay english.

IF YOU HAVE TROUBLE SETTING YOUR DESIRED RESOLUTION, because your screen goes black and maybe you get a message "out of range" or something similar, you can easily configure resoultuion and refresh rate (this is a problem due to the game using a refresh rate your monitor can't handle) through the game's config-files + adding a startup-command in Steam.
To do this you only have to look for the TWO user.cfg-files. In Windows 7 they are located in: <drive letter>:\...\Steam\Steamapps\Common\Metro 2033\
and in
C:\Users\%username%\AppData\Local\4A Games\Metro 2033

You want to find and change the following lines (best in both .cfg-files):
r_res_hor 1280
r_res_vert 1024

Now you have to add a startup-command for this game in steam. Go to "Library->Metro2033-Properties-Set Launch Options....". There you add the line "-refresh 70" without the exclamation marks (or whatever refresh rate you'd like/need to have for the game).


YOU ALSO MAY WANT TO CHANGE THE FOV-value to an appropiate one for yor aspect ratio respectively resolution. The standardvalue is 45, I changed it to 78 which is a good value for 5:4 aspect ratio. You may change it through this line:

sick_fov 78

To look which FOV is good/best for you, you can use this calculator:
http://www.rjdown.co.uk/projects/bfbc2/fovcalculator.php


If someone else likes to add solutions for other or similar problems, you are cordially invited to scribble them down here :).
最後修改者:Gemma; 2012 年 12 月 23 日 @ 下午 1 時 16 分
顯示 1-15,共 27 則回應
< >
mychaelo 2012 年 12 月 23 日 @ 上午 4 時 40 分 
You can publish it as a guide in "Guides" section, will be easier to read and link. PM if interested.
ChristosK (Kur Vasilis) 2012 年 12 月 23 日 @ 上午 7 時 55 分 
Thank you Grey Mouser, you solved my won't startup problem!
DanielF823 2013 年 03 月 14 日 @ 下午 10 時 13 分 
I jjust built a top of the line PC with a Radeon HD 7970 GHz Edition and the refresh rate is so bad in this game... no issues in new titles... but this one is really bad!
Gemma 2013 年 03 月 15 日 @ 下午 2 時 37 分 
DanielF823 發表:
I jjust built a top of the line PC with a Radeon HD 7970 GHz Edition and the refresh rate is so bad in this game... no issues in new titles... but this one is really bad!
Did you ever try out The Witcher 2 on High Settings? =D But okay, I guess that is kind of weird. I know that i had issues, but that was understandable, since I only had a GT440. If i remember it correctly the worst drop was on the menu-screen and I just lowered the gfx settings a little bit which worked quite nicely. ..umm, okay just see that you wrote refresh rate and not fps...mmh.. if its the refresh rate you can change it via the console command described above. But if it's a problem with your fps, maybe try updating your drivers, or trying out different settings in your radeon graphics control system (whatever it is called nowadays, used to be catalyst), but maybe it's just one of those games like Ultima 9, who knows^^.
galletto galerunner 2013 年 04 月 3 日 @ 上午 12 時 31 分 
yes could you tell me how to fix burbon gliching out in the market whenever i go to him he will talk and then just stand there and i know its not lag and iv tryed verafieing the games cashe to fix it but it whont fix what the problem is all it will do is tell me that something isw broke
mychaelo 2013 年 04 月 3 日 @ 上午 12 時 48 分 
You'll need to rerun the 'Market' chapter. Then, when Bourbon finally speaks to you, try to go around him so that he'll be facing the exit.
TZ 2013 年 04 月 3 日 @ 上午 8 時 45 分 
I typed -refresh 59 , at the 'set launch options'... Afterburner, in game, still saying that I am getting 75 fps.... and a bunch of tearing/micro-stutter/whatever. I changed fov in cfg. files to 90 for my 1920x1080 monitor... I didn't notice any changes on the fov.
galletto galerunner 2013 年 04 月 3 日 @ 下午 3 時 20 分 
no i dont think thats it mychaelo i think theres something broke with the game that i need to fix manuley because i have tryed that a thaousend times but it never worked so if someone here could tell me how to fix the codeing that would be helpful as the so called 'helpful' 'verafie game cashe' does not fix it but only says thats theres something wrong with something
最後修改者:galletto galerunner; 2013 年 04 月 3 日 @ 下午 3 時 21 分
Gemma 2013 年 04 月 6 日 @ 上午 8 時 23 分 
tater-tots 發表:
I typed -refresh 59 , at the 'set launch options'... Afterburner, in game, still saying that I am getting 75 fps.... and a bunch of tearing/micro-stutter/whatever. I changed fov in cfg. files to 90 for my 1920x1080 monitor... I didn't notice any changes on the fov.
Don't confuse FPS with refresh rate. The refresh rate setting is only for those people getting a black-screen, since their monitors can't handle high refresh rate settings on higher resolutions, mostly people with older TFCs. If you don't get a black-screen with the standard refresh rate, then don't change it via the launch command.
galletto galerunner 2013 年 04 月 9 日 @ 下午 11 時 17 分 
and i found a fix to the market glich :but now im stuck at the armory level as i cant even get past the first guard with out him killing me
最後修改者:galletto galerunner; 2013 年 04 月 9 日 @ 下午 11 時 17 分
dxhxa 2013 年 04 月 13 日 @ 下午 9 時 37 分 
when i change the .cfg in C:\Users\%username%\AppData\Local\4A Games\Metro 2033, it´s back to 800 and 600 at start game, how can solve this problem?.

sorry for the inglish, but i don´t know so much of it.
TZ 2013 年 04 月 14 日 @ 上午 5 時 25 分 
to make the changes you make in the ini files stick, you must make changes in 3 locations. The one that maintains your user defaults will revert the games ini settings back to default every time. The three locations are, as far as I know; 1.) ... -> Steam / Userdata / .... / 43110 / remote. 2.) Steam / Steamapps / Common / Metro2013. 3.) Users / ... / Appdata / Local / 4a Games / Metro2033.
dxhxa 2013 年 04 月 14 日 @ 下午 6 時 39 分 
thanks, i put all in 1280 and 1024, and tip -refresh 70, 45 and 59 in advanced settings, but the game don´t run.
最後修改者:dxhxa; 2013 年 04 月 14 日 @ 下午 6 時 40 分
Magnum 2013 年 04 月 17 日 @ 下午 7 時 06 分 
i did everything and nothing fixes my black screen issue... i know its not my specs either cuz i can play more demanding games than this. someone help plz....
TZ 2013 年 04 月 17 日 @ 下午 9 時 18 分 
@ Velard29; Please be more specific. Does the game boot up? and if so, at what point do you get the black screen? You've verified your game cache thru steam settings so we know that it is not an issue of corrupted files? Please be as specific as possible in regards to when and where you are getting a black screen.
When you say 'more demanding games'; so you mean games like 'Sleeping Dogs' and 'Hitman, Absolution'? (Games that were originally written for directX 11) So, you mean, something like, a decent quad core processor and a gtx 660 Ti? Maybe you could go ahead and tell me what your actual processor and graphic card is. What operating system?
Did you start getting this problem after you changed ini files? or has it always been a problem?
顯示 1-15,共 27 則回應
< >
每頁: 15 30 50
張貼日期: 2012 年 12 月 22 日 @ 下午 4 時 47 分
回覆: 27