Metro 2033 > General Discussions > Topic Details
em_t_hed May 22, 2013 @ 11:03pm
is there no way to turn on vsync?
ive tried the nvidia control panel and ive changed the vsync to 'on' in both user.cfg files all to no avail.
Showing 1-15 of 17 comments
< >
WeristLAN May 23, 2013 @ 10:25am 
Personally, i wouldn't turn it on anyway...unless you have a monster rig, holding 60 fps is next to impossible, and if your rig can't hold 60 fps it drops down to 30 fps.
It's imo better use Adaptive VSync, so it runs vsync'd if 60 fps are possible but disables vsync if 60 fps are not possible. Or you could use the frame limiter, the result will be the same.
em_t_hed May 23, 2013 @ 2:18pm 
and there's the issue... every thread i've read on vsync for this game always talks about frames being limited and i dont care about that... it's the screen tears i want to go away which is the reason im asking about vsync....

several threads someone chimes in with 'just use a frame limiter and you'll get the same result...' NO. the screen tears are still there.... THE WHOLE POINT OF VSYNC IS TO PREVENT SCREEN TEARS BY LIMITING THE FRAME RATE TO THAT OF THE MONITOR!!!

WHAT IN GODS NAME MAKES PEOPLE THINK THAT A FRAME LIMITER IS DOING THE SAME THING AS VSYNC?!?! IT'S NOT!!!

NONE of the nvidia control panel options work!
going into both user.cfg files and turning the vsync to 'on' doesn't work...

am I missing some other option?
Unknown-no-name May 23, 2013 @ 3:46pm 
NVIDIA via it I turned on this
Kusarama May 24, 2013 @ 10:30am 
Bu teknolojiden nefret ediyorum ne zaman açsam PC kasıyor.
Bebop0389 May 24, 2013 @ 11:33pm 
There's 3 different user.cfg files that need to be modified to enable vsync. The default is "r_vsync off", change it to "r_vsync on" and save each document. It worked for me (for a day anyway; now the gpu drivers crash every 5 min). It was sweet; eliminated screen tearing with no loss in fps, didn't even need to enable it in the gpu options. Supposedly they render each frame twice by default for 3d gaming, so enabling vsync does not effect your fps (tested and confirmed this with the benchmark tool).

1. C/users/(your user name)/app data/local/4a games/metro 2033/user.cfg
Note: you need to be able to view hidden files and folders to access this file. You can enable it under control panel/files and folders/view

2. (your steam library)/userdata/(a number representing your user id <?>?)/43110/remote/user.cfg

3. (your steam library)/steamapps/common/metro 2033/user.cfg

EDIT: Sorry, didn't read your post thoroughly. Well, you say you tried two of these locations, I'd recommend trying-and confiming- all 3. Note that the game will occasionally overwrite your settings and you need to re-edit the files, especially if you 'verify the game cache'. Good luck.
Last edited by Bebop0389; May 24, 2013 @ 11:36pm
Sandcracka May 24, 2013 @ 11:40pm 
Originally posted by Bebop0389:
3. (your steam library)/steamapps/common/metro 2033/user.cfg
That is just the default settings, and if you make any changes in that particular one they will likely get reverted once the game is launched. Your first two references are correct though.

Originally posted by em_t_hed:
ive tried the nvidia control panel and ive changed the vsync to 'on' in both user.cfg files all to no avail.
The screen tearing in this game is horrid. For me, the vsync in the cfg files was fubared. Can't remember if the vsync didn't work at all or if I was getting lousy fps with it on. So I left the game vsync off and turned it on with RadeonPro, also turned on Dynamic Framerate Control set to 60fps. Though I did not turn on triple buffering as I heard it is not good to use with multi gpu setups. Now I get 60fps and no screen tearing.

Have you tried Nvidia Inspector? I've heard it works similar to RadeonPro.
Last edited by Sandcracka; May 25, 2013 @ 12:10am
Bebop0389 May 24, 2013 @ 11:47pm 
Personally, I haven't had any problems with that file reverting.However, even with the .cfg file edit, vsync only seemed to work for one day for me. Why I don't know.

Next thing I'd recommend (and i'm going to try when and if the ****Ing game will run) is desribed here: http://forums.steampowered.com/forums/showthread.php?t=2095559. Some application that comes with Rivatuner that apparently allows you to set vsync settings. Worth a shot anyway
Bebop0389 May 25, 2013 @ 8:50pm 
Sry to double post, but I was able to get screen tearing down to a bare minimum by going from DX 11 to DX 10 in game; its about 75%+ better, nearly non-existant now.

Admittedly, it's a crappy solution, but I don't see any huge loss in image quality with DX10.

(To elaborate, disabling DX 11 features DOF and tesselation did not help-I had to switch to DX10 in the options menu. Yes, I have a DX 11 gpu, a GTX 580. I've tried everything but external software to fix the screen tearing, and this is the only solution that's worked.)
AngusHades May 26, 2013 @ 4:21am 
The newest Nvidia drivers did it for me
gearsman Aug 5, 2013 @ 11:16am 
ok the idiots just need to release an update that enables vsync in the in game options EA did it with crysis 1 because the screen tearing was so bad wtf did the idiots who made metro 2033 not do it. Last light has vsync, played that game on a phenom 9600 and still had less screen tearing then 2033.
_GoldSrc_ Aug 22, 2013 @ 5:31pm 
Use Adaptive Vsync, it turns off when your framerate goes below the refresh rate of your monitor, and turns on when it goes above your refresh rate.
Ape (with car keys) Aug 23, 2013 @ 6:50pm 
adaptive vsync is wonderful, i have that enabled globally and don't muck with individual game settings at all
(TC Idling)[*S❤C*]SgtFopper™ Sep 8, 2013 @ 8:07am 
Thanks guys! RadeonPro finally solved my screen tearing problems. :)
Niner Sep 8, 2013 @ 10:07am 
I turned on Vsync and triple buffering in the NVIDIA control panel and it works perfectly and it does not cause it to go down to 30fps. Every time I've tried adaptive vsync on my GTX 470 I've still gotten tearing though I haven't tried it in Metro since regular vsync is working great.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50