Metro 2033 > General Discussions > Topic Details
Rafkin Apr 9, 2013 @ 8:05pm
Graphics Problems
Just installed Metro 2033, and running into graphics problems. Screenshots of them here:
http://steamcommunity.com/profiles/76561197993268240/screenshots/?appid=43110&sort=newestfirst&browsefilter=myfiles&view=grid

Problems exist in DX11 & DX10, but not DX9. DoF is turned off. 2xSLI nVidia GTX680, i7-990x OC'ed, 24GB RAM, etc. Everything's up to date, and I'm pretty certain it's not my machine hardware or drivers.

Has anyone seen this before and have suggestions as to how to fix it?

Thanks in advance!
Showing 1-15 of 19 comments
< >
Rafkin Apr 9, 2013 @ 8:15pm 
And I just noticed that DX11 Low and Normal settings work fine. It's when I change DX11 to High and Very High that these graphics problems occur.
NoStall Apr 9, 2013 @ 8:39pm 
Don't know if I can help. Try uninstalling your video drivers and then doing a clean install using the Nvidia installer. I know, you've probably already done that, but your pix look like stuff I have encountered after updating drivers (over the years). Also, have you tried removing one of the video cards and tried it on one card only? I am running 2 GTX660 s in SLI and EVGA's Precision tool is only showing one of them being used during the game: I am not having any video problems, but that doesn't mean I won't. Let us (the forum) know if any of this works. Best of Luck.
Rafkin Apr 9, 2013 @ 9:04pm 
Thanks for the comments and suggestions. I have done a clean install of video drivers, but I'm not going to unseat/reseat video cards. I use this machine heavily for video/photo editing and gaming, and everything else (all video editing apps and more than a dozen games) works fine. I really don't want to risk screwing something up in the machine for this one game.

I played Metro once before, when it was first released, and this issue seems familiar, though I don't recall how I fixed it at the time, unless I just switched to DX11 Normal and just played through like that.
NoStall Apr 9, 2013 @ 10:11pm 
Grizol, I figured you had tried a lot of solutions. I am busy all day tomorrow but will do some research Thursday and see if I can find anything that might help.
I am wondering why this game is only using my primary video card and not both of them: Perhaps I will be able to answer both problems. Talk to you later.
Rafkin Apr 9, 2013 @ 10:36pm 
Thanks, I really appreciate your help.

Btw, while I didn't physcially unseat one of the cards, I did go into nVidia settings, and, for game specific options, toggled to only use one GPU/card. Unfortunately, that didn't help.

I also discovered that the crazy red tint in the image is from some effect related to the laser sight of the weapon. When I switch to the knife, the ghost images are still there, but the image is now colored normally (no more red hue across the screen).
Camisado Apr 10, 2013 @ 2:44am 
Try loading a game without that weapon at all and see what happens. Honestly though it looks like it could be an issue with your video cards memory dying - do you have any issues in other graphically intensive games?
Rafkin Apr 10, 2013 @ 6:07pm 
No, this game is the only game that exhibits problems. And weapons with a laser sight cause the red hue, but with or without that red hue, there is always a ghost image present.
NoStall Apr 10, 2013 @ 9:30pm 
Grizol, I will see what I can find tomorrow. I am back, I am beat, it has been a long day and I am exhausted (part of being older). You probably already checked this, but I hadn't: go into your Nvidia control panel and make, oh never mind, you already did it (two posts ago). I found my problem, a driver installation had switched off SLI; turned it back on and my frame rates are back up where they should be.
I did looke for some solutions to the "red" this a.m. before leaving. Some with ATI cards had athe problem and fixed it by turning off Global Illumination. Our NV cards don't have that in the control panel but it looks like a config file setting within the game. What our cards do have is 'Ambiant Occlusion". Just a wild shot but try turning that off in the NV Control panel, either in the global setting or specifically in the game setting. What the H@#$, it might work.
Per previous post I will see what else I can find tomorrow. Have a good night.
AMS AGENT 000 Apr 10, 2013 @ 10:09pm 
I have the same problem, the ghost image freezes and becomes permanently overlayed over what is actually happening and therefore making the game unplayable.
Rafkin Apr 10, 2013 @ 10:21pm 
Good suggestion, NoStall. Just did some additional research on Ambient Occlusion and SSAO, and it seems there are quite a few people who complained about the same, or similar problems, and all traced it back to the Ambient Occlusion effects. Unfortunately, AO is disabled in the nVidia control panel, and there is no way to turn it off in the game or in the game's cfg file, so the general concensus was to notch the game down from DX11 High to DX11 Normal. This removes all of the special lighting effects, along with AO, and renders the game only a tad better than the Xbox360 version.

Well, sad that I have a high-end system but am forced to play the game at a console level quality, but at least I can get on with it. :)

Thanks for all of your help with this, NoStall - much appreciated!
Gummydrop Apr 11, 2013 @ 12:07am 
Can't you use the Nvidia control panel to change the ambient occlusion specifally for Metro2033.exe or whatever the exe is?
jerry1970com Apr 11, 2013 @ 4:27am 
Originally posted by Grizol:
Just installed Metro 2033, and running into graphics problems. Screenshots of them here:
http://steamcommunity.com/profiles/76561197993268240/screenshots/?appid=43110&sort=newestfirst&browsefilter=myfiles&view=grid

Problems exist in DX11 & DX10, but not DX9. DoF is turned off. 2xSLI nVidia GTX680, i7-990x OC'ed, 24GB RAM, etc. Everything's up to date, and I'm pretty certain it's not my machine hardware or drivers.

Has anyone seen this before and have suggestions as to how to fix it?

Thanks in advance!
jerry1970com Apr 11, 2013 @ 4:35am 
Hey Grizol!

Try too use d3d overrider (enforce- vsync!)

It comes with Rivaturner also..,.HTTP://downloads.guru3d.com/rivatune...nload163.HTML

Good luck!

Jerry1970.com
NoStall Apr 11, 2013 @ 9:20am 
Morning, just getting up and functional. Read your post and it says that AO was off in the control panel; did you turn it ON to see if that solved the problem. Good Lord, I hope it might be this simple.
NoStall Apr 11, 2013 @ 1:42pm 
Grizol, found this entry in another part of this forum through Google search. Don't know if it is going to help but is worth looking into. Only near the bottom of the current page does anyone talk about the problem and the laser, so it is just another shot at solving the problem.
I HATE to see someone with a system like yours have to play at reduced settings:Shouldn''t happen.
http://forums.steampowered.com/forums/showthread.php?t=2167297
Here's another one.
http://forums.steampowered.com/forums/showthread.php?t=1195080
Let us know if eithere of these (or my earlier morning idea) work and you can play at the very high settings.
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Apr 9, 2013 @ 8:05pm
Posts: 19