Metro 2033 > General Discussions > Topic Details
SurrenderMonkey Apr 3, 2013 @ 7:42am
Why no Vsync?
The graphics are very good but the horrible tearing just ruins everything.
Showing 1-15 of 17 comments
< >
♥Pingas™ Apr 3, 2013 @ 12:05pm 
So tearing ruins everything, but input lag doesn't?
Jammy Bastard Apr 3, 2013 @ 1:50pm 
Force it through the control panel.
Sp0gooter Apr 3, 2013 @ 8:23pm 
how u do it through contol panel?
SurrenderMonkey Apr 4, 2013 @ 8:27am 
Forcing it through the CCC doesn't work....
mooner Apr 6, 2013 @ 3:05pm 
Use D3D overrider
tater-tots Apr 6, 2013 @ 7:43pm 
Rivatuner, which comes with MSI AfterBurner, works. Just click on the wrench and limit the framerate to 60 (or whatever your refresh rate is in Hz)
chingotchcook Apr 7, 2013 @ 11:18am 
Just turn it on in the .cfg files. Google "metro 2033 turn on vsync".
tater-tots Apr 8, 2013 @ 6:33am 
Originally posted by chingotchcook:
Just turn it on in the .cfg files. Google "metro 2033 turn on vsync".

Changing the ini files did NOT work for me. After changing the ini files, it still showed that I was getting 128 fps on my 60Hz monitor. btw, there are 3 ini files that you must change or it will revert back to the defult settings.
Now, I have a HD 7970 and even maxed out, I still get more fps than my monitor can handle. This causes tearing/micro-stuttering/what ever you want to call it. CCC doesn't work in this instance, and neither does altering the ini. files in Metro.
Tox Laximus Apr 8, 2013 @ 1:35pm 
Originally posted by tater-tots:
Originally posted by chingotchcook:
Just turn it on in the .cfg files. Google "metro 2033 turn on vsync".

Changing the ini files did NOT work for me. After changing the ini files, it still showed that I was getting 128 fps on my 60Hz monitor. btw, there are 3 ini files that you must change or it will revert back to the defult settings.
Now, I have a HD 7970 and even maxed out, I still get more fps than my monitor can handle. This causes tearing/micro-stuttering/what ever you want to call it. CCC doesn't work in this instance, and neither does altering the ini. files in Metro.

On my 6870 the only way I could force vsync on with certain games was with D3Doverider, that should work.
tater-tots Apr 8, 2013 @ 5:43pm 
right, same here, that's what Riva Tuner is. The software is included in the Afterburner package that MSI puts out, for free.
spat55 Apr 9, 2013 @ 9:20am 
Originally posted by chingotchcook:
Just turn it on in the .cfg files. Google "metro 2033 turn on vsync".

Not the OP, but I have done that, in all three cfg files, and it still isn't on, why they did put the option in game beats me. The only way to do it is fix it at 60 fps with some program which i couldn't be bummed to do lol.
deltuh Apr 9, 2013 @ 6:41pm 
just lock your fps using fraps or something.
♥Pingas™ Apr 14, 2013 @ 1:14am 
Silly kids and their vsync.
gearsman Aug 29, 2013 @ 6:21pm 
yeah my twin frozer 7850 has less screen tearing on crysis 1-3 then metro 2033
cant stand the screen tearing even oc my card and it didnt help, I dont understand followed it step by step and still didnt work, they're fraking idiots for not having it in the game in the first place, looks like ♥♥♥♥ with screen tearing $!@!#ing idiots!!http://www.gamefaqs.com/boards/935068-metro-2033/53962903
Last edited by gearsman; Aug 29, 2013 @ 7:13pm
Ol' Dirty Bastard Sep 2, 2013 @ 1:45am 
i recommend not using msi afterburner as it causes problems and the gpu monitoring can interfer with games rendering them useless
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Apr 3, 2013 @ 7:42am
Posts: 17