Metro 2033 > General Discussions > Topic Details
[AP] Will Mar 16, 2013 @ 3:52am
Mega, mega, mega, MEGA lag.
I can run pretty much every single one of my games on maximum or very high settings, but Metro 2033? Nope. Incredible lag even on the lowest settings. Help, plz?
Showing 1-5 of 5 comments
< >
HighKillerDK Mar 16, 2013 @ 9:56am 
What specifications do you have?
Metro is a really heavy graphically game.
The Rainmaker Mar 20, 2013 @ 11:38pm 
turn your graphics settings to the lowest? It doesn't help that you dont list your specs... I can max this game but then I have a beast of a machine.
Séamus Mar 21, 2013 @ 3:59pm 
Make sure you have "Advanced DOF" OFF in the directx 11 options. It's a real fps killer.
FunkSausage Mar 22, 2013 @ 1:07am 
Yes turn off advanced DOF, that fixed the problem for me, and the tesselation I believe, ran really smooth after that.
Séamus Mar 22, 2013 @ 2:54pm 
Oh and don't forgot physx in game options.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50

Metro 2033 > General Discussions > Topic Details
Date Posted: Mar 16, 2013 @ 3:52am
Posts: 5