ShouldNotBe Feb 1, 2013 @ 6:55pm
Cannot Join/Play Online
Everytime I host my game does not show up in the list of games. I tried forcing port 27015 in Windows Firewall for Sword of the Stars 2 (It originally had access to all ports) and that did not work. Does anybody know how to fix this?

Also, having somebody direct connect to my IP results in a server not responding error.
Showing 1-5 of 5 comments
< >
[GGS]PureCruncher Feb 2, 2013 @ 8:18am 
I had a similar issue. Are you behind a router?
My router was blocking me. I just opened my ports on the router and it worked fine. I have not touched my windows firewall so I doubt it is that.
Last edited by [GGS]PureCruncher; Feb 2, 2013 @ 8:18am
ShouldNotBe Feb 2, 2013 @ 8:17pm 
Problem fixed, kind of. Now to deal with it crashing in MP.... ):
of Jul 27, 2013 @ 1:48am 
Originally posted by ShouldNotBe ♋:
Problem fixed, kind of. Now to deal with it crashing in MP.... ):

Please tell me how did you fix the problem. I have forwarded port 3369, but it's not working.
ShouldNotBe Jul 27, 2013 @ 8:24am 
Originally posted by of:
Originally posted by ShouldNotBe ♋:
Problem fixed, kind of. Now to deal with it crashing in MP.... ):

Please tell me how did you fix the problem. I have forwarded port 3369, but it's not working.
I honestly don't remember anymore.
FireStorm20 Jul 27, 2013 @ 12:29pm 
Originally posted by of:
Originally posted by ShouldNotBe ♋:
Problem fixed, kind of. Now to deal with it crashing in MP.... ):

Please tell me how did you fix the problem. I have forwarded port 3369, but it's not working.

Port 3369 has got nothing to do with sots 2, the port that need to be forwarded are all on the sots2 launcher....
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Feb 1, 2013 @ 6:55pm
Posts: 5