Hopes Revenge 2013년 1월 16일 오후 8시 26분
Play button on steam doesn't work.
I hit the play button while on steam and the game doesn't start at all it just does nothing. Please help.
22개 중 1-15 표시중
< >
Commodore Dannerson 2013년 1월 17일 오전 4시 42분 
does it open a launcher? have yout tried validating your files? have you tried reinstalling?
Hopes Revenge 2013년 1월 17일 오후 2시 09분 
I hit the play button in steam and it dosn't do anything. I have reinstalled and by validating do you mean the thing in properties under local files that says "varify intregrity of game cache"?
Overread 2013년 1월 17일 오후 3시 42분 
Also double check that your virus scanner or firewall software isn't blocking the exe. I know many programs will break or fail to launch if a firewall jumps up to block or ask for user permission for the program to access the net. Check and make an exception of the exe if needed and then try again.

Also as said do verify the game cache - that should help ensure that the files you have downloaded and instealled are correct and not corrupted (it can happen).


After that check the regular things like that you're using the latest graphics card drivers and so forth (though that shouldn't be a problem in the pre-launcher stage of the game).
Hopes Revenge 2013년 1월 17일 오후 4시 09분 
Is it true you can't play this game on a laptop?
Zane 2013년 1월 17일 오후 4시 19분 
Hopes Revenge님이 먼저 게시:
Is it true you can't play this game on a laptop?

You can, but it should be a gaming laptop with a good graphics card, not just Intel built-in graphics. You'll also need lots of CPU power. Most laptops don't have either.
Hopes Revenge 2013년 1월 17일 오후 4시 36분 
Would that prevent it from starting up at all?
Zane 2013년 1월 17일 오후 5시 06분 
Hopes Revenge님이 먼저 게시:
Would that prevent it from starting up at all?

If your video card support DirectX 10 then it should, it just might be extremely slow.
Hopes Revenge 2013년 1월 17일 오후 5시 32분 
O yeah i have a good laptop since i can run that but it still won't start up at all.
Hopes Revenge 2013년 1월 23일 오후 1시 59분 
Does it mean only directx 10 or can it run on directx 11 of which i have on my laptop? Steam does seem to reconise it started because it brought up that specials things that comes up when you exit a game.
Shadow 2013년 1월 24일 오전 12시 12분 
SotS2 does NOT support Intel HD any version. Having said that I've gotten it to work just fine with HD, HD3000 and HD4000 just fine (if slow). I did however have to update the graphics driver to get to work (apprently the preinstalled HD drivers any any of my three laptops weren't current nor DX10 (or 11) fully compat. until I got the latest drivers).

However, if it's not launching the launcher something else sounds wrong here. The start button in steam doesn't run the "game" but the launcher, which then runs the game. The Launcher is not direct X specific and shouldn't need anything special to run them.

Have you tried installing the direct X, Net, and msvc manually, sometimes steam messes those installs up and the game won't run properly. (they have their own folders in SoTS2 folder).

Hopes Revenge 2013년 1월 24일 오전 4시 56분 
I'm srry that probably whould be very helpful if i knew how to do that.
Shadow 2013년 1월 24일 오후 7시 22분 
Right click on the steam icon (assuming it's on your desktop), and click on properties from the menu that appears (should be last choice).

From that window click the button that says Open File Location (should be to the left above the ok/cancel/apply buttons)

From the window that opens, open the steamapps folder
Now open the common folder
Then open the Sword of the Stars II folder
From here you should see three folders:
directx >> Run dxsetup
msvc2010sp1>> Run vcredist_x86 (vcredist_x64 if you have a 64 bit windows)
netfx4cp>> Run dotNetFx40_Client_x86_x64

Hope that's clear enough.
Shadow님이 마지막으로 수정; 2013년 1월 24일 오후 7시 23분
Hopes Revenge 2013년 1월 24일 오후 7시 42분 
Ther seems to be a problem with the netfxcp.
Number of applicable items: 4
Exe (C:\083f0f45af52e861e6\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
MSI (C:\083f0f45af52e861e6\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Client Profile Setup_20130124_213750980-MSI_netfx_Core_x64.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:01:44).

also it says it stoped working after i closed it.
Shadow 2013년 1월 26일 오전 11시 37분 
A silly question, are you using windows vista, win 7 or win 8?
Hopes Revenge 2013년 1월 26일 오후 12시 26분 
windows 7
22개 중 1-15 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 1월 16일 오후 8시 26분
게시글: 22