Sword of the Stars II: Enhanced Edition

Sword of the Stars II: Enhanced Edition

View Stats:
CommodoreZ Dec 5, 2012 @ 10:26pm
New Modules Problems
Today after experimenting with the Loa for a while I decided that it would be fun to try out the new cybernetics tech tree with an organic race to see what had been added. I selected humans and eventually got the Abbadon laser, Remilliard, and Sjet modules. I tried putting them on my ships but nothing happened. The only ship that they appeared on was the heavy missile section. Bringing a heavy missile ship wouldn't have been very advantageous to me (my hiver enemy was using deflectors and was point defense heavy) so I added them to the standard armor vessel and hoped that it was just a graphical issue and that the effects would still be present. When I went into combat with my new ship it had some peculier effects. The usual grey camo on my ships (I was using the immersion pack. Maybe that was why?) was replaced with shining bright texture. The abbadon wouldn't fire and I noticed no benefits from the remilliard on my ships with xavier modules. The game crashed after I tested the Sjet (although this may have been random since, other than that, I had the same effects as with the other two which caused no crash.) Is this the same with the other races? I really want to test out that Abaddon cannon.
< >
Showing 1-2 of 2 comments
Honorable_D Dec 6, 2012 @ 1:39am 
I think that cannon is a psy ability and you need to click to hold like other psy powers in order for it to continue to fire.

You're not the first report that the new cyber modules don't render properly on most ship sections, gotta be a bug and I'm sure it'll get fixed up eventually.
CommodoreZ Dec 6, 2012 @ 11:20am 
I know that the cannon is a psi-ability. I've tried clicking and holding to see if anything will happeen but nothing does. So far I don't think cybernetics is worth pursuing.
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Date Posted: Dec 5, 2012 @ 10:26pm
Posts: 2