Magicka > General Discussions > Topic Details
A. Pajander Aug 20, 2013 @ 10:27am
Has anyone tried local co-op with two Xbox 360 controllers?
We tried playing local co-op with an Xbox 360 controller and a Logitech Rumblepad (both wireless) and the controls constantly get "stuck" for 2-3 seconds, so you end up running off cliffs since you can't turn etc. Seems to happen more often when there's more stuff going on in the game. It affects both players at the same time.

I might end up buying another X360 controller anyway, but I'm wondering if anyone has experienced that issue with two X360 controllers.
Last edited by A. Pajander; Aug 20, 2013 @ 4:38pm
< >
Showing 1-5 of 5 comments
T@F Aug 20, 2013 @ 12:48pm 
looks like the joypad is bugged.
I'v never had a prob with mine,but i have not played it in ages,booted it up today only to find soon as i click joypad crash to desktop.
So imo the devs needs to look into why the joypads are messing up.
A. Pajander Aug 20, 2013 @ 4:40pm 
Yeah, I also have that "crashes if you touch the analog stick in the main menu" but that's... manageable I guess.
Nequis Aug 21, 2013 @ 5:32am 
Never ever had problems with 360 controllers,maybe it is your logitech one.
A. Pajander Aug 21, 2013 @ 1:46pm 
Yeah might as well buy a second X360 one. That's the only pad PC games are actually tested on, if even that.
Wezilla Aug 22, 2013 @ 1:46am 
Yes new bug as recently sadly please fix 360 controller bugged in the menu...
Last edited by Wezilla; Aug 22, 2013 @ 1:46am
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Magicka > General Discussions > Topic Details
Date Posted: Aug 20, 2013 @ 10:27am
Posts: 5