Magicka > General Discussions > Topic Details
Random Geek Lord Apr 2, 2013 @ 12:36am
Magicka Loading Crash
I just got the Magicka 4-pack, along with a few DLC's. (namely Nippon, Final Frontier, and Vietnam if that means anything). But I'm having trouble playing it.
When I try to play Magicka, the game load up fine until I try to start a game. After the intro cutscene, it starts to load the game, then it just turns off. It doesn't give me an error message or anything. It just shuts off.
Can someone help me please?
Game Version is 1.4.14.0, if that helps
Showing 1-10 of 10 comments
< >
Random Geek Lord Apr 2, 2013 @ 12:38am 
Almost forgot, Computer is Windows 7 64 bit
Random Geek Lord Apr 2, 2013 @ 12:45am 
And I have already tried the arcane slimecube fix, and there's been no change. It still just shuts off.
You could've found your answer here already: http://steamcommunity.com/app/42910/discussions/0/864949719232276054/

go to the following directory on your computer and run DXSETUP.exe ...\Steam\SteamApps\common\magicka\Dependencies\directx_feb2010
Last edited by [Lemons] w!z@rD (◜◡^)つ━☆・*; Apr 2, 2013 @ 12:53am
Random Geek Lord Apr 2, 2013 @ 1:01am 
Thank you, but it didn't do anything. It still just closes when the game loads even after I ran DXSETUP.exe
Hrm, then vo to the magicka directory, sarch for the latest errerReport text file and copy/paste the content here.
Random Geek Lord Apr 2, 2013 @ 1:12am 
Version: 1.4.14.0 Thread: LoaderThread


Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "c:\program files (x86)\steam\steamapps\common\magicka\content\data\characters\cross". This is not a compiled content file.
at Microsoft.Xna.Framework.Content.ContentReader.PrepareStream(Stream input, String assetName)
at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
at Magicka.SharedContentManager.CommonContentManager.Load[T](String assetName)
at Magicka.SharedContentManager.Load[T](String assetName)
at Magicka.GameLogic.Entities.Abilities.SpecialAbilities.SummonCross.InitializeCache(Int32 iNr, PlayState iPlayState)
at Magicka.GameLogic.Spells.Magick.InitializeMagicks(PlayState iPlayState)
at Magicka.GameLogic.GameStates.PlayState.Initialize()
at Magicka.Game.LoaderFunction()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()


0x0066 Microsoft.Xna.Framework.dll->Microsoft.Xna.Framework.Content.ContentReader.PrepareStream
0x002f Microsoft.Xna.Framework.dll->Microsoft.Xna.Framework.Content.ContentManager.ReadAsset
0x002b Magicka.exe->Magicka.SharedContentManager+CommonContentManager.Load
0x0008 Magicka.exe->Magicka.SharedContentManager.Load
0x0000 Magicka.exe->Magicka.GameLogic.Entities.Abilities.SpecialAbilities.SummonCross.InitializeCache
0x017a Magicka.exe->Magicka.GameLogic.Spells.Magick.InitializeMagicks
0x031f Magicka.exe->Magicka.GameLogic.GameStates.PlayState.Initialize
0x003a Magicka.exe->Magicka.Game.LoaderFunction
0x003b CommonLanguageRuntimeLibrary->System.Threading.ThreadHelper.ThreadStart_Context
0x005f CommonLanguageRuntimeLibrary->System.Threading.ExecutionContext.Run
0x002a CommonLanguageRuntimeLibrary->System.Threading.ThreadHelper.ThreadStart
Do this:
Steam Library\right click Magicka\Propeties\Local Files\Verify integrity of Game Cache.
Random Geek Lord Apr 2, 2013 @ 1:26am 
Thank you, that seems to have done the trick for now.
winiethepu2 Aug 23, 2013 @ 1:31pm 
hey i have a little problem too when i go to start magicka it gives me a loading icon on my mouse then it just goes away and if i click it again it says its alredy running
Veggieguy Aug 24, 2013 @ 4:47pm 
I did that to my magicka and it says 1 file is missing and will be reccquired. when will i get it?
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Apr 2, 2013 @ 12:36am
Posts: 10