Singularity > General Discussions > Topic Details
Nubec Mar 26 @ 11:33am
Why don't run my game ?
I launch this game, no show icon in window's bar, my avatar's profile turn green 10 seconds and blue again, and game don't run. Why? Please, I need help with this.
Showing 1-15 of 17 comments
< >
Scipi Mar 26 @ 2:43pm 
Try running it from the Steam client. If that doesn't work, try validating the game's cache.
Nubec Mar 26 @ 3:10pm 
I did it. Same, ArcaniA -Gothic 4 don't run, but other games yes :(
brent41284 Apr 22 @ 8:06pm 
Did u ever get the game to work? cuz i just bought it digital download and am having the same problem. nothing loads for me.
Nubec Apr 23 @ 11:09am 
No executed before.
CalmDownMonkey May 1 @ 11:00am 
Anyone with Windows 8.1 managed to get this to work? Same problem as OP.
samuel6885 May 1 @ 11:22am 
Originally posted by Nubec:
I launch this game, no show icon in window's bar, my avatar's profile turn green 10 seconds and blue again, and game don't run. Why? Please, I need help with this.

Im using windows 7 and the game won't even show up on my libary, 10 seconds after I bought it! I know I've got it because I go on the store page and it says I own it then stops steam when I try to play it.

Last edited by samuel6885; May 1 @ 11:23am
Rafz May 1 @ 5:58pm 
same problem here
Rafz May 1 @ 6:25pm 
i uninstalled physX and it worked
sir_voe May 1 @ 7:32pm 
Wasn't loading on my windows 7 machine either post setup. I restarted my computer, verified the game files and now it's working just fine.
♥samantha♥ May 1 @ 7:34pm 
Originally posted by Rafz:
i uninstalled physX and it worked

Yes I had a old version of physX installed from another game, and had to re-install my video card drivers, just to get the latest physX drivers, now Singularity works.
Most of the time when games dont run or crash it's the fault of PhysX, Turok 2008, and Wolfenstein 2009 doesn't run with me unless I down grade the physX drivers.
Angrydroid May 1 @ 10:30pm 
same here dowloaded from steam installed and wont open or anything tried running it in admin mode but nothing steam says to clear the the cacheapp in the steam files but i looked and didnt find anything close to that please help because steam wont! thanks
Saymens May 2 @ 12:36am 
i've been looking at various stuff via google and tried all diffrent kind of solutions, but none worked. Hope someone will find a solution to this, because this is pretty annoying wasting money on stuff that dont work.
VinteR May 2 @ 12:56am 
The solution for me is reinstall latest version of PhysX manually after the game tried to install an old version.
Saymens May 2 @ 1:00am 
Didn't help for me unfortunate.
♥samantha♥ May 2 @ 1:14am 
Originally posted by Vinte.R:
The solution for me is reinstall latest version of PhysX manually after the game tried to install an old version.
Correct has I said above that worked for me.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50