Krater > General Discussions > Topic Details
RAWRGRIZZLYOMNOM Oct 25, 2012 @ 8:39pm
Data Execution Prevention
Whenever I try to launch Krater Data Execution Prevention shuts the game down before it can launch. However I can't add Krater to the ignore list because it apparently can't run with out it? Is there anyway to fix this?
Showing 1-15 of 17 comments
< >
wiredhands Oct 26, 2012 @ 4:40am 
just a maybe stupid question, you are running it in windows vista or windows 7 ?

Because windows XP is not supported by the game
RAWRGRIZZLYOMNOM Oct 26, 2012 @ 2:29pm 
I'm on vista, probably should have said that in the first place anyway.
wiredhands Oct 26, 2012 @ 7:14pm 
Steam support suggests the following

https://support.steampowered.com/kb_article.php?ref=7169-TIAV-5361

look for the area about DEP or Data Execution Prevention
RAWRGRIZZLYOMNOM Oct 26, 2012 @ 7:21pm 
Originally posted by wiredhands:
Steam support suggests the following

https://support.steampowered.com/kb_article.php?ref=7169-TIAV-5361

look for the area about DEP or Data Execution Prevention

As said before, when I try to add Krater it tells me that Krater will not launch without it.
wiredhands Oct 27, 2012 @ 6:04am 
oh lol im an idiot..way to go to not read things properly you old fool Wired and suggest what you already tried..

Have you tried right clicking on Krater and setting it to run as administrator ?
Are your Vista fully updated ? there are some of the updates for vista that are mandatory for Krater to run (I unfortunately can't remember which ones, sorry)
RAWRGRIZZLYOMNOM Oct 30, 2012 @ 2:58pm 
Originally posted by wiredhands:
Are your Vista fully updated ? there are some of the updates for vista that are mandatory for Krater to run (I unfortunately can't remember which ones, sorry)
Ah yep, this seems to have been the problem, windows stopped downloading updates a while ago for some reason, thanks for your help!
Bantustan Dec 6, 2012 @ 8:15pm 
I have the same problem. TO the top.

and TrippleD needs to kill himself already. What kind of mod bans/deletes threads where someone is trying to find a solution to a bug in the client? Really?
wiredhands Dec 7, 2012 @ 4:18am 
who is TrippleD ?

Anyway if you have Vista maybe this is the solution for you too

Originally posted by RAWRGRIZZLYOMNOM:
Originally posted by wiredhands:
Are your Vista fully updated ? there are some of the updates for vista that are mandatory for Krater to run (I unfortunately can't remember which ones, sorry)
Ah yep, this seems to have been the problem, windows stopped downloading updates a while ago for some reason, thanks for your help!
Blastmetal Dec 7, 2012 @ 10:54am 
Iv got the same problem but iv got Windows 7 and my game won't launch i tried the thing that was advised on the top also tried some other stuff but this game keeps failing, and iv got precisely the same problem with shogun totalwar 2 witch also won't launch.
wiredhands Dec 7, 2012 @ 12:00pm 
you tried the suggestion for DEP in the link I posted from steam support ?

Data Execution Prevention

Go to Start > Control Panel > System > Advanced > Performance > Data Execution Prevention.

Select "Turn on DEP for all programs and services except those I select:"

Select "Add", navigate to C:\Program Files\Steam (or your default Steam directory), and add Steam.exe to the exception list.

Additionally, you will need to add the executable (hl2.exe, for example) for any game you are seeing issues with. These files will either be in Steam\steamapps\common\<Game Title> or in \Steam\steamapps\<Your Steam Account Name>\<Game Title>\


the above is what is suggested by steam support for DEP problems.
If it doesn't work and your windows is fully updated then I'm not sure what could be causing it.

Have you tried running steam as administrator ? (rightclick and select run as administrator)
Last edited by wiredhands; Dec 7, 2012 @ 12:02pm
Blastmetal Dec 7, 2012 @ 1:17pm 
yup yup and yup i can't point the problem with shogun iv got the same thing but thats because it won't create the developers file after installation this could be the same thing.
wiredhands Dec 7, 2012 @ 4:15pm 
if it is that with Krater..try setting

run_game.exe in the x:\Program Files (x86)\Steam\steamapps\common\krater folder to run as administrator, rightclick, properties, compability selecte run as administrator, apply and ok and the ntry running it from steam

either that one or Krater.exe, but since run_game.exe is run before Krater.exe i think that might be the one you need to set as run as admin
Last edited by wiredhands; Dec 7, 2012 @ 4:17pm
Blastmetal Dec 8, 2012 @ 12:31am 
its giving me the finger in this way....

Krater.exe - Invallid Installment copy.

C:\Windows\system32\D3DCompiler_42.ddl is not suited for Windows or contains an error. Try to reinstall the program with the original media or contact the software suppliers.

This is the same error im getting with Shogun total war 2 and with a couple of other games i downloaded from steam and its annoying as hell.
Last edited by Blastmetal; Dec 8, 2012 @ 12:34am
wiredhands Dec 8, 2012 @ 2:40am 
Well..as far as I can read on the internet, this particular error type can be from a corrupted windows installation, I mean this one :C:\Windows\system32\D3DCompiler_42.ddl is not suited for Windows or contains an error. 1 solution is to re install windows (and possibly fastest), but for most this is not an option.

First option is to just normally check you have the latest gfx card drivers installed and the latest dx drivers. Just download and install should be easy enough.


if you are a little tech knowledgeable you could try what i suggest below(if you are not, do NOT attempt this as it can break your windows installation if you delete stuff in the registry that does not like being deleted)

download latest driver for your graphic card, and the latest webinstall from direct x, and a driver sweeper
Go into safemode, uninstall your gfx card driver, then use the driver sweeper to make sure its gone
uninstall direct x via the registry, (run->regedit->to registry key "HKEY_LOCAL_MACHINE\Software\Microsoft\DirectX", rightclick and choose delete).

reboot into normal windows

use the webinstall to reinstall DX, make sure you are administrator when you do it, reboot when done.
then install your gfx card drivers
reboot and get your gfx card settings correcly
try running the game

Again don't do this unless you know what you are doing, if you delete the wrong things you may be forced to reinstall windows, so thread carefully
Last edited by wiredhands; Dec 8, 2012 @ 2:43am
Blastmetal Dec 8, 2012 @ 3:10am 
Thnx for heads up but i dont have a new windows on standby i need to rebuy a windows my last windows was a discard from a friend of mine.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Oct 25, 2012 @ 8:39pm
Posts: 17