Krater > General Discussions > Topic Details
City Builder Jan 7, 2013 @ 6:36pm
Krater crashes when using "stomp" skill.
Hi,
I played Krater a couple days ago and it was fine, I've not changed any settings in the game since then, nor in Windows, nor done any Windows updates since then.

Now however every single time that I press the skill associated with the 2 key (stomp), the game immediately crashes with no crash message, it simply closes.

I don't quite understand why the game played perfectly fine 2 days ago and now it crashes every single time I press the 2 key to use that skill associated with it. Oh and regardless if I press the 2 key or click the stomp icon it does the same thing.

Windows event viewer provides no log for the crashes.


Edit, this did not start happening until I accepted the villahund quest. Also when I am in town and press the 2 key, the stomp skill fires off and the game does not crash/exit, however when I go back to the underground where the hunds are located and use the stomp skill the game does crash. Perhaps something related to the villahund quest and the stomp skill?
Last edited by City Builder; Jan 10, 2013 @ 2:39pm
Showing 1-15 of 16 comments
< >
[Fatshark]LiVam  [developer] Jan 8, 2013 @ 12:47am 
Could you post a log of this please?

First reproduce the crash, then browse to
%appdata%\Fatshark\Krater\console_logs\
and select the latest log.

You can upload this log to pastebin or a similar site.

Cheers,
LiVam - Fatshark QA
City Builder Jan 8, 2013 @ 1:18am 
Last edited by City Builder; Jan 8, 2013 @ 1:19am
wiredhands Jan 8, 2013 @ 4:17am 
have you tried going to another dungeon and using it there ?

I'll almost bet that you crashing is related to the achievement called 'Hound Slayer' (or caused somehow by whichever thing they use to keep track of these achievements)
Last edited by wiredhands; Jan 8, 2013 @ 4:18am
City Builder Jan 8, 2013 @ 10:22am 
No, but I'll try that. I'm only into the beginning of this playthrough for a live stream that I've been doing.
City Builder Jan 8, 2013 @ 9:04pm 
Okay so I tried using Stomp in the "freedigger" basement (underground basically) and it did not crash the game. So I'm guessing this has to do with what wiredhands mentioned above about the Hound Slayer achievement maybe?

Do I have to only avoid the first dungeon where the game crashes to avoid this bug or are there other known areas in the game that I have to now avoid to avoid crashing the game?
wiredhands Jan 9, 2013 @ 5:23am 
Well I took a look at the log you supplied instead of just guessing, and I'm even more sure now that I'm right about the achievement thing being the cause of the crash...since it crashes with

scripts/achievements/achievement_manager.lua:40: Cannot get state of achievement 1

so I'm pretty sure the achievement is to blame somehow

Does it only happen when you use stomp or it is triggered by anything that kills one of the dogs ?
[Fatshark]LiVam  [developer] Jan 10, 2013 @ 1:01am 
I've been trying to reproduce this but am unable to.
You could try verifying the game files
Steam Library->Krater->Right-click->Properties->Local Files->Verify Game Cache
or Reinstalling.

Occasionaly some files may not be installed properly through Steam, this could be causing your issue. If you still have problems after that feel free to contact me at liam.oneill@fatshark.se

Cheers,
LiVam - Fatshark QA
wiredhands Jan 10, 2013 @ 4:05am 
I'm pretty sure the crash can't be reproduced on a profile that already have the steam achievement. If you haven't already done it, try on one that doesn't have the hound slayer steam achievement
I tried to reproduce it on my account, but since I already have the achievement nothing happened
Last edited by wiredhands; Jan 10, 2013 @ 4:06am
wiredhands Jan 10, 2013 @ 4:23am 
I just thought of something.
CB do you play in offline mode ?
I have an idea that the crash might happen if the ingame achievement checker can't reach steam to see/set the current state of the achievement. Ofc this is all speculation on my part since I don't know how it actually works behind the scenes.
I base it on
scripts/achievements/achievement_manager.lua:40: Cannot get state of achievement

error, which somehow seems like either you cant contact steam about the achievement or if FS keeps a tracking file locally somehow you are not allowed to write/read it.

Might also be that for some of the achievements, the reading routine is doing something wrong and expecting a default value if this is the first time something happens in the achievement and it can't find it
City Builder Jan 10, 2013 @ 2:35pm 
No, I'm pretty sure that I'm playing in Steam online mode since there is the option until the Steam word to go offline which I haven't used in probably a couple years now.

II continued to play further into the game and have not had a crash again, so after a few hours I went back to the original dungeon and used Stomp and BOOM-BANG-SMACK - Game crashed to desktop without notification.
City Builder Jan 10, 2013 @ 2:39pm 
Oh and according to Steam I have the hound slayer achievement, I'm guessing I picked that up further into the game so next time I stream I'll go back to the original dungeon and see if it still crashes.
City Builder Jan 10, 2013 @ 2:49pm 
Okay, I tried it out (just couldn't sit here wondering...) and went back to the first underground area (sorry can't remember the name let alone spell it) and set off stomp many times and now the game no longer crashes. (it's the underground area outside of the first town, NOT the basement with the rats where this crash continually reproduced itself for me)

I hate to guess, but I'm going to anyway, probably what wiredhands said earlier about a problem with the achievement (yes, I'm playing online) and now that I've gotten the achievement elsewhere in the game, going back to the original dungeon where stomp always produced a crash once I took on the hund quest is no longer crashing becauise I've now got the achievement.

Hopefully this will help Fatshark to try to pin down this dastardly CTD bug.

Oh and obviously it's not a problem with the game files, it's a problem with the game code itself since I did NOT need to verify the game files or re-install the game.
Last edited by City Builder; Jan 10, 2013 @ 2:52pm
[Fatshark]LiVam  [developer] Jan 11, 2013 @ 12:40am 
Thanks for the information City Builder,
I did try reproducing this on an account that didn't have the achievement, so it's odd I'm not running in to the same issue. Nevertheless, I've taken note of this and hopefully we can fix it if we figure out what's wrong.

Appreciate the effort in reporting!
Cheers,
LiVam - Fatshark QA
A Flying Mystical Frog Jan 12, 2013 @ 11:11pm 
hi i dont have this game
lomaxgnome Jul 30, 2013 @ 11:49pm 
Just wanted to say that six months later, this exact crash bug is still happening, as it has happened to me multiple times tonight. The game seems to have potential, but it seems the universally bad reviews because of bugs and instability are quickly proving to be accurate.

Update: from what I can tell, the bug happens only on Murkmala level 3. Going back up to level 1 (which had respawned due to the crashing), I was able to kill the last hound, get the achievement, and the proceed as normal. Truly an odd bug, but still disappointing that it was never corrected.
Last edited by lomaxgnome; Jul 31, 2013 @ 12:06am
Showing 1-15 of 16 comments
< >
Per page: 15 30 50
Date Posted: Jan 7, 2013 @ 6:36pm
Posts: 16