Krater > General Discussions > Topic Details
Psian Dec 1, 2012 @ 11:00pm
"Not really Fullscreen" and Cursor not pointing in right place.
I just installed Win 8 and reinstalled Krater. Now although in the settings menu it says I am in full screen, the task bar is still at the bottom of the page and I cannot click directly on any of the menu options in the title screen. What I mean by this is that I need to click about 20 pixels lower than the button.
I managed to change the setting from fullscreen to "disabled" but now I cant click anything at all.
Any ideas?

Win 8
GeForce GTX 560

Update: it does go into windowed mode but now my cursor is pointing about 100 pixels left of buttons...
Last edited by Psian; Dec 1, 2012 @ 11:10pm
Showing 1-5 of 5 comments
< >
wiredhands Dec 2, 2012 @ 3:29am 
as far as I know Krater is not officially tested nor supported in windows 8 yet and the steam store does only list Vista and Win 7 as supported.

However one would think that since it supports Vista and Win 7 it should work for win 8 right out of the box (but nothing is truly 100% certain and there are usually things that need to be worked on with new OS's)

In fullscreen setting aspect ratio to Auto should fix the mouse is off by x pixels problem (it does in win7 and vista, so hopefully should work in Win 8 too)
For the taskbar still being visible you can try ALT+Enter which brings it in an out of fullscreen mode (default windows behaviour).
I don't know if windows 8 like win 7 have desktop overlays, like for example bing desktop, but these have been known to cause problems with Krater. So turning them off could be an option.

for windowed mode and yyy pixels off try what another user did, might work for you :

In windowed mode the window for the game put it flush with the top of the screen, obscuring the window header, this then offest the mouse by the width of the taskbar. Grabbing the exact pixel on the side of the screen was able to snap the window down as it maintained aspect ratio. Mouse is working normally now.

Not sure it is very clear, I think it's about making the games window 'snap' to the border or the taskbar in normal windows way when in windowed mode and then the mouse will get the right bearings..

anyway, do post if any of the suggestions work since win 8 is relatively unexplored
Psian Dec 2, 2012 @ 4:09am 
Setting the aspect ratio to auto works! Cursor fixed.

Now that the cursor is fixed I can play the game in fullscreen but the task bar is still there.
Psian Dec 2, 2012 @ 5:13am 
ok rebooted... twice!?.. for another problem... the fullscreen is properly full screen now.
Wmply_Nig Mar 6, 2014 @ 11:10am 
Just got this game and I'm getting the task bar issue. I have found a fix - Reset the screen resolution to anything other than the default chosen one and then change back again. Unfortunately, this needs to be done at the start of every game.
chrislynx Jun 27, 2014 @ 6:27pm 
I have this problem too. Whenever I alt-tab to look something up or read an email it goes into windowed mode. Even if I switch it back to fullscreen the mouse is offset. So far I can fix it by changing Aspect Ratio to the actual ratio if it was Auto, or Auto if it was the actual ratio (basically toggling it to reset it.)
Showing 1-5 of 5 comments
< >
Per page: 15 30 50