d10sfan 7. März 2013 um 12:02 Uhr
Linux Version & DLC Not appearing
Just downloaded the game on Linux steam (showed up in the game library) but the DLC dosen't appear to be in the game (store says I have it). Is it planned for that to be in the Linux version?
Beiträge 1-15 von 22
< >
[LINUX] Liam 8. März 2013 um 10:25 Uhr 
The DLC is not supported under Linux sadly.
Nexus 9. März 2013 um 17:41 Uhr 
The DLC isn't officially supported under Linux Steam (yet I hope)

But you could convert windows DLC to linux version (new races and campaign)

Please look at thread:

http://positech.co.uk/forums/phpBB3/viewtopic.php?f=29&t=6842
Zuletzt bearbeitet von Nexus; 10. März 2013 um 1:06 Uhr
cliffski  [Entwickler] 10. März 2013 um 0:40 Uhr 
Indeed, I think it's only the file format of some graphics that need changing, the DLC is just data, not code, but the very latest (outcasts) DLC required code not in the linux build, AFAIK, but apart from that, it should be easy to manually get the other DLC to work.
d10sfan 10. März 2013 um 21:32 Uhr 
Ok, there a way to download the DLC without using Windows steam (wine) or is that my best option?

Also, are there plans to add the DLC to the Linux build?
[ARCH] perlmut 12. März 2013 um 9:54 Uhr 
You guys should not support them with money until they release it for linux ... -.-
edgley][linux 12. März 2013 um 12:14 Uhr 
Ursprünglich geschrieben von cliffski:
Indeed, I think it's only the file format of some graphics that need changing, the DLC is just data, not code, but the very latest (outcasts) DLC required code not in the linux build, AFAIK, but apart from that, it should be easy to manually get the other DLC to work.

Just out of interest, if all other DLC's are compatible and it would just be a case of extracting the files in the right place -- surely Linux support for the rest of them (excluding Outcasts) would be trivial?

Even if -- like in the forum thread posted above -- you required to convert dds to png, what's stopping it? I can convert all dds recursively to png using imagemagic in a 5 second shell command (the guy who posted that even gave the exact command he used).

Not trying to be rude, as I said previously I would buy the DLC in a heartbeat if released :)
cliffski  [Entwickler] 13. März 2013 um 15:02 Uhr 
I don't have a linux pc, or experience with linux, or indeed time to get involved in it at the moment, but at some stage I would like to do exactly that, have it tested, and make the DLC officially available under linux. It just has not happened yet.
d10sfan 13. März 2013 um 15:30 Uhr 
Ursprünglich geschrieben von cliffski:
I don't have a linux pc, or experience with linux, or indeed time to get involved in it at the moment, but at some stage I would like to do exactly that, have it tested, and make the DLC officially available under linux. It just has not happened yet.
Have you tried using a VM (would only really help the first problem though)?
[LINUX] Liam 13. März 2013 um 15:43 Uhr 
You don't need to have a "linux pc" Linux can be booted along side windows or mac...or even all 3 together on one machine.
[ARCH] perlmut 13. März 2013 um 17:13 Uhr 
Ursprünglich geschrieben von cliffski:
I don't have a linux pc, or experience with linux, or indeed time to get involved in it at the moment, but at some stage I would like to do exactly that, have it tested, and make the DLC officially available under linux. It just has not happened yet.
I really like GSP. Id love to play purchase DLCs. Purchase means i would spent money - money getting to you. Sadly Linux users are third class users, the game doesnt even need to be up-to-date and their money doesnt seem to be very attractive.

I can guess your in the middle of an awkward situation: A 3 year old game very likely programmed with a MS Windows compiler within a MS Windows IDE. How did it come to different formats of the DLCs? Such things really shouldnt be platform dependent! More than that you have propably much more exciting projects planned promising more money and the Humble Bundle Linux Version duty is just annoying.
I contrast to that: Hello, i am a not very happy customer with an outdated main program. :'(

BTW: Installing any linux shouldnt be that hard for a talented game designer like you.
Zuletzt bearbeitet von [ARCH] perlmut; 13. März 2013 um 17:17 Uhr
not_kevin 10. Apr. 2013 um 6:20 Uhr 
It doesn't make any sense why you can't distribute a sprite based game more elegantly. There were games like this in the 90s where we could insert our own sprites. I'm just going to stop playing your game now, because you made this an issue I had to think about.
d10sfan 10. Apr. 2013 um 8:47 Uhr 
Anything new here? Would it be possible to at least support the DLC that dosen't require code changes?
[LINUX] Liam 3. Juni 2013 um 13:27 Uhr 
So it's been a few months, the DLC is still listed, what is happening?
UbuntuIsFriendly 29. Juli 2013 um 0:45 Uhr 
Ursprünglich geschrieben von =(eG)= d10sfan:
Anything new here? Would it be possible to at least support the DLC that dosen't require code changes?

Any news on this?
d10sfan 12. Sep. 2013 um 7:44 Uhr 
Anything new on this?
Beiträge 1-15 von 22
< >
Pro Seite: 15 30 50