GideonKain Jan 29, 2013 @ 12:41am
Most infuriating ♥♥♥♥♥♥*T ever!
I have downloaded and installed Stalker Call of Pripyat over 10 times today, I AM NOT EXAGGERATING...I have downloaded over 30gb of data today.

I download it, install it, start the game everything works fine. But as soon as I try to start it up a second time I get the "xrengine 1.6 stopped working" error, and nothing else.
I have the system requirements
I have direct X and VC++ Runtimes
I have tried to upgrade EXE to 3gb memory header
-new install-
I have installed Complete mod
-new install-
I have installed Misery Mod
-new install-
I have changed Sound device from Generic Hardware to Generic Sotware
-new install-
I have run it as Admin Mode
-new install-
I have made sure compatibility mode is off
-new install-
I have disabled Steam Overlay
-new install-
I have deleted USER.ltx from base directory and from _appdata_ directory
-new install-
I have checked, and no user.ltx gets generated anywhere else on my computer - not in Users\Public or my current Users\Ryan folders

...nothing works.

Every single time I want to play this game I have to delete the entire game and re download the 3 GB game files

This is completely ridiculous.

A few threads have mentioned deleting a sound driver...but never go into specifics.

My log file aends with multiple errors depending upon which "solution" I try, but most commonly:

FATAL ERROR

[error]Expression : fatal error
[error]Function : out_of_memory_handler
[error]File : D:\prog_repository\sources\trunk\xrCore\xrDebugNew.cpp
[error]Line : 336
[error]Description : <no expression>
[error]Arguments : Out of memory. Memory request: 0 K

The company that made this game is out of business, so I really can't be expected to contact their customer support.

Please, please please...if you have anything to add to my plea, please do so.
This is one of my favorite games of all time, yet it is completely unplayable unless I plan to play the entirety of the game in one sitting with no mods or changes to the Video configurations.

Most infuriating ♥♥♥♥♥♥*T ever!

Help me, I'm begging you.

* Detected CPU: AMD Phenom(tm) 9950 Quad-Core Processor [AuthenticAMD], F15/M2/S3, 2609.00 mhz, 69-clk 'rdtsc'
* CPU features: RDTSC, MMX, SSE, SSE2, SSE3, MONITOR/MWAIT
* CPU threads: 4

Initializing File System...
using fs-ltx fsgame.ltx
FS: 39048 files cached 29 archives, 7675Kb memory used.
Init FileSystem 1.963525 sec
'xrCore' build 3967, Dec 14 2009

EH: C3F91E466048C9CFDE405970F8B6A87B

-----loading d:\games\steam\steamapps\common\stalker call of pripyat\gamedata\configs\system.ltx
-----loading d:\games\steam\steamapps\common\stalker call of pripyat\gamedata\configs\system.ltx
Initializing Engine...
Starting INPUT device...
Loading DLL: xrRender_R2.dll
Loading DLL: xrRender_R3.dll
refCount:m_pAdapter 1
Loading DLL: xrRender_R4.dll
command line
Executing config-script "user.ltx"...
! Cannot open script file [user.ltx]
Loading DLL: xrRender_R1.dll
Loading DLL: xrGame.dll
* [win32]: free[3949148 K], reserved[100100 K], committed[144992 K]
* [ D3D ]: textures[0 K]
* [x-ray]: crt heap[13596 K], process heap[4131 K], game lua[0 K], render[0 K]
* [x-ray]: economy: strings[8027 K], smem[0 K]
SOUND: OpenAL: enumerate devices...
SOUND: OpenAL: EnumerationExtension Present
dir[0]=D:\Games\Steam\steamapps\common\Stalker Call of Pripyat\bin\
dir[1]=D:\Games\Steam\steamapps\common\Stalker Call of Pripyat\
dir[2]=D:\Games\Steam\steamapps\common\Stalker Call of Pripyat\bin\
dir[3]=C:\Windows\system32\
CleanDeviceSpecifierList
CleanDeviceSpecifierList Generic Hardware
devices Generic Hardware
SOUND: OpenAL: system default SndDevice name is 1 - Digital Display Audio (AMD
SOUND: OpenAL: All available devices:
1. Generic Software, Spec Version 1.1 eax[0] efx[no] xram[no]
2. Generic Software, Spec Version 1.1 eax[0] efx[no] xram[no]
3. 1 - Digital Display Audio (AMD High Definition Audio Device), Spec Version 1.1 eax[2] efx[no] xram[no]
4. Digital Output (SoundMAX Integrated Digital HD Audio), Spec Version 1.1 eax[2] efx[no] xram[no]
5. Speakers (SoundMAX Integrated Digital HD Audio), Spec Version 1.1 eax[2] efx[no] xram[no]
6. SPDIF Interface (SoundMAX Integrated Digital HD Audio), Spec Version 1.1 eax[2] efx[no] xram[no]
7. Speakers (Logitech G930 Headset), Spec Version 1.1 eax[2] efx[no] xram[no]
Executing config-script "d:\games\steam\steamapps\common\stalker call of pripyat\gamedata\configs\default_controls.ltx"...
[d:\games\steam\steamapps\common\stalker call of pripyat\gamedata\configs\default_controls.ltx] successfully loaded.
Executing config-script "user.ltx"...
! Cannot open script file [user.ltx]
SOUND: Selected device is Generic Software
* sound: EAX 2.0 extension: absent
* sound: EAX 2.0 deferred: absent
* sound : cache: 65537 kb, 4856 lines, 13820 bpl
Starting RENDER device...
* GPU [vendor:1002]-[device:68BA]: AMD Radeon HD 6700 Series
* GPU driver: 8.17.10.1172
* CREATE: DeviceREF: 1
* Vertex Processor: PURE HARDWARE
* Texture memory: 747 M
* DDI-level: 9.0
* GPU shading: vs(fffe0300/3.0/30), ps(ffff0300/3.0/30)
* GPU vertex cache: unrecognized, 16
* NVAPI is missing.
* Starting rendering as 2-GPU.
* DVB created: 1536K
* DIB created: 512K
* distortion: used, dev(30),need(14)
* color_mapping: used, dev(30),need(14)
* SSample: 1024x768
compiling shader postprocess
compiling shader postprocess_d
compiling shader postprocess_cm_pre
* SSample: enabled
compiling shader particle_distort
compiling shader particle
compiling shader particle
- r__tf_aniso 8
- r1_tf_mipbias 0.
compiling shader simple_color
compiling shader portal
compiling shader editor
compiling shader sky2
compiling shader sky2
compiling shader clouds
compiling shader clouds
! bad node in heap
Starting engine...
! bad node in heap
* [win32]: free[3762608 K], reserved[145504 K], committed[286128 K]
* [ D3D ]: textures[0 K]
* [x-ray]: crt heap[8092 K], process heap[13299 K], game lua[2066 K], render[254 K]
* [x-ray]: economy: strings[8173 K], smem[0 K]

FATAL ERROR

[error]Expression : fatal error
[error]Function : out_of_memory_handler
[error]File : D:\prog_repository\sources\trunk\xrCore\xrDebugNew.cpp
[error]Line : 336
[error]Description : <no expression>
[error]Arguments : Out of memory. Memory request: 0 K


stack trace:

Showing 1-15 of 73 comments
< >
bernardwatson Jan 29, 2013 @ 5:24am 
Are you running a 32 or 64 bit operating system?
(EDIT 1: I see "win32" in the dump above, but this is the from the program that's bugging out, so...)
(EDIT 2: I also see "dir[3]=C:\Windows\system32\" so question answered.)


In that case, how much total system RAM? And how much in use by the system when just sitting at an empty desktop?
(d^u^b) Jan 29, 2013 @ 8:57am 
uh... @GideonKain, "you're doing it wrong." ;-)
GideonKain Jan 29, 2013 @ 10:10am 
Originally posted by bernardwatson:
Are you running a 32 or 64 bit operating system?
(EDIT 1: I see "win32" in the dump above, but this is the from the program that's bugging out, so...)
(EDIT 2: I also see "dir[3]=C:\Windows\system32\" so question answered.)


In that case, how much total system RAM? And how much in use by the system when just sitting at an empty desktop?

I run Vista 64, and I jusr reformatted my computer yesterday.
A 64 bit version of Windows doesn't have a system64 directory.

I have a HD 6770? video card (1 gb vram) and 8 GB of Crucial memory.
I play most games at max settings, it's not a hardware limitation as I have played through this entire game before....and as I've stated can run the game ONCE after installation but NEVER again
bernardwatson Jan 29, 2013 @ 10:55am 
Originally posted by GideonKain:
I run Vista 64, and I jusr reformatted my computer yesterday.
A 64 bit version of Windows doesn't have a system64 directory.

What specifically does "reformatted" mean? Reinstall of Vista 64? Installed new hardware? The last time you played through without problems, were you using precisely the same computer (OS, hardware, etc)?

Also, when precisely does the crash occur? When loading a saved game? When simply starting/before main menu? Can you start a new game without having to reinstall?
GideonKain Jan 29, 2013 @ 11:53am 
Originally posted by bernardwatson:
Originally posted by GideonKain:
I run Vista 64, and I jusr reformatted my computer yesterday.
A 64 bit version of Windows doesn't have a system64 directory.

What specifically does "reformatted" mean? Reinstall of Vista 64? Installed new hardware? The last time you played through without problems, were you using precisely the same computer (OS, hardware, etc)?

Also, when precisely does the crash occur? When loading a saved game? When simply starting/before main menu? Can you start a new game without having to reinstall?

"Reformatting" refers to formatting the hard drive and reinstalling the OS
When I install the game it starts up fine, I can play it. Then when I close the game I can never reopen it again unless I delete it and redownload it.

I have stated that I have played the game on the same computer before and that the game crashes as soon as I try to run it. (Splash screen, then broken)
Kamikazi Flyswatter of Godspeed Jan 29, 2013 @ 7:16pm 
I think there is a text file where you can edit to change a few start-up things for the game... i forget what they are since its been so long since i have played. Perhaps something about changing the Splash Screen bypass, and some other settings... I must have used google to find my fixes...
Professor Von Kriplespac Jan 30, 2013 @ 3:42am 
Disable all your mods and everything etc and try to reinstall and play if that doesn't work then it must be some format issues.
GideonKain Jan 31, 2013 @ 12:49am 
Originally posted by Strelok:
Disable all your mods and everything etc and try to reinstall and play if that doesn't work then it must be some format issues.

Um...I have now deleted and reinstalled the game 15 times...conflicting mods are not the issue.
Maybe I should Verify my game cache? Oh wait, I've done that over 20 times.
jill920 Jan 31, 2013 @ 7:25am 
Maybe he meant play the vanilla first. That means delete the gamedata folder.
Also, calm down. You sound extremely frustrated.
CxBΞ Jan 31, 2013 @ 2:15pm 
Try deleting the "user.ltx" from:
C:\Users\Public\Documents\S.T.A.L.K.E.R. - Call of Pripyat
GideonKain Jan 31, 2013 @ 6:11pm 
Originally posted by Hessu Stalin:
Try deleting the "user.ltx" from:
C:\Users\Public\Documents\S.T.A.L.K.E.R. - Call of Pripyat

As I stated in initial message...that file/folder does not exsist. All user.ltx files are generated in program directory
GideonKain Jan 31, 2013 @ 6:11pm 
Originally posted by Riki:
Maybe he meant play the vanilla first. That means delete the gamedata folder.
Also, calm down. You sound extremely frustrated.

Vanilla? I have vanilla installed each of the 15 times i've downloaded it. It's not mods as 13 out of my 15 downloads of the game were unmodded.
Sojun Feb 3, 2013 @ 12:10pm 
i see nothing wrong with your system, but 1 thing stands out bigtime, i remember all stalker games had a big issue with VISTA , unfortunatly that might be it, they were supposedly going to patch to deal with vista , but did pripyat ever get this treament before the axe fell for their company? ...vista mate...sadly. ive found a few games that didnt like vista..manhunt, sniper elite, and this.. maybe theres more that didnt like it..hope im wrong.real sorry for your trouble bud
GideonKain Feb 3, 2013 @ 6:25pm 
Originally posted by Sojun:
i see nothing wrong with your system, but 1 thing stands out bigtime, i remember all stalker games had a big issue with VISTA , unfortunatly that might be it, they were supposedly going to patch to deal with vista , but did pripyat ever get this treament before the axe fell for their company? ...vista mate...sadly. ive found a few games that didnt like vista..manhunt, sniper elite, and this.. maybe theres more that didnt like it..hope im wrong.real sorry for your trouble bud

Who knows, there doesnt seem to be an issue...besides the fact that I've played al lthe staker games and won them with the complete mods installed in the past...as soon as I get the xrengine 1.6 stopped working error there is nothing I can do - as I mentioned I tried installing this with a brand new installation of Vista, i.e. Zero conflicts.
HSoga Feb 3, 2013 @ 10:29pm 
Sorry to hear you are having such trouble, I didn't see it mentioned, you playing DX9 or 10? Have you tried not making any changes to the settings after you freshly install and then restarting the game? Perhaps something that you are enabling is causing the crash.. like DX10 or other settings. The USER.LTX file is the file that contains all of the game config settings. Graphics, Sound, Keybindings, Network/Server settings, etc.

So I see it suggested that you delete this.. but I didn't see that it was already tried (forgive me if I am mistaken), I believe the file should be located in: \Steam\steamapps\common\stalker call of pripyat\_appdata_
Showing 1-15 of 73 comments
< >
Per page: 15 30 50
Date Posted: Jan 29, 2013 @ 12:41am
Posts: 73