A rainbow unicorn Jan 1, 2013 @ 11:42am
My game locks up for a few seconds every now and then
I'm having the same problem with CoP as I did with SoC. While the game gets good FPS most of the time, every once in a while it locks up for a moment, often just when I've pulled the trigger of a gun. It happens often enough to be annoying. I'm playing with the Complete mod installed, Normal installation, and I had Complete installed for SoC as well.

I've tried reducing the graphical settings, disablying the enhanced dynamic lighting, SSAO, etc. But I don't think the problem is my specs. They should be able to run this game pretty well.

I have:
64-bit Windows 7
Nvidia GeForce 9800 GT
Intel duo-core CPU, 2.4GHz
4 gigs RAM
SB Audigy sound card

Anyone have a fix for this?
Showing 1-8 of 8 comments
< >
HSoga Jan 1, 2013 @ 3:50pm 
Tough to say, could be CPU getting bogged down. I say this since you mentioned that it happens as soon as you pull the trigger. Seems like that would cause allot of activity that would need to be calculated and processed. I have occasional stutters and from what I have heard/read it's from the AI being processed when I approach an area. Can you overclock the CPU higher and see if it makes a difference? Maybe to 3Ghz?
GR:) 33397 Jan 2, 2013 @ 10:37am 
Haha, I had very similar specs of my computer (I upgraded). You can try using Ashampo Core Tuner to make CoP use all cores instead of just one. It's a wierd problem with stalker games that they don't use all cores when there are more than one. These lag spikes can be caused sometimes but the spawn of NPC's and their running scripts. Try setting the that CoP uses all cores using the program mentioned above, it might help. Otherwise, there's not much you can do except optimizing different configs.
swenor Jan 5, 2013 @ 6:05am 
Originally posted by Max:
Intel duo-core CPU, 2.4GHzAnyone have a fix for this?
So Core 2 Duo or Dual Core? Anyway OC - intel nas nice OC potential.
A rainbow unicorn Jan 5, 2013 @ 8:38am 
It's Intel Core 2 CPU, sorry, I thought those meant the same thing.
HSoga Jan 5, 2013 @ 9:12am 
OC the CPU will help reduce the latency of the pauses but may not effect how often they occur. The problem may be that the game is 32 bit, so if you have a 4GB or ram it's probably not taking full advantage of any available RAM that you have. The pauses are probably related to some moments when paging is holding up the game. You might reduce how often this occurs by making Stalker 'large-address-aware'.

http://www.moddb.com/mods/call-of-pripyat-complete/downloads/stalker-cop-3gb-ram
Jcylco Jan 8, 2013 @ 3:41pm 
I get the same problem on my rig

specs:
i5 (can't remember the exact model)
AMD Radeon HD 7950 (again, not sure which exact model)
8gigs of DDR3 RAM
500GB Seagate hardrive

Surely this setup would be enough to run this game. It must be due to bad optimization or coding. I can run every thing else on ultra with 60-70fps.
HSoga Jan 9, 2013 @ 3:08pm 
I have modest system specs and the game plays well for me on very high settings.

core 2 duo E8500 OC to 3.9GHZ.
AMD Radeon HD 5870
4GB DDR3 1333Mhz 6-6-6-20

I have the occasional stutter when entering a new area, but this is unfortunately unavoidable due to the AI loading. Again, my experience may be different since I'm playing a modded version of CoP and it seems to be using more of my RAM than when it was a vanilla install.

Sojun Feb 2, 2013 @ 3:48pm 
id like to add that unfortunatly u cannot make call of pripyat large adress aware- it already is if u are using 64 bit, the link to the mod ---the mod doesnt work as stated on the page.the pauses are unavoidable on all systems as AI is loaded. i have a quad core 3.5ghz and a 5870 1gb, and it pauses as do intel i7's and i5's. just the way it is. i wished since years ago that they would find a fix but theres none. in shadow of chernobyl; and clear sky u CAN add -noprefetch to the .exe which spreads out the pauses and shortens them as AI is loaded- on faster systems this almost removes the pauses...almost.. but on call of pripyat gah..the prefetch command doesnt work..its a ♥♥♥♥♥♥
Last edited by Sojun; Feb 2, 2013 @ 3:49pm
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jan 1, 2013 @ 11:42am
Posts: 8