Kamerad Kommando Dec 25, 2012 @ 4:35am
Problems running CoP
For some reason CoP runs pretty bad on my PC(I5-2500K, HD6870, installed on SSD, so I don't think my specs are the problem).
Pausing the game basically makes it freeze for half a minute and load times are poor on my SSD.
Anyone know what the problem is?
Showing 1-12 of 12 comments
< >
Captain Lost Dec 25, 2012 @ 2:41pm 
I got the same issues along with microstutters, fx 4100 and gtx 660..game is terribly optimized
Perkan Dec 25, 2012 @ 2:59pm 
try playing with video options, maybe one of the options had a great impact on your fps
Kamerad Kommando Dec 26, 2012 @ 2:36am 
No, my FPS seems fine, it's just the load times and the game freezing when I pause it.
I have tried messing with the options, doesn't seem to help a lot.
Flyboy75 Dec 26, 2012 @ 12:30pm 
are you guys also have issues with the x-ray engine not responding?
gonks Dec 26, 2012 @ 8:01pm 
try enabling/disabling the windows page file, i had to mess with these things to solve the freezing/load times
Captain Lost Dec 27, 2012 @ 1:10am 
Flyboy, I do have that issue but rarely..funny thing is though, clear sky runs without a hitch with the complete mod installed...CoP with or without the mod still takes at least 6 minutes just to get in game and then freeze for 10 sec every 3 or 4 steps I take...

I've tried everything, no fix people said will work has..I gave up on it.
Kamerad Kommando Dec 27, 2012 @ 1:57am 
Originally posted by gonks:
try enabling/disabling the windows page file, i had to mess with these things to solve the freezing/load times

The windows page file?
Exactly where can I find it?
[NM] Splyce dog Dec 31, 2012 @ 12:19am 
Ive had the same problems with two different video cards, upgraded awhile back but it still has these problem (went from 4890 to 6970)
[USEF-R] jonezy Jan 3, 2013 @ 6:44am 
Ninja you shouldnt have any games on your SSD drive, thats for windows and drivers and photos and crap, i just took BF3 off my SSD and it runs even better than before. i got i7 2600k and GTX 560 Ti in SLI. Im not saying that having the game installed on your ssd drive is the cause, but it wouldnt hurt to move it off your solid state drive. Your gonna kill your ssd drive man!
Kamerad Kommando Jan 5, 2013 @ 7:05am 
Originally posted by jonezy:
Ninja you shouldnt have any games on your SSD drive, thats for windows and drivers and photos and crap, i just took BF3 off my SSD and it runs even better than before. i got i7 2600k and GTX 560 Ti in SLI. Im not saying that having the game installed on your ssd drive is the cause, but it wouldnt hurt to move it off your solid state drive. Your gonna kill your ssd drive man!
Shouldn't have games on my SSD!?
That's the reason I got it, cuts load times in half.
BF3 isn't a game you put on a SSD anyway, it's a multiplayer game, there is no point.
I call ♥♥♥♥♥♥♥♥ on killing it man, according to SSDLife I just ran it'll last 8 years, the M4 Crucial is built like a Kalash.
CxBΞ Jan 5, 2013 @ 7:56am 
SSD - Windows installation, system files
Normal HDD - Everything else
Voltage Jan 16, 2013 @ 3:24pm 
Try to change compatibility mode of steam.exe to something else. It solved the problem for me.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Dec 25, 2012 @ 4:35am
Posts: 12