Hammerfight > General Discussions > Topic Details
sssu1 Aug 22, 2013 @ 5:24am
Engine cutting out?
I just recently started playing this game again, after a loooong brake.
And now there is one problem, in every game mode and every character, i can always fly for a few seconds and after that the engine of the machine stutters and i lose all control, falling straight down. After some smoke and sparks, it works normally again for a few seconds.

So is this a feature or a bug? Because the game is inplayable right now.
Showing 1-9 of 9 comments
< >
Saturn2888 Feb 11 @ 10:37am 
Is it something to do with how heavy all your armor and weapons are?
sssu1 Feb 11 @ 10:57am 
I've tried to do without any armor or weapons, and it still happens.
Saturn2888 Feb 11 @ 12:00pm 
What DPI is your mouse set to?
sssu1 Feb 11 @ 1:05pm 
500-5600, i can adjust it on the fly. Seems to be no difference with different speeds.
Saturn2888 Feb 11 @ 1:34pm 
The game itself has DPI settings. Those should change things up. That's all I know.
tiavals Feb 14 @ 2:26am 
Hmm, I think the engine cutting out and black smoke coming out is a regular thing that happens , but it shouldn't really do as much as you said. It does sound like what happens if you suddenly move from zero speed to incredible speed(for instance if your mouse is too sensitive). Still, that shouldn't cripple you. If it happens when you move carefully too, then it does sound like a bug(is a fresh install impossible?). If it happens only when you fly "normally"(normal for you may be too much for the machine), then it's likely a feature and your computer is too good for the game(ironically) or it's an issue with the mouse.

Have you tried a different mouse? It may be your current mouse has some problem that causes it to "warp" around the "screen"(which means going from zero to lightspeed in Hammerfight terms) due to a hardware issue(especially if it's an optical mouse). Still, I wouldn't buy a new mouse just because of that, but if there's one lying around, best try another mouse, preferrably of a different kind(optical or ball).
sssu1 Feb 15 @ 4:48am 
Thanks for the insight, i have G500. I'll see what can I do, reinstall and maybe another mouse.

I just wanted to confirm that it is not normal for this to happen.
sssu1 Feb 15 @ 4:52am 
I verified game cache, and now it seems to be back to normal. Thanks for help everyone!
Saturn2888 Feb 15 @ 5:36pm 
Cool!
Showing 1-9 of 9 comments
< >
Per page: 15 30 50