DEN [CT]  [utvecklare] 13 nov, 2012 @ 2:30am
[Linux] fix for bad frame-rate and/or stuttering in Sam3
Guys, can you please switch off all stuff in BIOS that make CPU adjust its frequency? Like turbo-mode, cool'n'quiet, C1E, power management... you know what I'm talking about? :)
And report your finding here.
TIA
Senast ändrad av DEN [CT]; 13 nov, 2012 @ 2:31am
Visar 1-15 av 21 kommentarer
< >
RegSizedRudy 13 nov, 2012 @ 8:04am 
I only had my CPU overclocked from 3000 Mhz to 3300 Mhz , I turned it back down to the default of 3000 Mhz and I dont see any increase in FPS in Serious Sam on Ubuntu 12.04.

I am still seeing around 20 - 25 FPS

you can see my original post about the issue I am having here : http://steamcommunity.com/app/221410/discussions/1/882965239725596786/
keks  [utvecklare] 13 nov, 2012 @ 12:08pm 
Roger, is Cool'N'Quiet enabled in your bios? It's usually enabled by default. Please see my post in your thread.
[BOX] Varus 13 nov, 2012 @ 12:35pm 
Had the same problem; I was at around 5 FPS before using the libpci and the compositing (didn't relaunch and check after doing those, so I'm not sure not sure which one worked). After that, I was hovering at the 15 to 20 FPS mark. Disabling cool'n'quiet and C1E shot me up to a solid 60 FPS.
TakkaRakkaTakka 13 nov, 2012 @ 3:27pm 
You don't need to disable it. Just use the performance governor.

I have the same problem, I think that it is my GPU's fault. I have AMD HD6850. On Windows the game runs fine with Ultra/High/High@1980x1200, I almost never have less than 30fps. But on Linux (Kubuntu 12.10) I have like 15-20fps with the same settings almost all the time. The strange thing is that sometimes the fps are fine like in singleplayer survival but in other modes like campaign or co-op it sucks. I also have some weird glitches, for example the intro video at the beginning (Croteam) have some artifacts, sometimes the game is black etc.
RegSizedRudy 13 nov, 2012 @ 5:58pm 
I could not find Cool N Quiet but I searched and found that it is called AMD Power Now in my bios. Disabled and now I am for the first time getting 50 - 60 fps Solid 60 when i am alone with no enemy combat.
DEN [CT]  [utvecklare] 15 nov, 2012 @ 10:42am 
Horst, yes, unfortunately, AMD driver is not yet, how should I put it, polished for gaming on Linux. We have to wait some new version, and hope for the best. :-/
hero1900 18 nov, 2012 @ 12:11am 
when i try to get info regarding FPS i get always 0 which is ofcourse wrong. the game getting slower and slower since i am progressing in the game. i don't know how is my card suppose to run i have 8400GS which i think give the minimum requirement for this game
radoslav.dejanovic 18 nov, 2012 @ 9:40am 
Disabling CPU power management seem to help a lot. :-) Cool'n'quiet does have some impact on fps, too.
diversario 24 nov, 2012 @ 4:06pm 
I didn't have any CPU power management enabled to this fix doesn't apply. I'm seeing the same thing as -http://steamcommunity.com/app/41070/discussions/0/864951362254505189/#c864951657782218082 - games gets slower as I progress. In fact, I'm only at the second level and it's already unplayable - frame rate is about 10 FPS, no amount of reloading/rebooting helps.

I'm running Ubuntu 12.10, Unity, with 310 nVidia driver (my card is 460 GTX). I had to customize some graphic settings to get acceptable FPS and it worked OK on the first level. Maybe it's because of something that's only used in interior missions?.. I don't know.
AlenL  [utvecklare] 24 nov, 2012 @ 10:21pm 
Diversario, are you sure you covered all possible power options in BIOS? Which ones exactly are disabled for you?
I'm asking because we had several case already where people missed one because it was named differently in their BIOS, or was hidden in some submenu.
MidFingr 24 nov, 2012 @ 10:24pm 
I changed BIOS settings as pre request. The results appear to be much better; 3-4 fps to 30-60+ fps Ubuntu 12.10 with AMD beta 12.11 drivers -- using 'classic mode' seems to help as well.
diversario 25 nov, 2012 @ 9:10am 
Ursprungligen skrivet av AlenL:
Diversario, are you sure you covered all possible power options in BIOS? Which ones exactly are disabled for you?
I'm asking because we had several case already where people missed one because it was named differently in their BIOS, or was hidden in some submenu.

Well... I'm pretty sure. I was looking for anything that has to do with CPU speed, and in my case - Gigabyte EX58-UD4P - there's this "C.I.A." option that does exactly that - adjusts CPU speed dynamically. There are also settings for voltage and memory speed, which are set to Auto. I had spent some time with this before because my mobo was giving me trouble and I just went reset everything to defaults and disabled overclocking etc.

How about this: is there a some utility for Linux that can display CPU frequency? I could run it and start SS and see what's going on.

EDIT: Yeah, CPU frequency does scale, just ran "more /proc/cpuinfo | grep "cpu MHz"" and it shows that freq goes up at some cores.

EDIT2: Great success! Turns out, I missed one option there and now it runs pretty well.
diversario 26 nov, 2012 @ 4:45pm 
Whelp, it was fun while it lasted. I switched to public beta updates and it's back to stuttering 5 FPS. Sigh.
keks  [utvecklare] 26 nov, 2012 @ 11:42pm 
Ursprungligen skrivet av diversario:
Whelp, it was fun while it lasted. I switched to public beta updates and it's back to stuttering 5 FPS. Sigh.
Could you please post your Sam3.log
diversario 27 nov, 2012 @ 2:29am 
Ursprungligen skrivet av keks:
Ursprungligen skrivet av diversario:
Whelp, it was fun while it lasted. I switched to public beta updates and it's back to stuttering 5 FPS. Sigh.
Could you please post your Sam3.log

Here - http://pastebin.com/raw.php?i=PcB4S7eU
Visar 1-15 av 21 kommentarer
< >
Per sida: 15 30 50
Datum skrivet: 13 nov, 2012 @ 2:30am
Inlägg: 21