Lauri Nov 10, 2012 @ 8:18am
Linux graphical glitches
I'm getting a lot of graphical glitches in Serious Sam 3 on Xubuntu 12.10. My graphics card is NVidia Geforce GTX 560 and I'm using 310.14 drivers.

This is how the game looks like for me:
http://i.imgur.com/MIOY9.jpg
http://i.imgur.com/Qblie.jpg
http://i.imgur.com/ydKwu.jpg

Also when I launch the game it doesn't start in fullscreen even though I have set it on fulscreen from the options. And sometimes when I start a new game or load a game everything is black. I can see croshair, health and all that stuff but everything else is black.

Log file:
http://pastebin.com/D8jFvwNw
Last edited by Lauri; Nov 10, 2012 @ 8:35am
Showing 1-15 of 19 comments
< >
AlenL  [developer] Nov 10, 2012 @ 9:57am 
Please install the 32 bit version of the libpci.3.so library. The game did not detect your GPU because that is missing. Do autodetect of Performance Options after that. If that doesn't help, let me know. Thanks.
Lauri Nov 10, 2012 @ 10:24am 
Thanks. After installing 32 bit libpci3 all the graphical glitches are gone. Still the game doesn't start in fullscreen but everything else works fine.
Lauri Nov 10, 2012 @ 10:38am 
Everything doesn't work fine after all. I started getting those graphical glitches again.
AlenL  [developer] Nov 10, 2012 @ 3:12pm 
One thing to try:
ren_bGeometryInstancing=0
in the console (F1)

If that doesn't help, please post a new log file (now that libpci is installed) Thanks!
sakuramboo Nov 10, 2012 @ 4:49pm 
I had similar problems with similar hardware. The weird thing was, it corrected itself. The first time I started the game, it was unplayable. I started it a second time, I was able to play, but Sam wasn't rendered. The third time I started, it was flawless. And it has been flawless ever since.
Lauri Nov 11, 2012 @ 1:28am 
ren_bGeometryInstancing=0 didn't help

Log file:
http://pastebin.com/znTDtE2j
Lauri Nov 11, 2012 @ 1:55am 
It seems I only get those graphical glitches when using XFCE. I tried it with Unity and Openbox, and with both of those the game works just fine.
Chris Nov 11, 2012 @ 12:51pm 
in facing tons of graphical 2 issues also ..i use the same driver and have a gtx 560 ti ..but neither openbox nor unity fix my issues ..can you post the rest of your specs ?
Mad Grenadier Nov 12, 2012 @ 1:37am 
I was having this issue as well once I updated to the 310.14 nvidia driver, Installing the 32bit libpci.3.so fixed the graphical glitches for me.

Running Mint 13 x64 with a Nvidia 560ti
Putteri Nov 12, 2012 @ 8:37am 
I have those glitches after switching to desktop from game (with alt-tab). When I resume game glitches appear. I'm running openbox+kde (same happens with probably every desktop, I tested it with openbox, cinnamon, kwin and lxde), Nvidia gtx 670 and 310.14 driver.
Last edited by Putteri; Nov 12, 2012 @ 9:09am
Chris Nov 12, 2012 @ 11:23am 
thanks for the info..i always used alt tab to get the game fullscreen cause it started always in windowed mode...
cbrunos455 Nov 12, 2012 @ 11:04pm 
I have the same issues on my machine, even after installing libpci3:i386. The game works fine for a while and then the glitches come back. I have a GT430 and proprietary Nvidia drivers version 304 on Ubuntu 12.10. Will try with the nvidia-experimental drivers (310).

EDIT: Even with the latest drivers (nvidia-experimental package, version 310) I get the glitches after some time.

EDIT: I played for more than one hour today without any issues. Seems that the textures glitch bug is gone!
Last edited by cbrunos455; Nov 14, 2012 @ 12:57pm
atomic-penguin Nov 14, 2012 @ 1:53pm 
I am also an XFCE user, and tried the recommended workarounds. Nothing except for using an alternate window manager worked.

The easiest way I found to work around the black screen issue was to use this handy steam-login[github.com] project to launch Steam bigpicture mode as a Window Manager session.
DEN [CT]  [developer] Nov 15, 2012 @ 10:38am 
Guys, can you confirm that glitches only appear when you alt-tab out of the game and then back in? Or they appear (after some time) without leaving the game screen?
TIA
Putteri Nov 15, 2012 @ 12:37pm 
Hi DEN, here is my observations about glitches, copied from Steam for Linux-hub SSam3 discussion:

"Unfortunately the graphics corruption after minimizing (by using alt-tab) isn't fixed for me. It seems to affect only models that haven't been seen before minimizing. If I minimize the game when it is loading the level, the screen will be full of corruption, but if I play for a while, then pause, minimize and return to game only new enemies or items are corrupted.

I tested this with gentoo x64, openbox and nvidia-driver 310.19 and Linux Mint x64, metacity and nvidia-driver 310.14. graphics card is gtx 670."

The glitches appear only after using alt-tab (for me).
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Nov 10, 2012 @ 8:18am
Posts: 19