mearo 9. nov, 2012 @ 11:44am
Linux NVidia performance culprits?
Found 2 settings that can give a large fps boost (I'm using an NVidia GeForce GTX 295)

I was messing around with the settings and I noticed something a bit interesting with the "GPU speed" setting.

If I let the game autodetect my settings I would get about 22FPS, I tried lowering the 3 settings 1 at a time and found that "CPU speed" and "GPU memory" only had very little change on FPS.
"GPU speed" also had very little change UNTIL I moved from "low" to "lowest" there was a HUGE fps increase. From about 25fps up to more like 70 - 100fps.


So I set it on "low" and then manually edited each of the "custom" settings 1 by 1 and I found the there are 2 settings in there that seem to make the largest difference for me.

1) enable "no dynamic lighting"
2) disable "shadow blur"

In conclusion, if I then allow the game to auto-detect my settings and ONLY change those 2 options, the performance goes from 22fps to around 60fps
and it still looks great!

Hopefully this helps someone.
Sist redigert av mearo; 9. nov, 2012 @ 11:46am
Viser 1-12 av 12 kommentarer
< >
٩(●̮̮̃•̃)۶вσσмєя 9. nov, 2012 @ 12:01pm 
good tip.
AlenL  [utvikler] 10. nov, 2012 @ 6:51am 
It would be interesting to note is Shadow Blur does a difference. However, if No Dynamic Lights is off, then Shadow Blur shouldn't make a difference, since there are no shadows. Are you sure these are _both_ required?

Could you please post your log file so we can get all the detailed info about it?

Also, please note that you should use the 310 driver, not 304 or any older. 310 is minimum required for good performance.
mearo 10. nov, 2012 @ 8:13am 
You were right apparently the big setting for me then is to turn off dynamic lighting. Once I have this off I notice no difference if shadow blur is on or not. Sorry I don't know why I didn't check that the first time. (but leaving dyn lighting on and turning off shadow blur gave a 15 fps increase)

Also, I am currently using the 304.60 drivers. I'll try to upgrade to 310.14 and post back here if it makes a difference to that setting for me or not
AlenL  [utvikler] 10. nov, 2012 @ 9:53am 
Please do, as in our testing 310 is much faster than 304.
mearo 10. nov, 2012 @ 2:07pm 
Ok I updated to 310.14 and there is a very noticeable performance increase, thanks for the help.

Now turning on and off dynamic lighting doesn't make much of a difference to my overall fps, it's like a 2 frame difference.
But the performance is much higher
AlenL  [utvikler] 10. nov, 2012 @ 2:35pm 
Excellent! Does the game now work well enough on autodetected settings?
Also, can I please ask you to post the Sam3.log file, as we are looking for info about machines that work well, so that we can compare against those that don't. Thanks!
mearo 10. nov, 2012 @ 2:57pm 
ya it works great on autodetect settings, I get about 60fps on average

Here is my Sam3.log
http://bpaste.net/show/57157/
Let me know if you need anything else from me, I'd be happy to help.

[EDIT]
It does work good with autodetect, but I thought I should mention that before posting that log file I did edit the settings a bit just in case it matters to you.
Here is what I changed:
turned off antialiasing, turned off shadow antialiasing, turned off shadow blurring, and changed the "max 3d rendering mpix" to match the games resolution"

If you want me to run autodetect and post the log file again just ask.
DEN [CT]  [utvikler] 15. nov, 2012 @ 10:41am 
mearo 15. nov, 2012 @ 11:09am 
Opprinnelig skrevet av DEN CT:
OP, have you tried this:
http://steamcommunity.com/app/41070/discussions/0/864951362254505189/
Any luck? :)

I do remember having one of those settings in my BIOS, but I don't recall if I disabled it or not. I am already getting much better framerate in SS3 though with the latest drivers, but next time I turn my computer on I will be sure and check if I have this disabled or not and if I notice a change here.
(although my framerate seems pretty stable to me already)
Dr. Allcome 16. nov, 2012 @ 12:34pm 
Opprinnelig skrevet av AlenL:
Excellent! Does the game now work well enough on autodetected settings?

"sudo apt-get install libpci3:i386" made all the difference for me. The game now detects ultra settings and runs at 30-40 fps most of the time. Installing libpci3 also fixed some texture bugs where I could not see the weapon I was holding.

However I can only play in windowed mode as I have a dual monitor setup and in fullscreen mode it tries to stretch the game over both monitors.

Also, can I please ask you to post the Sam3.log file, as we are looking for info about machines that work well, so that we can compare against those that don't. Thanks!

http://pastebin.com/SsgNQ4h6
AJenbo 21. nov, 2012 @ 5:18pm 
With shadows on shadow blur was one of the most noticeable (on the fps) effects to have on.

Upgrading to 310 fixed the issue for me. I think it even improved the visuals.

Installing libpci3:i386 didn't do any thing for me.

http://pastebin.com/mQBJBxpz

I also got and issue where the world would become a polygon mess when holding the poistol and the hammer was invisable, after minimizing the game. I haven't checked if this is now also solved.
AlenL  [utvikler] 22. nov, 2012 @ 12:04pm 
Minimizing the game can mess a lot of things. There are some driver problems with that. We are trying to work around that. A part of that will be in a new beta, maybe even tomorrow.
Viser 1-12 av 12 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 9. nov, 2012 @ 11:44am
Innlegg: 12