Serious Sam 3: BFE
Prof Farnsworth Jun 30, 2013 @ 6:40pm
sam3 dedicated server not starting (linux)
I'm trying to get a dedicated server running on our clan-server but it just doesn't start.
First I had the problem with missing 32bit libs, which I sorted myself after a bit of trial and error action :)
But now I'm seriously stuck. When I try to start the server I get the following error log:
7: pushd: not found ./Bin/
17: ./sam3_dedicatedserver: not found ./Bin/
18: popd: not found

I haven't written a cfg-file yet, just running the sh-file with a few added options, like this:
./Bin/ +sessionname "XXX Server" +gamemode BeastHunt +rconpass "XXX" &> Log/Sam3_console.log &

So, what am I missing or doing wrong, any suggestions?
Running Debian 6 64bit, if that matters.
Last edited by Prof Farnsworth; Jun 30, 2013 @ 6:57pm
< >
Showing 1-8 of 8 comments
keks  [developer] Jul 1, 2013 @ 5:59am 
It seems that the run script is somehow not being interpreted with bash, even though it starts wtih

Please check what happens when you enter pushd and popd commands in a terminal.
You can also try running the script directly with bash, e.g.
/bin/bash ./Bin/

If this fails, please post the output of this command
ls -al /bin | grep sh
It lists all files with sh in their name in the /bin directory.
Last edited by keks; Jul 1, 2013 @ 6:07am
Prof Farnsworth Jul 1, 2013 @ 2:47pm 
A clan-mate tried again this morning and managed to get the server starting with just another port specified. Problem now is that we, for some reason, don't seem to be able to start the server with a versus mode. If we start with
+gamemode BeastHunt
+gamemode "BeastHunt"
added, the process starts but the server doesn't show up in the server list or hlsw.
If we ditch the gamemode line everything works fine and the server is listed.

Thanks (again) for the help :)
ChrisW Jul 1, 2013 @ 3:00pm 
Make sure you set the gamemode variable before any other variable. Any variables you set before the gamemode variable will be discarded.
Prof Farnsworth Jul 1, 2013 @ 3:06pm 
tried that already. no luck. thx for the effort though :)
ChrisW Jul 1, 2013 @ 3:20pm 
I'm not sure if you need to put those values in quotes or not, but I'm sure the gamemode setting needs to come before the port or session name. Try placing the following in a text file, rename it to beasthunt.cfg, move it to your Serious Sam 3 folder, then run the server by adding +gameoptions "beasthunt.cfg" to the command line:
prj_strMultiplayerSessionName="XXX Server";
rcts_strWelcomeNote="Welcome string goes here";
Prof Farnsworth Jul 1, 2013 @ 3:46pm 
It seems to be a linux-specific problem, according to this thread.
The workaround proposed there also works.
So problem solved for now I guess, though I'll try writing a .cfg-file tomorrow and see if that maybe simplifies things a bit.
Last edited by Prof Farnsworth; Jul 1, 2013 @ 3:46pm
ChrisW Jul 1, 2013 @ 7:19pm 
This seems to be limited to running the dedicated server with command line codes. Running it via a server script the way I outlined works fine. You are really better off running it with server scripts anyway as it is way more powerful being able to use Lua commands.
AlenL  [developer] Jul 2, 2013 @ 4:33am 
Yes, there's a known bug that made dedicated server start, but lock up if +gamemode was specified on the command line. Note that this bug existed only on Linux.

This bug is fixed in the current public beta, and will be shipped to default version in a day or two. If you can't use beta, just wait until we propagate it and then update the server.
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Jun 30, 2013 @ 6:40pm
Posts: 8