Serious Sam 3: BFE
dumpsterkeeper Mar 10, 2013 @ 3:44pm
Crash at end of campaign
I've encountered a crash at the end of the campaign while playing under Ubuntu 12.10, both with the base game and JOTN. Once defeating either end boss, if I click to exit the cutscene or simply wait to the very end of the cutscene, the game exits to the desktop with no warning or message. I've posted the Sam3.log file[] following one of those crashes. At the end, it appears to be a Lua error that occurs immediately before exiting.

It's likely related to the unexpected exit, but this also causes the achievement for beating the campaign/DLC to not be rewarded properly.

If I can provide any additional information about this error, let me know. Thanks!
< >
Showing 1-15 of 23 comments
Quebec Dragon Mar 10, 2013 @ 8:49pm 
Same problem here at end of campaign and I'm on a standard Windows 7 64-bit system. The graphic card is an ATI Radeon 7700 2 Gigs. I do get a message telling me, "The application has malfunctioned an it will now close. We apologize for the inconvenience. Please send error log to the technical support." I don't get the achievement for finishing the game either.
dumpsterkeeper Mar 10, 2013 @ 9:07pm 
Oddly enough, I did end up getting both achievements. I went back and played the first level of the standard campaign, and as soon as I finished the level both the achievement for completing the base game and the DLC popped up.
AlenL  [developer] Mar 11, 2013 @ 6:11am 
We store achievements locally and re-award them if previous attempt of awarding failed.

In order to fix eventual problem, please post Sam3.rpt and Sam3.log from one such crash. Thanks!
dumpsterkeeper Mar 11, 2013 @ 10:30am 
I did link to the Sam3.log in my original post. I threw it up on pastebin so as to not overwhelm the thread here, as there was no option to attach files that I could find. Here's the direct link:

I didn't see a Sam3.rpt file in the same directory, but I can re-trigger the crash and check again if that would be helpful.

Quebec Dragon Mar 11, 2013 @ 5:07pm 
I also got the achievement for completing the game, although I never saw it pop-up. I wouldn't feel comfortable posting Sam3.log and Sam3.rpt here because they're too long.
AlenL  [developer] Mar 12, 2013 @ 3:21am 
dumpsterkeeper, without a .rpt there is no way to know where it crashed. The log file signifies that the crash did indeed happen, but it too is cut off too early. If you can try to repro, that would be great.
Suits Mar 12, 2013 @ 7:55pm 
Is Sam3.CodeGuard.rpt the file you are talking about? Because I'm having the same problem on Vista 32-bit. I can make a seperate thread assuming it can't be resolved in the same way.
AlenL  [developer] Mar 13, 2013 @ 3:00am 
No, CodeGuart.rpt is a different thing. It is caused by some other internal checks. For a crash, we need plain Sam3.rpt (or Sam3_Unrestricted.rpt depending on which version you started)
thehandofkwll Mar 14, 2013 @ 5:16am 
I get the same crash after the final cutscene.
Sam3.log: Sam3.CodeGuard.rpt: sam3_178606_crash_2013_3_14T11_59_5C0.mdmp:

There were no other .rpt files generated.
Last edited by thehandofkwll; Mar 14, 2013 @ 5:16am
pp Mar 14, 2013 @ 6:15am 
I have the same problem on my system (Ubuntu 12.10 64-bit), and - unfortunately - I don't have Sam3.rpt file either. It isn't created. To get more information about the crash, I run it with gdb:

It seems the crash happens after exit() has been called, maybe in some atexit() handler. Unfortunately, I can't save a core file:
(gdb) generate-core-file Couldn't get registers: No such process.

A list of open files:

Sam3.rpt is not on the list. There's nothing interesting in Sam3.log file, it just ends with "13:38:04 LOG: World stopped in 0.20sec."
Elvis II Mar 14, 2013 @ 7:02am 
I actually have the same problem on Windows 7 64-bit. It crashes every time after the credits or if I click to skip them. I did get my achievements, though. I just didn't get the pop-up for them.
Last edited by Elvis II; Mar 14, 2013 @ 7:04am
pp Mar 14, 2013 @ 8:53am 
Update: gcore command worked, so I have a complete core dump of the process. I can upload it somewhere if needed (it's big, 948M uncompressed).
pp Mar 14, 2013 @ 9:19am 
So I let the process continue, and there's another segfault in the signal handler. May be the reason why Sam3.rpt file is not produced:
(gdb) cont Continuing. Program received signal SIGSEGV, Segmentation fault. 0xd1e5a932 in ?? () (gdb) bt #0 0xd1e5a932 in ?? () #1 <signal handler called> #2 0x08e05f12 in ?? () #3 0x08e04a05 in ?? () #4 0x08deb268 in ?? () #5 0x08c03be5 in ?? () #6 0xf7dd3f51 in ?? () from /lib/i386-linux-gnu/ #7 0xf7dd3fdd in exit () from /lib/i386-linux-gnu/ [...cut, same as before...]
dumpsterkeeper Mar 15, 2013 @ 6:31am 
Yes, same here. I've reproduced the crash but have no Sam3.rpt file. The only files in that directory are Sam3.log (as linked above) and Sam3.All.log. I've searched that entire folder structure, but no *.rpt file exists that I can find.
Xaoraxon Mar 15, 2013 @ 11:49am 
Similiar issues here. Oddly enough the Serious Sam achievement popped up 2 days later when I logged into Steam. No Sam3.rpt file here either.
< >
Showing 1-15 of 23 comments
Per page: 15 30 50

Date Posted: Mar 10, 2013 @ 3:44pm
Posts: 23