AlenL  [developer] Feb 22, 2013 @ 10:47am
Serious Sam 3 Update 178606 - public beta
Build 178606 for Serious Sam 3 is now available in beta "publicbeta", which does not require a password.

To install the beta, do this:
- locate the game (Serious Sam 3 in this case) in the Steam's "Library" panel
- right click and invoke "Properties"
- select the "Betas" tab
- choose "publicbeta"

Here are the changes:
- Tentative fix for a crash at "Enumerating packages" that happened only on some machines.
- XBox360- and PS3-compatible gamepads are now supported on OSX. 
- Added inp_bDisableGamepads cvar that disables polling gamepad control values. Useful for machines with built-in sensors that act as gamepads.
- Fixed problems with microstuttering fix causing a momentary time warp when exiting in-game menu.
- Fixed an issue where Netricsa would be stuck on hud in rare cases.
- Puppets can no longer rotate while subjected to player melee. 
- Fixed kamikazes not inflicting damage to player when killed nearby player on Tourist/Easy difficulty. 
- Editor: Aircraft and Khnum puppets can now be killed by sandwhale. 
- Editor: Lose weapons flag on chapter info now works. 
- Editor: Various fixes and improvements on fbx importer like suport for vertex colors, some unit conversion problems, user property curves in animations, bind pose detection problems, etc.
- Editor: Fixed a rare crash when editing SandWhale on custom levels. 
- Scripting: Every spawned entity now sends an "EntitySpawned" event. 
- Scripting: Optimized event handling for events that are sent very often (needed for EntitySpawned).
- Scripting: Puppet class now exposes a new macro function: GetCharacterClassFromParams(), which returns the character class set in params. 
- Scripting: Path marker entity now exposes new macro functions: GetPreviousMarker() and GetNextMarker(). 
- Scripting: Added global OnStep script event, sent once per simulation step. 
- Scripting: Added new lua math function: mthLenV3f(). 
- Server: Fixed wrong names for vote pass/fail commands in DedicatedServer_Readme.txt. 
- Server: Dedicated server no longer attempts to initialize voice chat, which just caused spurious errors in the log. 
- Server: It is now possible to use chatSay cvar function on dedicated server. Messages sent that way appear as comming from the "[admin]" player.
Showing 1-12 of 12 comments
< >
Big Mogge Feb 22, 2013 @ 3:57pm 
gay!!! And good you fixed it buddie
MakaVeLi Feb 22, 2013 @ 8:19pm 
Im downloading atm, cant w8 to test it out
rad87gn Feb 23, 2013 @ 7:10am 
The new Nvidia drivers and this update makes my gtx 680 seriously overclocked (stable) go 20 or less FPS. Something is broken. If I'm struggling....I can't imagine what others are seeing. My system is tuned to a nats ♥♥♥. 30+ years for a living. I've also jumped in games I'm hosting and see the boss missing. I also saw the spots for bombs hanging in the air but cleared.
AlenL  [developer] Feb 23, 2013 @ 1:44pm 
rad87gn, I see you have another thread on this. Please post the log files there and we'll go from there.
gei3r Feb 24, 2013 @ 6:49am 
Great update, the game runs now very nice on linux for me :)
Thumbs Up for this super support!
Vedynn[Linux] Feb 25, 2013 @ 3:14am 
Хорошая работа парни =) !!!
Теперь я вижу Croteam )) До обновления игра ели ползола при crossfire 6950
Спасибо.
Vedynn[Linux] Feb 25, 2013 @ 3:14am 
До обновления на Linux)
widdledude {54th} Feb 25, 2013 @ 12:01pm 
as soon as the update came out, my game started crashing at the main menu and it says "enumerating packages", i validated the files for the game but it still doesn't work
AlenL  [developer] Feb 26, 2013 @ 7:01am 
nybaker04, you don't get this update by default. you have to opt into public beta, then the crashes will stop.
The-Guardian Feb 27, 2013 @ 7:06am 
my First problem ever lol :P

I have opt to the PublicBeTA. Game runs nice as usual but the very last cutscene in the game (The part where UGH ZAN IV Fell and so on) when I click to skip that cut-scene. The Game Crash with the "This App has Malfunction Window" in the end. weird as throughout the game it is perfectly fine. I have opted to this Publick Beta because of the Serious Sam 3: Extended Mod.

However while still opted to this update, I have tried the game in the NON Moddable Version. Same crashing on the end after clicking to skip the very last cutscene in that version.

Other cut scenes in game is fine even during skipping. Just the last one.

Did verify the files tho.

Only happen when I opt to the Public Beta.
magic1983 Feb 27, 2013 @ 9:28am 
The game crashes on startup.
OS: Ubuntu 12.10
Vga: Radeon HD 7540D
Driver: 13.1 and 13.2 beta 6

(steam:4925): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:4925): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:4925): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
INF: GameEnv API: Steam
Setting breakpad minidump AppID = 41070
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198041419184 [API loaded no]
INF: Encoded user ID = ae3eeea3:93792f2a
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
INF:
INF: * Desktop settings...
INF: Color depth: 32-bit
INF: Desktop resolution: 1366 x 768
INF: Fullscreen on primary display
INF: Crash! (Segmentation fault)
Game removed: AppID 41070 "Serious Sam 3: BFE", ProcID 5936
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
ExecSteamURL: "steam://url/GameHubDiscussions/41070"
AlenL  [developer] Feb 28, 2013 @ 10:46pm 
For all crashes, please post complete log files and .rpt files, as per the pinned FAQ. Thanks.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50
Date Posted: Feb 22, 2013 @ 10:47am
Posts: 12