Serious Sam 3: BFE
Is MultiThreaded Rendering going to be ever supported?

Alenl you have posted 10-18-2012 on Steam forums here #46:
Originally posted by alenl:
Now, enable multithreading by ren_bMultiThreadedRendering=1. Note that this feature is not 100% supported yet, so if it renders artefacts or crashes, don't call us. :) Some people are playing with it as it can give quite a speedup, but no guarantees on stability.

Did you improve this feature since this post? Can we expect it working stable now or in the future?
Last edited by Rasta Pedobear (your dad); Mar 4, 2013 @ 2:54am
< >
Showing 1-15 of 27 comments
MultiThreaded Rendering gives me up to 30% better performance, improves fps around 5-15. That's very much. When I'm using it fps very rare drop below 30. I can play for 2-3 hours without a break and without crash. Unfortunately the game crashes from time to time. It seems to crash always when I play multiplayer and players decapitate a Khnum. Same do alt+tab, keep the game in background for a long time and come back to it.

So main question is back: Are you working on this feature or it's something you will never support?
DEN [CT]  [developer] Mar 7, 2013 @ 1:02am 
It should work fine now. I hope. :)
For best results, use ren_iMaxThreads=2 or =3.
(Higher numbers could easly flood the driver, and you get lower FPS.)
kwahoo Mar 7, 2013 @ 2:00am 
Works fine for me. I have played several hours - no crash or shuttering;) Best performance for 4 cores/8 threads i7 is for ren_MaxThreads=4.
It seems to works good in single player.
In multiplayer the game crashes always when someone use Sirian Mutilator on Khnum or Scrapjack. It's 100% reproducible for me. Doesn't crash when smaller monsters are killed this way. Kinda weird. Should I post my logs

[fixed & outdated issue]

For my Q9400 and GTS 250 the best value is ren_iMaxThreads=2. 3 increases frametime and doesn't change fps, 4 also increases frametime and causes fps drops.

kwahoo@: Could you check if decapitate a Khnum in multiplayer cause crash for you, please?
Last edited by Rasta Pedobear (your dad); Jun 10, 2013 @ 3:19am
AlenL  [developer] Mar 7, 2013 @ 2:56am 
Rasta, if you can really 100% repro, please describe exact steps to reproduce and we will fix the crash. Thanks!
Ok I checked today once again after update. Crashes as soon I perform Mutilator "lasso" on big monsters like Scrapjack, Big Archanoid, Khnum and red Biomech.
[fixed & outdated issue, description removed]
Last edited by Rasta Pedobear (your dad); Jun 10, 2013 @ 3:17am
kwahoo Mar 7, 2013 @ 7:08am 
I can confirm Terminal output[] Should I post *.mdmp file? Is it useful?
Last edited by kwahoo; Mar 7, 2013 @ 7:12am
AlenL  [developer] Mar 7, 2013 @ 8:24am 
Thanks guys. If it is reproducible by just performing mutilator on scrapjack, we should be able to debug and fix it. Thanks for the report!
kwahoo@: Thanks for checking, good to know I'm not alone with this issue.
[fixed & outdated issue]
AlenL@: You don't fear to fix crashes and really provide support for your games. That's great. Please more developers like you guys :)

Dunno if it's important or not and if it's only this case related but while the game already freeze and:
* you press Esc/spacebar/enter then the malfunction message won't appear, log will be cut and minidump won't be created
* you wait 5-10 seconds and press ctrl + alt + del to enter the Windows 7 lock screen then the malfunction message will appear, log won't be cut and minidump will be created

Already fixed :)
Last edited by Rasta Pedobear (your dad); Jun 10, 2013 @ 3:21am
Szoreny Klepko Mar 7, 2013 @ 11:57am 
Hey I just tested this with multithreaded rendering on '1' and got the exact same crash when hitting a scrapjack with the mutilator, something I'd never tried before. Was running the moddable version on Win7.

Good luck with the debug AlenL & co.
yeah good luck with that, you guys are awesome. Best game developer ever!
MultiThreaded Rendering seems to work more less stable with build 180038 so I keep it enabled and use ren_iMaxThreads=2.

Kinda interesting that turining on Vsync doesn't change my FPS when MultiThreaded Rendering is enabled. When Vsync is disabled GPU usage is slightly lower about 1-5%.
I've checked MultiThreaded Rendering on Windows using DirectX and OpenGL.
1. MultiThreaded Rendering off, DirectX
2. MultiThreaded Rendering on, DirectX

Changed testing place and GPU settings to lowest.

3. MultiThreaded Rendering "off", OpenGL
4. MultiThreaded Rendering "on", OpenGL

So MultiThreaded Rendering works in all cases - on Windows when DirectX or OpenGL is used and on Linux when OpenGL is used.

Thanks to kwahoo for providing screenshoots from Linux (post #15)
Last edited by Rasta Pedobear (your dad); Jun 10, 2013 @ 3:11am
Skully Jun 8, 2013 @ 7:48pm 
it definatly works in Linux
kwahoo Jun 9, 2013 @ 3:38am 
It works in Linux/OpenGL (pics from January) Disabled[]
< >
Showing 1-15 of 27 comments
Per page: 15 30 50

Date Posted: Feb 18, 2013 @ 5:22am
Posts: 27