DawidR Feb 18, 2013 @ 1:38am
SS3 Ubuntu 12.04 LTS x64 since install AMD 13.2 BETA game won't start
Hello,

since i installed the new 13.2 BETA driver from amd SS3 won't start :( before it was ok with 13.1

here the log:


-------- START OF LOG --------

10:29:42 LOG: Core version: $Version: distro_Sam3_PC; SeriousSam3_Executables-Linux-Final; 176695 2013-01-24 17:16:44 @builderl02; Linux-Static-Final-Default$
10:29:42 LOG: Command: $
10:29:42 LOG: Initializing timer.
10:29:42 LOG: Timestamp: 2013/02/18 10:29:42
10:29:42 LOG: Binary name: Sam3
10:29:42 LOG: Binary soft path: Bin/
10:29:42 LOG: Binary hard path: /home/dawid/Steam/SteamApps/common/Serious Sam 3/Bin/
10:29:42 LOG: Application directory: /home/dawid/Steam/SteamApps/common/Serious Sam 3/
10:29:42 LOG: * OS...
10:29:42 LOG: Type: Linux
10:29:42 LOG: Kernel: 3.2.0-38-generic
10:29:42 LOG: Version: #60-Ubuntu SMP Wed Feb 13 13:22:43 UTC 2013
10:29:42 LOG: Architecture: x86_64
10:29:42 LOG: Output of lsb_release: Distributor ID: Ubuntu
10:29:42 LOG: Description: Ubuntu 12.04.2 LTS
10:29:42 LOG: Release: 12.04
10:29:42 LOG: Codename: precise
10:29:42 LOG:
10:29:42 LOG: /etc/*-release: DISTRIB_ID=Ubuntu
10:29:42 LOG: DISTRIB_RELEASE=12.04
10:29:42 LOG: DISTRIB_CODENAME=precise
10:29:42 LOG: DISTRIB_DESCRIPTION="Ubuntu 12.04.2 LTS"
10:29:42 LOG: NAME="Ubuntu"
10:29:42 LOG: VERSION="12.04.2 LTS, Precise Pangolin"
10:29:42 LOG: ID=ubuntu
10:29:42 LOG: ID_LIKE=debian
10:29:42 LOG: PRETTY_NAME="Ubuntu precise (12.04.2 LTS)"
10:29:42 LOG: VERSION_ID="12.04"
10:29:42 LOG:
10:29:42 LOG: /etc/debian_version: wheezy/sid
10:29:42 LOG:
10:29:42 LOG: Power saving settings: /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies:3400000 2700000 2200000 800000
10:29:42 LOG: /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors:conservative ondemand userspace powersave performance
10:29:42 LOG: /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq:3400000
10:29:42 LOG: /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver:powernow-k8
10:29:42 LOG: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor:ondemand
10:29:42 LOG: /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq:3400000
10:29:42 LOG: /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq:800000
10:29:42 LOG: /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed:<unsupported>
10:29:42 LOG:
10:29:42 WRN: CPU Power saving is enabled and performance governor is not used.
10:29:42 LOG:
10:29:42 LOG: XDG_CURRENT_DESKTOP: Unity
10:29:42 LOG: GDMSESSION: ubuntu
10:29:42 LOG: DESKTOP_SESSION: ubuntu
10:29:42 LOG: KDE_SESSION_VERSION: (null)
10:29:42 LOG:
10:29:42 LOG: * CPU...
10:29:42 LOG: Vendor: AuthenticAMD
10:29:42 LOG: Name: AMD Phenom(tm) II X4 965 Processor
10:29:42 LOG: Type: 0, Family: 15, Model: 4, Stepping: 3
10:29:42 LOG: Clock: 3.42 GHz
10:29:42 LOG: Cores: 4
10:29:42 LOG: CMOV: Yes
10:29:42 LOG: SSE: Yes
10:29:42 LOG:
10:29:42 LOG: * Memory...
10:29:42 LOG: Total physical memory: 7985 MB
10:29:42 LOG: Free physical memory: 1071 MB
10:29:42 LOG:
10:29:42 LOG: Loaded "/home/dawid/Steam/SteamApps/common/Serious Sam 3/Bin/ScriptLua.so".
10:29:42 LOG: Loaded "/home/dawid/Steam/SteamApps/common/Serious Sam 3/Bin/GameEnv_Steam.so".
10:29:42 INF: GameEnv API: Steam
10:29:42 INF: Encoded user ID = 34fad65c:12443137
10:29:42 LOG: Created thread -176977088(ResourceLoader).
10:29:42 LOG: Loading cvars from "$/home/dawid/Steam/userdata/2424664/41070/local/SeriousSam3.ini".
10:29:42 LOG: Loaded "libX11.so.6".
10:29:42 LOG: Loaded "libXi.so.6".
10:29:42 LOG: Loaded "libXrandr.so.2".
10:29:43 LOG: Display 0: DFP2 (1680x1050)
10:29:43 LOG: Trying to set display mode 1680x1050(fullscreen)...
10:29:43 INF:
10:29:43 INF: * Desktop settings...
10:29:43 INF: Color depth: 32-bit
10:29:43 INF: Desktop resolution: 1680 x 1050
10:29:43 LOG: Loaded "/home/dawid/Steam/SteamApps/common/Serious Sam 3/Bin/GfxOGL.so".
10:29:43 INF: Fullscreen on primary display
10:29:43 LOG: Loaded "libGL.so.1".
10:29:43 LOG: Loaded "libXxf86vm.so.1".
10:29:43 INF: Crash! (Segmentation fault)
Showing 1-3 of 3 comments
< >
keks  [developer] Feb 18, 2013 @ 1:50am 
Please delete ShaderCache from the game's temp directory. We contacted AMD about this problem and it will hopefully be fixed in a future driver release.
DawidR Feb 18, 2013 @ 6:03am 
it solved my problem. thank you :)
Thyriel Mar 19, 2013 @ 8:04am 
Had the same problem after replacing 12.10 running 13.2 Beta with 13.04 running 13.3 Beta.
Deleting ShaderCache solved it, thanks ;)
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Feb 18, 2013 @ 1:38am
Posts: 3