Beetlejuice Feb 2, 2013 @ 10:04pm
application has malfunctioned
Sam3.log


-------- START OF LOG --------

10:59:09 LOG: Core version: $Version: distro_Sam3_PC; SeriousSam3-Windows-Final; 174807 2012-12-20 11:35:37 @builder05; Win32-Static-Final-Default$
10:59:09 LOG: Command: $
10:59:09 LOG: Initializing timer.
10:59:09 LOG: Timestamp: 2013/02/03 10:59:07
10:59:09 LOG: Binary name: Sam3.exe
10:59:09 LOG: Binary soft path: Bin/
10:59:09 LOG: Binary hard path: F:\Program Files\Steam\steamapps\common\Serious Sam 3\Bin\
10:59:09 LOG: Application directory: F:\Program Files\Steam\steamapps\common\Serious Sam 3\
10:59:09 LOG: * OS...
10:59:09 LOG: Name: Windows XP
10:59:09 LOG: Kernel: WinNT (32-bit)
10:59:09 LOG: Version: 5.1, build 2600
10:59:09 LOG: Misc: Service Pack 3
10:59:09 LOG:
10:59:09 LOG: * CPU...
10:59:09 LOG: Vendor: GenuineIntel
10:59:09 LOG: Name: Intel(R) Core(TM)2 Duo CPU E7500 @ 2.93GHz
10:59:09 LOG: Type: 0, Family: 6, Model: 7, Stepping: 10
10:59:09 LOG: Clock: 2.94 GHz
10:59:09 LOG: Cores: 2
10:59:09 LOG: CMOV: Yes
10:59:09 LOG: SSE: Yes
10:59:09 LOG:
10:59:09 LOG: * Memory...
10:59:09 LOG: Total physical memory: 3071 MB
10:59:09 LOG: Free physical memory: 1746 MB
10:59:09 LOG:
10:59:09 LOG: Loaded "F:\Program Files\Steam\steamapps\common\Serious Sam 3\Bin\ScriptLua.dll".
10:59:09 LOG: Loaded "F:\Program Files\Steam\steamapps\common\Serious Sam 3\Bin\GameEnv_Steam.dll".
10:59:09 INF: GameEnv API: Steam
10:59:09 INF: Encoded user ID = 0addc650:4eb701f6
10:59:09 LOG: Error getting mixer source line info for microphone. Will not be able to control microphone.
10:59:09 LOG: Created thread 3888(ResourceLoader).
10:59:09 LOG: Loading cvars from "$F:/Program Files/Steam/userdata/36531622/41070/local/SeriousSam3.ini".
10:59:09 LOG: Skipped assigning to thr_iAffinityStrictness because the saved version (0) is different than the current version (2).
10:59:09 LOG: Trying to set display mode 1280x1024(fullscreen)...
10:59:10 LOG: 2013/02/03 10:59:10: Crashed! (used process memory: 170 MB, free system memory: 1708 MB)
10:59:10 ERR: sysStartProcess("F:\Program Files\Steam\steamapps\common\Serious Sam 3\Bin\BugReporter_Win32.exe") - 'Invalid argument'


____________________________________________________________________________

Sam3.rpt

//=====================================================
Report generated at: 02/03/13 10:59:10
Version: $Version: distro_Sam3_PC; SeriousSam3-Windows-Final; 174807 2012-12-20 11:35:37 @builder05; Win32-Static-Final-Default$
Build type: Win32-Static-Final-Default
Exception code: 80000004 SINGLE_STEP
Fault address:
00530E70 0001:0012FE70 "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe"

Dumping registers:
EAX:00010E00
EBX:0012FC6C
ECX:00040000
EDX:7C90E4F4
ESI:064D0A00
EDI:00000D28
CS:EIP:001B:00530E70
SS:ESP:0023:0012F9A0 EBP:0012FC10
DS:0023 ES:0023 FS:003B GS:0000
Flags:00200202

Dumping stack back trace:
00530E70 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:0012FE70
006AAA90 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:002A9A90
009FA64F 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:005F964F
00A17806 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:00616806
008EF922 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:004EE922
00B31E60 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:00730E60
00B32403 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:00731403
00B32A55 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:00731A55
00885B0C 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:00484B0C
00BB1B0B 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:007B0B0B
00451CDB 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:00050CDB
0064FE61 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:0024EE61
00AE9DCF 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:006E8DCF
00C93381 00000001 $adr: "$F:/Program Files/Steam/steamapps/common/Serious Sam 3/Bin/Sam3.exe" 0001:00892381

//=====================================================

Showing 1-15 of 23 comments
< >
ChrisW Feb 3, 2013 @ 2:05am 
If you have ZoneAlarm installed, try uninstalling the ZoneAlarm toolbar.
Beetlejuice Feb 3, 2013 @ 2:29am 
thnx, but i havn't zonealarm
AlenL  [developer] Feb 4, 2013 @ 1:44am 
Please see the FAQ thread. Look for ZoneAlarm there, you will find there are several other things similar to ZoneAlarm that can cause this. In all cases, this is some third-party low-level software installed on the machine, and that software introduces bugs in the way Windows kernel responds to the game's calls. Note that it doesn't have to be enabled at the moment. Merely having it installed will intercept system calls and can cause crashes.
Beetlejuice Feb 4, 2013 @ 6:33am 
looks like I have to re-install Windows?
AlenL  [developer] Feb 4, 2013 @ 11:39pm 
Well, if you have the time and will, that should most likely fix the problem. But if you know what kinds of low level software, like antiviruses, firewalls, USB limiting drivers etc, you have installed, and if you can cleanly uninstall it, it can go away without OS reinstall.
Beetlejuice Feb 5, 2013 @ 1:19am 
hmm...i have a standart Windows-firewall and Avast...
MavisSC Feb 20, 2013 @ 11:10pm 
I have the same problem, never had Zone alarm or any virus/firewall software on this computer. Using standard windows 8 firewall and Windows Defender.
Zephyr Feb 21, 2013 @ 1:00am 
The game worked fine yesterday when I first played it, now I'm having the same problem.
The game launches, but soon after launching, it makes an error noise and freeze, when I check the error box, it's the same application has malfunctioned thing.
I would appreciate a solution, and if possible a realist and understandable one.

Which means no "Just reinstall the game/windows and it should work fine", "Turn off your antivirus" or "Flash your bios, trust me, it will work!"
kompis Feb 21, 2013 @ 4:27am 
I have problem to Zephyr, I have played the game several times prior with the last time being last night and it worked perfectly fine. As of today it makes an error sound and freezes within several seconds of hitting the main menu. NOTHING has changed between now and last night when it worked perfectly fine.
Priest Feb 21, 2013 @ 5:03am 
Вчера, как и у многих, всё работало отлично, а сегодня игра крашится и выдаёт эту ошибку.
Появилось какое-то решение пролблемы?
AlenL  [developer] Feb 22, 2013 @ 12:54am 
MavisSC, Zephyr, kompis, Priest... I would like to ask you all to please post the Sam3.log and Sam3.rpt files, so we can examine them. Perhaps your problem is not the same as Zabadais.

Just to be clear, we didn't make any updates in the past few days. The last change in the releases was done on "Feb 12, 2013", which is ten days ago. So, the problem is certainly related to something else that has update in the mean time. It could be some system module in Windows, or some 3rd party software that is common to you all that can interact with the game - i.e. antivirus, or.... it might be that a Steam client update triggers some problem on some machines.

Btw, we don't have a policy of recommending "reinstall Windows" as a silver-bullet solution. We always try to find the actual cause of the problem and fix that. Sometimes, it _is_ "flash your BIOS", e.g. But this doesn't look like it. To know what it is, we need more data.

Thank you for understanding.
Zephyr Feb 22, 2013 @ 2:11am 
The game works fine again today. I don't know if it will stop working tomorrow or not, but in the meantime, it works. I didn't change anything, nor downloaded anything.

So I will put that on a Steam update of some sort. Better to be lucky than good, like the saying goes.

As for my previous comments, I'm just forum-wise. I've seen my part of all-made recipes to fix things, despite them being neither logical nor good.
Things I have seen in the past:
-The famous verify your game cache: For me, it has never fixed any problem on any game EVER.
-Reinstalling the game. Usually you will just redownload the same files, so it's moot. The only thing that seems to vary is the config file which in most games is created after the first launch where the game "adapt" to your configuration. And this is one thing that can go wrong and prevent you from launching the game again(often a resolution problem, but can also be linked to antialiasing and/or v-sync). A common cause of games not launching. Hence most of the time just making a backup copy of said file, and deleting it so the next time you launch you get a new one and allow you to modify things in game to avoid it happening again.
-Reinstalling windows. Honestly, reinstalling windows for one game is not worth it... And I would even say when one game is wrong, and the rest is fine, windows isn't the cause, the game is.
-Flashing the BIOS. I would never do that. Ever. Maybe if my computer was completly collapsing and nothing at all worked, I would consider it, but I would rather call specialists.

Well, at least that problem didn't make my graphic card overheat like Dead Island...(Dead Island still haven't fixed that issue, believe it or not...)
Lyon Loudsnake Feb 22, 2013 @ 3:12am 
The problem is caused by the "Enumerating Packages" on the titlescreen, it's cause crash when it's finished to "load" , for play withouth crash on title screen, you should turn your steam in "Offline mode" , but it's not due to your configuration. Waiting for a fix from the dev'.
Last edited by Lyon Loudsnake; Feb 22, 2013 @ 3:33am
Megafont Feb 22, 2013 @ 3:25am 
I tried your work around, Lyon and it works. I suspected the problem was the "Enumerating Packages..." thing happening on the main menu screen. Because if you sit on the menu screen, the "Enumerating Packages..." process never finishes before the game crashes.

I just tried running the game with steam in online mode again and the problem is gone. Running the game once with steam in offline mode seems to have solved the problem entirely :O
Last edited by Megafont; Feb 22, 2013 @ 3:28am
CxFx Feb 22, 2013 @ 6:20am 
Running in offline mode works, but it doesn't stop online mode from crashing with the same 'enumerating packages' message. At least for me.

Edit: Updating to the latest Nvidia drivers seems to have done the trick.
Last edited by CxFx; Feb 22, 2013 @ 6:50am
Showing 1-15 of 23 comments
< >
Per page: 15 30 50
Date Posted: Feb 2, 2013 @ 10:04pm
Posts: 23