Max Power Jan 18, 2013 @ 3:19pm
SS3 BFE on Ubuntu 12.04: slow performances and random slowdowns
Comparing with the windows version i have about the half of fps and random slowdowns (7-8 fps). I'm using the optimal settings automatically generated (everything high on linux and win).

Look the following screenshots:
http://steamcommunity.com/sharedfiles/filedetails/?id=121230818
http://steamcommunity.com/sharedfiles/filedetails/?id=121236388

26.4 vs 77 fps

http://steamcommunity.com/sharedfiles/filedetails/?id=121230004
http://steamcommunity.com/sharedfiles/filedetails/?id=121236049

25.3 vs 45 fps

Slowdown:
http://steamcommunity.com/sharedfiles/filedetails/?id=121230322

System information by steam:
Informazioni sul processore:
Produttore: AuthenticAMD
Velocità: 2800 MHz
Processori logici 3
Processori fisici 3
HyperThreading: Non supportato
FCMOV: Supportato
SSE2: Supportato
SSE3: Supportato
SSSE3: Supportato
SSE4a: Supportato
SSE41: Non supportato
SSE42: Non supportato

Informazioni sulla rete:
Velocità rete:

Versione di Windows:
Ubuntu 12.04.1 LTS (64 bit)
Nome del kernel: Linux
Versione del kernel: 3.2.0-36-generic
Produttore dell'X Server: The X.Org Foundation
Versione dell'X Server: 11103000

Scheda video:
Driver: ATI Technologies Inc. AMD Radeon HD 6800 Series

Versione driver: 4.2.12002 Compatibility Profile Context 9.012
Intensità colore desktop: 24 bit per pixel
Frequenza di aggiornamento del monitor: 59 Hz
VendorID: 0x1002
DeviceID: 0x6739
Numero di monitor: 1
Numero di schede video logiche: 1
Risoluzione visualizzazione primaria: 1680 x 1050
Risoluzione desktop: 1680 x 1050
Dimensioni visualizzazione primaria: 18,07" x 11,65" (21,50" diag)
45,9cm x 29,6cm (54,6cm diag)
VRAM primaria non rilevata

Scheda audio:
Periferica audio: VIA VT1708S

Memoria:
RAM: 3954 Mb

Varie:
Lingua IU: Italiano
LANG: it_IT.UTF-8
Microfono: Not set
Spazio totale disponibile su disco rigido: 295293 Mb
Blocco libero più ampio del disco rigido: 158882 Mb

I'm using the last catalyst driver 13.1 but nothing has changed comparing it with the previous 12.10. CPU governor setted on performance.
CPU: amd x3 720. GPU: radeon hd 6850. OS: ubuntu 12.04.1 with everything up to date.
I'm using the public beta (on linux and win)
Last edited by Max Power; Jan 18, 2013 @ 3:27pm
Showing 1-10 of 10 comments
< >
Max Power Jan 18, 2013 @ 3:24pm 
Last edited by Max Power; Jan 18, 2013 @ 3:24pm
AlenL  [developer] Jan 19, 2013 @ 1:30am 
Linux is still slower than Windows in rendering at high GPU loads, especially on ATI, as the driver needs more work. Then part with 26 vs 47 sounds realistic. (I guess your 77 is a typo?)

For the random slowdowns, we would need more info.
Cheogh Jan 19, 2013 @ 4:03am 
Do you have a gamepad plugged? Try without it.
Last edited by Cheogh; Jan 19, 2013 @ 4:15am
Max Power Jan 19, 2013 @ 4:45am 
I don't have a gamepad plugged and no, 77 isn't a typo (watch the screenshot: http://steamcommunity.com/sharedfiles/filedetails/?id=121236388).

Ok, so there is nothing else to do? Playing on linux, even lowering grafical details, it's far to be a good experience on my system (considering the slowdowns too :( ).

Originally posted by AlenL:
For the random slowdowns, we would need more info.
What info do you need? Maybe, i can help..
Last edited by Max Power; Jan 19, 2013 @ 4:46am
Shell Jan 19, 2013 @ 1:34pm 
i have same problem, but my system differs.

Processor intel i5-2500K 3,3GHz
Linux Mint 14 Nadia (64 bit). Cinammon. X Server: 11300000
GeForce GTX 560 1Gb
Driver version 4.3.0 NVIDIA 310.14 (not the latest beta)
DDR3 8Gb

Playing 1920x1080 Ultra settings (auto suggested)
I don't watch on fps, but sometimes it falls very much. My eye can recognize 1-3 seconds slowdown with about < 25 fps (~15 i think)

Also have problem with steam overlay, but maybe that's steam problems.
When i press to show it - it appears for a short time(less then a second) and then only black screen left. Maybe overlay is crashing (but on TF2 and Killing Floor works). For example on Windows, when overlay crashes it returns control for a game and here nothing is happening, on black screen only alt+f4 helps...
Cheogh Jan 19, 2013 @ 8:27pm 
I was getting 20-30 FPS on the auto high, when I switch to medium it went up to 60. Have you tryied to lowering the settings?
SandM1tch Jan 22, 2013 @ 8:34am 
My game only gets to the main menu and once i start up Summer of Cairo (new single player game), it freezes to a white screen (looking up at the sun) and i have to alt+tab out and end the window.

It might be that im using a quadro NVS notebook GPU (Nvidia Quadro NVS 5100m) but im using the latest 310.90 performance driver for Linux 64-bit (Ubuntu 12.04 LTS) and the cpu is a Core i5 M 540 at 2.53 Ghz with HT enabled.
AlenL  [developer] Jan 23, 2013 @ 7:14am 
When it freezes, does the Esc key work to invoke the menu? Does F1 invoke the console?
Padster Jan 25, 2013 @ 10:34am 
I get ~20-28 fps on Ubuntu 12.10 with Nvidia drivers, and ~23-35 fps on Windows 8.

Intel Core 2 Duo @ 2.2 GHz
4 GB DDR3
GT610 1GB
Koli Jan 28, 2013 @ 2:30am 
I'm getting sudden pauses as if the game is caching things - it happens in newly visible areas. I don't get FPS problems but that may be because I'm using Kubuntu 12.10 and have told KWin (the window manager) to disable compositing when something goes fullscreen.

AMD Phenom II X4 @ 3.4GHz
16GB DDR3 RAM
NVIDIA GTX560 Ti 1GB (driver 313.18)
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Jan 18, 2013 @ 3:19pm
Posts: 10