Serious Sam 3: BFE
Jittery Rat Dec 10, 2012 @ 7:52pm
Won't load after launch
After I launch the game, I get the initial loading screen with the loading icon in the lower left corner, however after leaving it for several minutes, the game does not go any further.

I have tried verifying the files through steam, checking the security certificate and disabling my antivirus/firewall, none of which has worked. Have also tried finding other solutions, however others that have had this issue don't seem to have gotten a fix for it.

My system specs are more than enough to run it and not sure what else to try at this point

AMD Fx-6100 Six core 3.3GHz
16Gb ram
AMD Radeon HD 6850

Edit: Should have also said that I'm running Windows 7 64-bit
Last edited by Jittery Rat; Dec 11, 2012 @ 2:07am
< >
Showing 1-2 of 2 comments
AlenL  [developer] Dec 11, 2012 @ 4:23am 
Seems like that is a Bulldozer CPU. You will need a BIOS update.
Jittery Rat Dec 11, 2012 @ 3:39pm 
That did the trick, cheers.
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Date Posted: Dec 10, 2012 @ 7:52pm
Posts: 2