John Noob doesn´t play ranked Dec 9, 2012 @ 5:51am
Is my ATI-Linux-Driver too old?
I am trying to play SS3 under SteamBeta for Linux. The game try to begin but no window or full-window is achieved.

Reading the log, only feel worried about that lines:

"14:27:40 LOG: Processing file Content/SeriousSam3/Config/CheckDriver.lua
14:27:40 INF: Driver version: 11627 (required: 11900)
14:27:40 WRN: Display driver is too old, please update it ASAP!
14:27:40 INF: SysMessage: Display driver is too old or version cannot be determined.
14:27:40 INF: Press OK to update driver, or Cancel to continue.
14:27:40 LOG: Trying to set display mode 1366x768(fullscreen)...
14:27:40 LOG: Loaded "/home/baltar/.local/share/Steam/SteamApps/common/Serious Sam 3/Bin/GfxOGL.so".
14:27:40 INF: Fullscreen on primary display
14:27:40 LOG: Loaded "libGL.so.1"."

I'm using a Mobility Radeon HD4330 with Catalyst-legacy aka 12.6. Team Fortress 2 doesn't work with this fully-♥♥♥♥-drivers, so I'm not afraid (I can play this games under windows)... xD Some advice?
Showing 1-4 of 4 comments
< >
Xpander Dec 9, 2012 @ 6:43am 
im afraid u have to wait a little until AMD releases new legacy driver for cards below HD5xxx series
John Noob doesn´t play ranked Dec 9, 2012 @ 6:51am 
I´m mentally prepare :D I have luck that Trine2 works on linux and I´m installing this awesome SS3 under Windows :D
DEN [CT]  [developer] Dec 10, 2012 @ 4:28am 
Apart from you GPU being treated as "legacy" by AMD, currently all AMD drivers are "too old" for SS3. That's because AMD/ATI still have several pending bugs to fix in their drivers in order for Sam3 to run fine.
(Sorry for bad news.) :(
John Noob doesn´t play ranked Dec 10, 2012 @ 7:17am 
yep, I always try to not cut myself for purchase a laptop with ati... happy with Nvidia9800GT on desktop :D
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Dec 9, 2012 @ 5:51am
Posts: 4