rubregg Nov 29, 2012 @ 5:17pm
[linux] Dedicated Server - version mismatch - how to update?
I finally got the Sam3 dedicated server running on my linux box, but when I try to connect to it I'm getting a version mismatch error. Checking the log suggests the server is still version 154741:
LOG: Core version: $Version: distro_Sam3_PC; SeriousSam3_Executables-Linux-Final; 154741 2012-05-09 10:38:00 @builderl02; Linux-Static-Final-DedServer$

I was wondering how I can get the dedicated server updated.

Have tried
./steam -command update -game "SeriousSam3-linux" -dir [sam3-path]
but this only gets me to version 154741 apparently.

System is openSuse 12.2 i586 / steam GUI not installed / dedicated server installed via hldsupdatetool.
Last edited by rubregg; Nov 29, 2012 @ 5:19pm
Showing 1-15 of 18 comments
< >
rami.cz Dec 6, 2012 @ 5:03pm 
same prob here!!
rami.cz Dec 7, 2012 @ 4:27pm 
cmon guys! no idea?!
AlenL  [developer] Dec 8, 2012 @ 7:21am 
Sorry for the delay guys. Meant to reply to this originally, but skipped it accidentally.

Don't use the hldsupdatetool, that's obsolete. You must use the new "SteamPipe" system.
Last edited by AlenL; Dec 8, 2012 @ 7:21am
rubregg Dec 10, 2012 @ 8:01am 
Thanks for the reply, AlenL. Will try this out and report back.
AlenL  [developer] Dec 10, 2012 @ 8:11am 
Almost forgot.... the appid for SS3 dedicated server is 41080
rubregg Dec 10, 2012 @ 12:28pm 
Edit:
All is working now, thanks again for the help.
Last edited by rubregg; Dec 10, 2012 @ 1:56pm
rami.cz Dec 12, 2012 @ 3:15pm 
For me not :(
I´ve just updated the game and when I want run a server it fails and in the terminal I see something like this


en (SIGABRT) (core dumped [obraz pamÄi uloĹžen]) ./Sam3_DedicatedServer "$@"

Thanks for any ideas

EDIT1: I tried to rewrite files in "Content/SeriousSam3/" to lowercase (the folders Content and SeriousSam3 as well) but still getting the same error
Last edited by rami.cz; Dec 12, 2012 @ 4:21pm
rubregg Dec 12, 2012 @ 9:06pm 
@rami
Which distro are you using? 32bit or 64bit? On my openSuse (12.2 - i586) I did not need to change any file/folder names to lower case (and I was wondering if I had to).

Edit:
I just noticed you said you updated the game. I'm not sure if this makes a difference, but I did not update, I did a clean and complete reinstall.
Last edited by rubregg; Dec 12, 2012 @ 9:09pm
rami.cz Dec 13, 2012 @ 12:12am 
@rubregg
Ubuntu server 12.04 LTS 64b. Yep everything is installed (libs, lin32 etc...)

Yeah after my unsuccessful update I did complete reinstall as well. It´s strange but the error shows again :(

Take a look at this kind of error in terminal "./Sam3_DedicatedServer "$@"" - its like wrong argument count or ST like that...

I run the server with these commands "./runSam3_DedicatedServer.sh +exec servercfgfile"
rubregg Dec 13, 2012 @ 2:06am 
@rami
Have you tried absolute paths?
./[path]/[to]/runSam3_DedicatedServer.sh +exec /[path]/[to]/[configfile]
Other than that I'm at my wit's end here, sry. :/
Last edited by rubregg; Dec 13, 2012 @ 2:06am
AlenL  [developer] Dec 14, 2012 @ 2:03am 
Are you running the dedicated server updated from the Steam client? If you are using betas, make sure server and game are in the same beta.

Otherwise try using the above to download the server in a separate directory from the game and main steam.
rami.cz Dec 15, 2012 @ 4:00pm 
Still got the error :(
rami.cz Dec 23, 2012 @ 10:46am 
Hey guys,

I´m really desperate!

@AlenL: I tried and doesnt work. Still got the error...


When I run ss3:
$ ./runSam3_DedicatedServer.sh +port free_port


And this is what I get on the terminal:
LOG: Loaded "/path_to_ss3/ss3/Bin/GameEnv_Steam.so".
INF: GameEnv API: Steam
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 41070
LOG: Loaded "/path_to_ss3/ss3/Bin/SeriousSam3_Project.so".
LOG: Content/SeriousSam3/All_147686.gro: 835 files, signature: OFFICIAL
LOG: Content/SeriousSam3/All_170136.gro: 703 files, signature: OFFICIAL
LOG: Content/SeriousSam3/CachedShaders_PC.gro: 4277 files, signature: OFFICIAL
LOG: Content/SeriousSam3/All_173936.gro: 95 files, signature: OFFICIAL
LOG: Content/SeriousSam3/All_02.gro: 5133 files, signature: OFFICIAL
LOG: Content/SeriousSam3/All_01.gro: 6414 files, signature: OFFICIAL
LOG: Content/SeriousSam3/All_150406.gro: 627 files, signature: OFFICIAL
LOG: Content/SeriousSam3/All_145562.gro: 2565 files, signature: OFFICIAL
WRN: Invalid locale string.
WRN: Invalid locale string. en (SIGABRT) (core dumped [obraz pamÄi uloĹžen]) ./Sam3_DedicatedServer "$@"


Pls gimme some hints!
Last edited by rami.cz; Dec 23, 2012 @ 10:47am
rubregg Dec 23, 2012 @ 10:55am 
Originally posted by =GMR=rami.cz:
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Setting breakpad minidump AppID = 41070
My log looks like yours except for the lines I quoted. Maybe the server doesn't find your steam files for some reason?

Edit - Correction:
Sorry, wrong info. I just checked and while I don't have these lines in the log, they are there in the console output (which I usually don't see, I've added "&" to my command line).
Last edited by rubregg; Dec 23, 2012 @ 7:08pm
rami.cz Dec 24, 2012 @ 3:33am 
@rubregg: Thank you for reply! Is there a file where I set the path to the steam dir? Or create a file where I set AppID ? Im really desperate, man :(
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Nov 29, 2012 @ 5:17pm
Posts: 18